Graphical tearing in Boot Camp on 3.06Ghz iMac.

Discussion in 'Windows, Linux & Others on the Mac' started by Tsurisuto, May 26, 2008.

  1. Tsurisuto macrumors 6502

    Joined:
    Jun 13, 2007
    #1
    I'm running Vista x64 in Boot Camp on my new 3.06Ghz iMac with 4GB RAM. I have noticed that if I grab any window and shake it around the screen, I get graphical tearing. I am running the latest Boot Camp Drivers (2.1) and have hardly any software installed on the Windows side.

    The problem has become particularly annoying when playing games, especially FPSs, as every time I turn side to side the screen tears.

    As the problem happens only in the Windows side, I'm assuming that the issue is most likely with the NVidia graphics drivers?

    Does anyone on these boards have the same issue with Vista x64 on the new iMacs?

    Any help would be appreciated.
     
  2. MacsRgr8 macrumors 604

    MacsRgr8

    Joined:
    Sep 8, 2002
    Location:
    The Netherlands
    #2
    Have you tried updating the grfx drivers from nVidia's site?

    nVidia has just updated them.
     
  3. Tsurisuto thread starter macrumors 6502

    Joined:
    Jun 13, 2007
    #3
    I ran a scan on NVidia's website last night and was told that my drivers were up to date. I tried to manually download the drivers from the NVidia site, but they wouldn't install. It said that my machine doesn't meet the required hardware.

    I have a Geforce 8800 GS, with drivers at 167.xx. Does anyone have anything different?
     
  4. Draeconis macrumors 6502a

    Joined:
    May 6, 2008
  5. Tsurisuto thread starter macrumors 6502

    Joined:
    Jun 13, 2007
    #5
    Where would I get them from? The only M drivers NVidia have, seem to be for the 8700GT!
     

    Attached Files:

  6. GreyMatta macrumors regular

    Joined:
    Jul 29, 2007
    Location:
    England
    #6
    I believe iMacs use laptop video cards so try

    www.laptopvideo2go.com

    that where I get mine for my MacBook Pro. I use the Forceware 175.75s and get no tearing at all
     
  7. Tsurisuto thread starter macrumors 6502

    Joined:
    Jun 13, 2007
    #7
    Thank you. Do you know if it is compatible with Vista x64 SP1?
     
  8. Infrared macrumors 68000

    Infrared

    Joined:
    Mar 28, 2007
    #8
    Have you tried enabling vsync?

    http://en.wikipedia.org/wiki/Vertical_synchronization
     
  9. Tsurisuto thread starter macrumors 6502

    Joined:
    Jun 13, 2007
    #9
    Thank you, that was a very good suggestion, but unfortunately it did not help. :(

    I am hoping that someone of these boards is kind enough to advise me on how to upgrade my drivers, and which one to use, etc. for the 8800GS and Windows Vista x64.
     
  10. GreyMatta macrumors regular

    Joined:
    Jul 29, 2007
    Location:
    England
    #10
    go here http://www.laptopvideo2go.com/forum/index.php?showtopic=18721

    and make sure that you download the driver and the modded inf file from the links at the top of the page.

    when you have both files extract the driver from its self extracting archive and then add the inf file to the folder before clicking on the setup.exe in the folder.

    hope that helps :)
     
  11. Tsurisuto thread starter macrumors 6502

    Joined:
    Jun 13, 2007
    #11
    You guys are great! I did what you said, and it installed without a hitch, but in the Control Panel it still says I am running Forceware 167.63, and I still get the screen tearing. :(

    Should I uninstall the NVidia drivers first, and then try again?
     
  12. Tsurisuto thread starter macrumors 6502

    Joined:
    Jun 13, 2007
    #12
    So I thought I would try unistalling the NVidia drivers first, and then install the ones from the Laptop2go site. It seemed to uninstall and install perfectly, but now the resolution is very low and I don't have an NVidia control panel. Any help would be greatly appreciated.
     
  13. Chrisl369 macrumors newbie

    Joined:
    May 31, 2008
    #13
    Boot Camp on 3.06 iMac

    I am trying to get Vista x64 in Boot Camp running on my daughter's 3.06 iMac and get the message 'not supported on this Mac'. I have downloaded the 2.1drivers but the file wil not run to install. I just wondered if you did anything special to get it working on your machine. Apple are no help as they say x64 is not supported on the iMac.

    Thank you
    Chris
     
  14. Tsurisuto thread starter macrumors 6502

    Joined:
    Jun 13, 2007
    #14
    I had to download the 2.01 Boot Camp drivers from a Torrent site and install them first, then upgraded to 2.1.

    Let me know if you can't find them, and i'll email them to you.
     
  15. Chrisl369 macrumors newbie

    Joined:
    May 31, 2008
    #15
    Thank you Tsurisuto,
    My son has the latest Mac Pro and I will get the drivers from his restore disks.

    I give it a try and see how it goes.

    Chris
     
  16. Chrisl369 macrumors newbie

    Joined:
    May 31, 2008
    #16
    GeForce 8800 GS drivers

    Tsurisuto,

    Thank you again I managed to get the files from the Mac Pro disks and updated the Boot Camp. One other thing, when I looked in the device manager the 8800 was not listed. Do I need to install seperate drivers? If so where do you find them and how do you instal them?

    Thank you
    Chris
     
  17. Tsurisuto thread starter macrumors 6502

    Joined:
    Jun 13, 2007
    #17
    Yes you do. Navigate to the Boot Camp folder on the Leopard DVD. Inside find the NVidia folder and then select and install the Mobile drivers.

    let me know if you get the tearing issue too?
     
  18. Chrisl369 macrumors newbie

    Joined:
    May 31, 2008
    #18
    Hi,
    By the time I got home today my son had already done the Laptopvideo and ini file thing and it is working great. According to him the Vista experience index shows just below his Mac Pro with the 8800GT. My son, Justin, has asked what programs are you getting the graphical tearing with?
    Thanks
    Chris
     
  19. Tsurisuto thread starter macrumors 6502

    Joined:
    Jun 13, 2007
    #19
    I get it in all windows. Just open Internet Explorer and shake the window left and right and see if you get any tearing?

    Also I would be grateful if you could let me know which drivers your son used from LaptopVideo?
     
  20. Chrisl369 macrumors newbie

    Joined:
    May 31, 2008
    #20
    Hi Tsurisuto,
    My son has said he installed 169.12 with the modified .ini file. My daughter has not had any problems so far with the various games etc. Hope this helps.

    Regards
    Chris
     
  21. SneakerFreak macrumors member

    Joined:
    Sep 19, 2007
    #21
    Could you point me to the modded ini file please - do you just copy it over the one in the 169.12 folder and run setup ?
     
  22. Tsurisuto thread starter macrumors 6502

    Joined:
    Jun 13, 2007
    #22
    Thank you. I opted to go for the 174.xx drivers instead. I have finally fixed the problem of tearing in games, but not on the desktop.
     

Share This Page