Graphics Corruption?

Discussion in 'MacBook Air' started by ayeying, May 4, 2009.

  1. ayeying macrumors 601

    ayeying

    Joined:
    Dec 5, 2007
    Location:
    Yay Area, CA
    #1
    I've been seeing many of these lately but only in full screen images on websites. I have it both on Safari and Firefox but I'm not sure what it really is. I thought it was the problem with the X3100 but it would appear on everything not just website full screen images. Has anyone have any clue on what it could be?

    Here's a screenshot.
     

    Attached Files:

  2. n0de macrumors 6502

    Joined:
    Feb 3, 2005
    #2
    Are you connected to an external monitor?

    If not, when this happens, is you laptop still or on your lap where the screen may be moving a bit?

    Generally I have seen this kind of thing when the LCD controller is bad or the cable is loose.

    If you are getting this on your laptop screen try everything you can think of to replicate it reliably because that is what you will have to do in front of a Genius to get it fixed else you end up getting it back with a note saying they couldn't find a problem.
     
  3. zedsdead macrumors 68040

    Joined:
    Jun 20, 2007
    #3
    I had something similar happen, but with thin black lines. I agree with the post above, make sure you can replicate it in front of the genius. They likely will replace the motherboard.
     
  4. ayeying thread starter macrumors 601

    ayeying

    Joined:
    Dec 5, 2007
    Location:
    Yay Area, CA
    #4
    No, I'm using the internal monitor. It happens no matter where the laptop is, stationary or moving. I haven't seen this problem on a loose cable but bad LCD controller maybe. The problem is very easily replicated. At first I thought the northbridge chip could've been overheating but even on a cold boot system it happens.

    I'm thinking about taking it to the genius bar as soon as classes are over next week. I was hoping its a simple software problem that can be solved on my own.
     

Share This Page