Graphics Glitch? Snow Leopard.

Discussion in 'macOS' started by Macmaniac411, Mar 8, 2010.

  1. Macmaniac411 macrumors member

    Joined:
    Mar 8, 2010
    #1
    So for about a week or two now i have been experiencing this glitches that seem to come around after the computer has been on for more than 2 or 3 hours. I have noticed restarting the machine will get rid of them. I have a 2.4ghz MacBook with 2 gigs or ram from early 2008. I am running Snow Leopard 10.6.2

    Does anyone know how to fix this? I think it might be a messed up graphics card, but i don't have much of a clue.

    I have noticed when trying to take a selected screen shot over the dock the glitches will go away, but they only happen on the dock, wallpaper, and window shadows, they are also random every time.
     

    Attached Files:

  2. kolax macrumors G3

    Joined:
    Mar 20, 2007
  3. Macmaniac411 thread starter macrumors member

    Joined:
    Mar 8, 2010
  4. Jolly Jimmy macrumors 65816

    Jolly Jimmy

    Joined:
    Dec 13, 2007
    #4
    Other people are suffering similar issues.

    http://forums.macrumors.com/showthread.php?t=865797

    My macbook has the X3100 graphics chip like yours, and the errors I'm getting look just like the ones in your screenshots.

    Hopefully 10.6.3 will have updated drivers to address the glitches.
     
  5. Macmaniac411 thread starter macrumors member

    Joined:
    Mar 8, 2010
    #5
    ok, im glad im not just the only one and that it should be software related, the last thing i want to do is fix it or buy a new mac, thanks for your input
     
  6. Prospekt macrumors regular

    Joined:
    Jul 5, 2009
    #6
    Same exact macbook, same exact software, same exact problem.
     

Share This Page