Gray screen, need help

Discussion in 'MacBook' started by chrisj, Aug 10, 2008.

  1. chrisj macrumors newbie

    Joined:
    Aug 10, 2008
    #1
    Have a year old macbook and out of nowhere the screen stays gray with blinking file folder picture with question mark on it. Can anyone help?
     
  2. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #2
    try booting into your first install disk and repairing your disk using Disk Utility and then selecting your hard drive in Startup Disk.

    if you dont have your install disc reboot your mac and hold C. then at the prompt type "fsck -fy" and wait till your disk is repaired. continue until to fsck until it is "OK". then type "reboot".
     
  3. iLEZ macrumors newbie

    iLEZ

    Joined:
    Apr 19, 2006
    Location:
    Sweden
    #3
    Hello!
    I have the same problem, except that my keyboard stopped working just when the flashing hard-drive-icon problem appeared.
    Coincidence? Can a failing HDD really cause the kbd to stop working?

    Oh! And my battery died (after two years and one batt-replacement), so i have been shutting my MB off frequently by closing the lid and yanking the magsafe-chord after a few moments, so an incorrect power-down could very well be the cause of the failing HDD, i know that. Would i be better off replacing the top (kbd, mouse, plastic) of the MB? I'm already on my second top, and this one has a crack and a hole in it... I know, i know, i bring my MB with me everywhere, and it has seen some rough rides. ;)
     
  4. jm4bcst1 macrumors newbie

    Joined:
    Oct 19, 2007
    #4
    I tried this but there is no activity, just the grey screen with flashing question mark folder. I also tried holding the option button when starting up and doing this got me a cursor on the screen that will move and all just nothing to move to or click on.

    Does anyone know what's going on? I really need some help, I'm overseas without my Startup Discs, is there anyway to figure this out without them?
     
  5. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #5
    Can you get your hands on some startup disks? If so, boot from them and try an Archive & Install. In the meantime, does fsck work for you? richthomas had the process half right, but boot the computer (without the startup disks) whilst holding COMMAND-S to get into Single User Mode, from where you can try fsck. :)
     
  6. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #6
    sorry reboot your Mac and hold "command+S" to enter Single User Mode then type "fsck -fy". EDIT: beat me to it! ;)

    also try resetting your PRAM by holding "command+option+P+R" on startup.
     
  7. PandaRevolution macrumors newbie

    Joined:
    Jul 18, 2008
    #7
    I have the same thing going on. I was given a ibook G4 by a friend. She told me she couldn't fix it. I have my old tiger disks but they wont work for some reason. So I tried to do all the things that were mentioned above.. Still no luck!
    I tried to put in my leopard disk and got pretty far but it told me that there wasn't enough ram to run leopard. So I think my next option will be to buy a new stick of ram and try that... Unless you guys have anymore ideas?

    Thanks
     

Share This Page