Great just when i thought my mbp was perfect..

Discussion in 'MacBook Pro' started by SchneiderMan, Oct 24, 2008.

  1. SchneiderMan macrumors G3

    SchneiderMan

    Joined:
    May 25, 2008
    Location:
    Apple state
    #1
    It has the Hd/battery cover problem,
    Its not really bad but it moves a little out of place and it has a spot where its not flush with the case, i didnt open it before too. i did try to fix it but to no avail.. so ill call apple tomorrow and see what they will do, i dont want to send it back.
     
  2. Nate025 macrumors regular

    Joined:
    Oct 18, 2008
    #2
    Yeah I'll be ringing right along with you. Same problem here. It's really not bad at all, but if they're willing to front me a new cover, cool. I have the multi light leak at the bottom of my screen as well, but it's also not that bad and isn't much of a bother. Other than that, so far so good. :)
     
  3. SchneiderMan thread starter macrumors G3

    SchneiderMan

    Joined:
    May 25, 2008
    Location:
    Apple state
    #3
    whats that multi light leak thing?

    and it kinda is a problems because dust a other things can get inside the mbp
     
  4. J the Ninja macrumors 68000

    Joined:
    Jul 14, 2008
    #4
    Your hard drive is sealed, dust won't hurt it. Dust is already going to get into the inside cavity. If that was airtight, the machine would overheat.

    Mine's a little loose as well (although not as much as some I've seen pics/vids of), but I really don't care. I don't see how it affects the machine at all, let alone enough to justify the hassle of a exchange/RMA.
     
  5. SchneiderMan thread starter macrumors G3

    SchneiderMan

    Joined:
    May 25, 2008
    Location:
    Apple state
    #5
    i only want to get a new cover, not a new mbp.. and a little thing like that still bothers me for the $$$$ i spent :D
     
  6. Nate025 macrumors regular

    Joined:
    Oct 18, 2008
    #6
    It appears as a series of white lights shining upwards, left to right, on the bottom of the screen about a half inch upwards. It's just barely visible and only on a black-lit screen. There are pictures somewhere around the board, I forget what thread.

    No there isn't a hazardous chance of dust getting in there, it's just a visible design flaw with the screen. A minor one, at that: I only noticed it because the system was rebooting for Vista. Like I said, it's hardly visible but there nonetheless. If it ever did become an issue, well Applecare's just a phone call away. :)

    Cheers.
     
  7. SchneiderMan thread starter macrumors G3

    SchneiderMan

    Joined:
    May 25, 2008
    Location:
    Apple state
    #7
    when i pick my mbp up the lid slides all the time and it makes a bad click noise, i think it will soon break off..
     
  8. nonick macrumors member

    Joined:
    Sep 4, 2008
    #8
    hi,
    i tried to find some pictures/videos showing the battery lid problem, but there are no pictures on flickr and no videos on youtube about this.
    could anyone post a link please?
     
  9. Chronocento macrumors newbie

    Chronocento

    Joined:
    Jan 15, 2008
    Location:
    Messina, Italy
    #9
    Hi, go here and read posts #137, #142 and #143, and you should fix your problem :)
     
  10. SchneiderMan thread starter macrumors G3

    SchneiderMan

    Joined:
    May 25, 2008
    Location:
    Apple state
    #10
    i called apple today but they didnt help me, they said they cant ship me a new battery cover. now i need to go and see if the apple store has some parts great :mad:
     
  11. J the Ninja macrumors 68000

    Joined:
    Jul 14, 2008
    #11

    No, go do the method posted above. I did it this morning to my machine, the cover doesn't budge in any direction now. It appears to be caused by the clips on the back not stretching out far enough to brace the back of the cover. Just bend them outward a tiny bit (you may not see them move, just give them some solid pressure), and you'll be good.
     
  12. tekmoe macrumors 68000

    Joined:
    Feb 12, 2005
    #12
    Yup, did the same thing to mine. It doesn't move at all now.
     

Share This Page