Great - USB HUBs don't work in Leopard!?

Discussion in 'macOS' started by mavis, Oct 27, 2007.

  1. mavis macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #1
    Well, this explains a lot. I have a powered USB hub that is about the same age as my new iMac (I bought it because I knew the iMac had a shortage of USB ports) and it has been just fine under Tiger, but now I'm finding it doesn't work at all in Leopard. No wonder I couldn't import video from my HDR-SR1! :mad:

    Any ideas on how to get this working? Like I said, it worked just fine in Tiger ...
     
  2. elmo151 Guest

    Joined:
    Jul 3, 2007
    Location:
    NYC
    #2
    I have a Belkin hub that is working. I did unplug the hub when I did my install. Perhaps that is what avoided your problem
     
  3. Maui macrumors 6502a

    Maui

    Joined:
    May 18, 2007
    #3
    I have 3 hubs (2 powered, 1 not) that worked after the upgrade without me doing anything to them. Have you recycled everything -- unplug, reboot, then plug it all back in?
     
  4. bilbo--baggins macrumors 6502a

    Joined:
    Jan 6, 2006
    Location:
    UK
    #4
    My Belkin USB hub/media reader combo worked fine with everything in Tiger, but since Leopard I find that most things don't work when plugged into it. The D-link USB bluetooth dongle and the iPhone dual dock (for bluetooth headset and iPhone) are 2 examples of items that did work in Tiger with this hub and don't work in Leopard. The PowerMac G5 only has 3 built in ports, and I don't have enough for the devices that don't work with the hub. Very annoying.
     
  5. bilbo--baggins macrumors 6502a

    Joined:
    Jan 6, 2006
    Location:
    UK
    #5
    I've just bought a Kensington 7-port USB 2.0 hub, and now the D-link BDT-120 B3 and the iPhone dual dock both work - but within an hour (a co-incidence that Time Machine backs up every hour?) I had a total system freeze - twice. I then tried unplugging the D-link and plugging it into the front USB port on the G5 and haven't had a crash (been running for about 6 hours now).

    For me, this hub seems fine except for the D-link causing a system freeze when plugged into the hub.

    I'd be interested to hear if anyone is using any other bluetooth dongles plugged into a USB hub. Preferably I'd like to get a Bluetooth 2.0 + EDR dongle - but I'm reluctant to buy one as I just end up wasting too much time and money trying various products until I find something that works reliably.

    It's quite annoying really that the Belkin 3-port hub/15-in-1 media reader doesn't work properly in Leopard. I spent ages trying out various USB 2.0 PCI cards a couple of years ago, ended up selling or returning them all because of issues. At the time lots of people stated that they were using USB hubs instead and so I settled on the Belkin device, and had no problems - until Leopard came along. Now it's all started again...
     
  6. durija macrumors 6502

    Joined:
    Jan 16, 2008
    Location:
    Seattle
    #6
    Similar problems...I bought a little D-link, 4-port, powered hub for my iMac. I can't run my printers through it, or my flash drive, or my camera interface. I can run my synthesizer for some odd reason. No amount of plugging-unplugging-rebooting seems to have any effect.

    I am really interested to hear of a hub that has worked nicely with my configuration (see signature). Or anybody's configuration, running 10.5.2.
     
  7. Palladium macrumors member

    Joined:
    Jan 2, 2006
    Location:
    Northern Ireland, UK
    #7
    I'm sorry to read of peoples' misfortunes. I just want to report that I have a Belkin 7-port powered USB2 hub and a Belkin card reader (which reads an incredible number of cards). I have been using these for some time with my 1st generation MacBook running various versions of Tiger 10.4. About a month ago, I fitted a larger hard drive and took the opportunity to upgrade to leopard. I did a fresh install on the new drive with nothing else connected except an external hard drive . I used Migration assistant to port things over from the external drive. I'm very happy to report that I have had only one (minor) problem and the hub and card reader continue to function perfectly. The one problem is that Airport does not pick up my WiFi signal every time the computer wakes from sleep but that is an old story, not relevant to this thread!
     
  8. SeasonedOne macrumors newbie

    Joined:
    Jun 7, 2008
    #8
    Solution to USB HUB problem for me

    I had the same problem. Check your USB cables.

    I have a MacBook with a Belkin 7 port USB hub and after upgrading to Leopard suddenly my scanner wouldn't work when connected to the hub. The hub is powered and new so that wasn't the problem. I finally decided to write to Belkin and while writing down the details I realized that the items that did work were attached to the hub via new good [belkin] usb cables and the ones that didn't were using their much older original equipment USB cables. I tested my theory with an extra new cable I had around (so the original load on the hub was the same) and it worked!

    Now why it worked with the cables before and not now I'm not sure. One other thing that was different was that I have a new Macbook and I don't have the old one to test anymore. I did find that a problem I had with the bluetooth activating after rebooting disappeared after I removed the old cables. Perhaps a sensitivity in the new hardware? I don't know but I hope this works for you too.
     

Share This Page