Green TB display on resume in clamshell mode

Discussion in 'OS X Mavericks (10.9)' started by thewusman, Sep 16, 2013.

  1. thewusman macrumors regular

    Joined:
    Aug 8, 2013
    #1
    Hi all

    I have a 2012 MBA 11" i5 running Mavericks DP7

    Since installing Mavericks (I jumped in from DP4, now at DP7) I've had the following bug in clamshell mode, did a clean reinstall last weekend and it persists:

    When resuming from sleep in clamshell mode, the TB Display will occasionally show green hues all over, as per image on the left.

    [​IMG]

    This is remedied by either unplugging and plugging the TB display in again (from the MBA TB port), or opening the MBA up and using both screens. A restart is not necessary.

    Any ideas ?

    Can't seem to find anybody else with this problem.

    Taking a screenshot of the green screen results in a perfect image, ie. the image captured is not green.

    Does not happen with another external display, 24" Samsung using TB->HDMI adapter, it's isolated to the Apple TB 27" display.

    Doesn't happen all the time, seemingly random but at least daily when waking from sleep while in clamshell mode.

    I usually always use my MBA docked in Twelve South BookArc at home. Never experienced this before.

    Bloody irritating.

    :confused::confused:
     
  2. thewusman thread starter macrumors regular

    Joined:
    Aug 8, 2013
    #2
    This persists.

    Woke from sleep this morning and all was green.

    While I love the colour of money (hey - who doesn't, right?) on my TB display it kinda sucks.

    I've noticed that changing resolutions with SwitchResX will bring things back to normal (ie. in and out of best for display and back again).

    Must be a driver issue, I can't see this being a hardware fault.
     

Share This Page