Grey lock screen when trying to do clean install

Discussion in 'OS X Mountain Lion (10.8)' started by E3BK, Jul 27, 2012.

  1. E3BK, Jul 27, 2012
    Last edited: Jul 27, 2012

    E3BK macrumors 68020


    Mar 15, 2008
    So I created a bootable USB of mountain lion so I could do a clean install. I did the same thing for lion and had no problems.

    When I boot while holding down the option key, I get a grey lock screen that just has a space for a password. My admin password isn't working. I've tried others but no go.

    I thought there might be something wrong with the USB so I tried booting in recovery mode with command+R. Same thing.

    Does anyone know what this is? Sorry if its a stupid question. :(
  2. dandypro macrumors newbie

    Jul 28, 2012
    Hi friend, I have the answear

    You are not stupid.

    I found it.

    You'll need to reset the password XXXXX startup from any disc.

    To reset it, you'll need to remove one of your RAM chips from the computer, and reset the PRAM (hold down the p+r+option+command keys for 3 full restarts, then release). After that, you should be able to startup from the disc by holding down the C key, and put the RAM chip back in.

    Read more: my macbook pro has a admin lock on it, i dont remember the - JustAnswer
  3. ptcrjosh macrumors newbie

    Jan 22, 2013
    Los Angeles
    dandypro you are a frickin' genius

    I've been beatin' my self over the head over this for the last two days trying to get past this Lock with password thing. Your suggestion worked like a charm. I couldn't boot from a CD or the hard drive and I've been getting that stupid question mark in the folder. I tried every boot option there is. Including the PRAM reset(holding down option, command and "P" and "R". Removing the RAM card was the key. Now this laptop recognizes the installed hard drive as well the optical drive. Dude, this was the answer I've been looking for. Like I said you're a frickin' genius. Thanks for your post!:cool:;)
  4. NowMacLover macrumors newbie

    Sep 2, 2014
    Worked for me!!!

    Thank you so very much for this much needed info. Worked like a charm for my iMac 20" A1224. A very , very happy camper. Thanks a million:apple::D
  5. DeltaMac macrumors G3


    Jul 30, 2003
    This technique to change the RAM configuration then reset, no longer works to reset a firmware password on Macs newer than late 2010.
    The method to retrieve the firmware password, and unlock a Mac with a firmware (EFI) password on newer Macs requires taking your Mac in for service.

Share This Page