Grey screen and loud fan after keyboard replacement

Discussion in 'MacBook Pro' started by Evo13, Jul 24, 2014.

  1. Evo13 macrumors newbie

    Joined:
    Jun 12, 2014
    #1
    My power button had stopped working and I ordered a keyboard to replace it. Went in and replaced it and after booting, I noticed a grey screen and my MBP fan to start running at full speed with a grey progress bar underneath the apple logo on screen. The bar takes time to fully load, and when it does complete my laptop shuts off.

    Looking at all my connections I noticed I may have broken the clamp for one of the connection where the ribbon cable goes into. So the cable is inside the area it needs to be in, but there is no clamp to shut it. I believe that could be causing the issue as all other cables and connections seem to be intact. :mad:

    Anything I can do to fix my problem? Replacing the logic board would seem the only possible way, but I might as well as buy a new laptop then.
     
  2. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #2
    If you broke that clamp that is definitely needed then a MLB replacement seems like the only thing you can do to resolve it. Unless there is some way you can use something to keep it in place.

    Was the laptop under warranty when you fixed it?
     
  3. Evo13 thread starter macrumors newbie

    Joined:
    Jun 12, 2014
    #3
    No its early 2011 13 inch model. I kind of regret not getting it replaced from Apple even when they were charging me over $200 to replace the top assembly :(
     

Share This Page