grey screen flashing ? on start up

Discussion in 'iMac' started by eddieblock, Apr 12, 2011.

  1. eddieblock macrumors member

    Joined:
    Feb 2, 2008
    #1
    hi. as title suggests that when i start my imac i get the grey screen with a flashing ? . i,ve got around this a couple of times by shutting down and restarting with the option key held down and choosing the hd. can anyone tell me how to stop this ? or is my hard drive knackered ? also what would the cause be ? one thing i noticed was just before it started the imac used to take ages to awake from sleep. any help would be great, thanks in advance and sorry for the long post !
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    System Preferences > Startup Disk > Select your OS X disk > Click Restart
     
  3. Badger^2 macrumors 68000

    Badger^2

    Joined:
    Oct 29, 2009
    Location:
    Sacramento
    #3
    You should do an immediate backup if you get it back up.
     
  4. eddieblock thread starter macrumors member

    Joined:
    Feb 2, 2008
    #4
    thanx for the replys. i,ll back up and then i,ll try what you suggest. thanx again
     
  5. Jexta macrumors member

    Joined:
    Apr 11, 2011
    #5
    This is referred to in my workshop (Apple Certified Service Center) as a Kernel Panic. It could indicate that your harddrive is on the fritz and I would suggest an immediate backup should you be able to boot completely.

    It may even be the result of a power spike, so I would suggest unplugging the AC cable of your iMac and letting it sit for a minimum of 2 minutes (5 is better) to let the capacitors drain and have everything reset.

    Also during boot you can try a PRAM reset by holding "Apple + Option + P + R" and waiting for the second chime before releasing the keys.
     
  6. eddieblock thread starter macrumors member

    Joined:
    Feb 2, 2008
    #6
    tried the pram thing still no joy. have backed up so i,m now re installing the operating system. hope this fixes things
     

Share This Page