Grey Screen of death + broken time machine

Discussion in 'Mac Basics and Help' started by Laurentr80, Oct 27, 2014.

  1. Laurentr80 macrumors newbie

    Joined:
    Oct 27, 2014
    #1
    I have a Macbook pro unibody 2009 that gives me the grey screen of death.
    I have done a number of checks to try and understand what's wrong, but more importantly, running it in recovery mode, it does not want to restore the Time Machine I have on an external hard-drive ("An error has occured while erasing your restore destination disk"), nor do an OS X reinstall ("an error occured while preparing the installation")...so I am at a loss...
    please see pictures for more details on machine and where it stops when starting in single user mode...
    I have fixed a "Disk0s2 I/O error" issue on it 2 years ago, which was the SATA cable on the HD which was dead and I had to change it...but given in recovery mode in disk utility I can currently actually "scan" all the content on my HD, I figured the cable must be fine...
    Can anybody advise what to do?

    Thanks
    Laurent
     

    Attached Files:

  2. subsonix macrumors 68040

    Joined:
    Feb 2, 2008
    #2
    It seems you got an I/O error reported by fsck, which does filesystem consistency checks. So either your filesystem or disk is has a problem I think.

    Have you tried to test the file system with disk utility, if so does it report the filesystem as OK? If not, have you attempted to do a repair on the filesystem on disk0s2 with disk utility? Just some thoughts.
     
  3. Laurentr80 thread starter macrumors newbie

    Joined:
    Oct 27, 2014
    #3
    Yes, I ran a file system verification and repair but it found nothing.
     
  4. subsonix, Oct 28, 2014
    Last edited: Oct 28, 2014

    subsonix macrumors 68040

    Joined:
    Feb 2, 2008
    #4
    I occurred to me that is says (NO WRITE) after the device node, so the file system is likely mounted read only, which may be why fsck fails. You can see that it wrote 0 bytes to the journal below. You could perhaps try to mount it read/write and run fsck_hfs again, but take care since you're root.

    Edit: I just saw this, http://support.apple.com/kb/ts1417 which advice against fsck for versions above 10.4, perhaps you can try the safe mode boot that is suggested in the document if you haven't already.
     
  5. Laurentr80 thread starter macrumors newbie

    Joined:
    Oct 27, 2014
    #5
    Ah! That is well spotted, thanks mate!...how do I remount it in R/W? In disk utility? Feeling a bit in unchartered territory here...
     
  6. subsonix macrumors 68040

    Joined:
    Feb 2, 2008
    #6
    I was referring to while in single user mode. You should be able to check if it's mounted read only with:

    Code:
    diskutil info /dev/disk0s2
    
    Then at the very bottom you'll se a row called "Read-Only Volume" Yes/No.

    You can also verify the volume with diskutil from there:

    Code:
    diskutil verifyVolume /dev/disk0s2
    
    Perhaps try that and take it from there.
     

Share This Page