Grey Screen of Death on 3 Year old Macbook

Discussion in 'MacBook' started by MissKreeps, Apr 16, 2012.

  1. MissKreeps macrumors newbie

    Joined:
    Feb 6, 2012
    #1
    Well i got its screen repaired it was the entire LCD that needed fixing in the end

    well since getting it back end of march its given me grey screen of death twice once just 10 mins ago

    this is the report it gave me about it:
    Interval Since Last Panic Report: 40880872 sec
    Panics Since Last Report: 2
    Anonymous UUID: C2A6D75D-68DF-4183-B394-75AD48C9A19C

    Mon Apr 16 10:58:43 2012
    panic(cpu 0 caller 0x001A0868): "trying to interlock destroyed mutex 0xabae4ec"@/SourceCache/xnu/xnu-1228.15.4/osfmk/i386/locks_i386.c:1760
    Backtrace (CPU 0), Frame : Return Address (4 potential args on stack)
    0x2fe7be48 : 0x12b4c6 (0x45f91c 0x2fe7be7c 0x13355c 0x0)
    0x2fe7be98 : 0x1a0868 (0x468040 0xabae4ec 0x2fe7bec8 0x3ee9af)
    0x2fe7beb8 : 0x19d72e (0xabae4ec 0x202 0x2fe7bf38 0x36ccb3)
    0x2fe7bec8 : 0x36ccb3 (0xabae4ec 0x1 0x5dc 0x4b8f250)
    0x2fe7bf38 : 0x3bc607 (0x4b8f250 0xabae4b8 0x45f20e4 0x1)
    0x2fe7bf78 : 0x3e3a7f (0x45f20e4 0x4468d80 0x4468dc4 0x0)
    0x2fe7bfc8 : 0x1a1c0a (0x42ed7e0 0x0 0x1a40b5 0x5586d00)
    No mapping exists for frame pointer
    Backtrace terminated-invalid frame pointer 0xbfffef98

    BSD process name corresponding to current thread: Safari Webpage P

    Mac OS version:
    9L31a

    Kernel version:
    Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386
    System model name: MacBook5,2 (Mac-F22788AA)

    System uptime in nanoseconds: 165259459563631
    unloaded kexts:
    com.apple.driver.InternalModemSupport 2.4.0 - last unloaded 176916970582
    loaded kexts:
    com.bresink.driver.BRESINKx86Monitoring 7.0 - last loaded 30641116608
    com.rim.driver.BlackBerryUSBDriverInt 0.0.68
    com.apple.driver.AppleHWSensor 1.9d0
    com.apple.driver.InternalModemSupport 2.4.0
    com.apple.iokit.IOBluetoothSerialManager 2.1.9f10
    com.apple.filesystems.autofs 2.0.2
    com.apple.driver.AppleHDAPlatformDriver 1.7.1a2
    com.apple.driver.AppleHDAHardwareConfigDriver 1.7.1a2
    com.apple.driver.AppleHDA 1.7.1a2
    com.apple.driver.AppleUpstreamUserClient 2.7.5
    com.apple.driver.AGPM 100.8.7
    com.apple.driver.AppleHDAController 1.7.1a2
    com.apple.Dont_Steal_Mac_OS_X 6.0.3
    com.apple.driver.AppleGraphicsControl 2.8.15
    com.apple.nvidia.nv50hal 5.4.8
    com.apple.driver.SMCMotionSensor 2.1.1d2
    com.apple.iokit.IOFireWireIP 1.7.7
    com.apple.driver.AppleIRController 113
    com.apple.driver.AudioIPCDriver 1.0.6
    com.apple.driver.ACPI_SMC_PlatformPlugin 3.4.0a17
    com.apple.driver.NVSMU 1.1.7
    com.apple.driver.AppleSMBusPCI 1.0.1d1
    com.apple.driver.AppleLPC 1.3.1
    com.apple.driver.AppleTyMCEDriver 1.0.0d28
    com.apple.driver.AppleBacklight 1.6.0
    com.apple.GeForce 5.4.8
    com.apple.driver.AppleUSBMergeNub 3.5.2
    com.apple.driver.BroadcomUSBBluetoothHCIController 2.1.9f10
    com.apple.driver.AppleUSBTrackpad 1.7.4f1
    com.apple.driver.AppleUSBTCKeyEventDriver 1.7.4f1
    com.apple.driver.AppleUSBTCKeyboard 1.7.4f1
    com.apple.driver.USBCameraFirmwareLoader 1.0.9
    com.apple.iokit.IOSCSIMultimediaCommandsDevice 2.1.1
    com.apple.iokit.SCSITaskUserClient 2.1.1
    com.apple.driver.XsanFilter 2.7.91
    com.apple.iokit.IOAHCISerialATAPI 1.1.2
    com.apple.iokit.IOAHCIBlockStorage 1.2.3
    com.apple.driver.AppleUSBHub 3.4.9
    com.apple.iokit.IOUSBUserClient 3.5.2
    com.apple.driver.AppleFWOHCI 3.9.7
    com.apple.driver.AirPortBrcm43xx 367.91.22
    com.apple.driver.AppleAHCIPort 1.7.0
    com.apple.nvenet 1.0.54
    com.apple.driver.AppleUSBEHCI 3.4.6
    com.apple.driver.AppleUSBOHCI 3.4.6
    com.apple.driver.AppleFileSystemDriver 1.1.0
    com.apple.driver.AppleEFINVRAM 1.2.0
    com.apple.driver.AppleSmartBatteryManager 158.10.5
    com.apple.driver.AppleRTC 1.2.3
    com.apple.driver.AppleHPET 1.4
    com.apple.driver.AppleACPIPCI 1.2.5
    com.apple.driver.AppleACPIButtons 1.2.5
    com.apple.driver.AppleSMBIOS 1.4
    com.apple.driver.AppleACPIEC 1.2.5
    com.apple.driver.AppleAPIC 1.4
    com.apple.security.seatbelt 107.12
    com.apple.nke.applicationfirewall 1.8.77
    com.apple.security.TMSafetyNet 3
    com.apple.driver.AppleIntelCPUPowerManagement 76.2.0
    com.apple.driver.DiskImages 199
    com.apple.BootCache 30.4
    com.apple.iokit.IOSerialFamily 9.4
    com.apple.driver.DspFuncLib 1.7.1a2
    com.apple.iokit.IOHDAFamily 1.7.1a2
    com.apple.iokit.IOAudioFamily 1.6.9fc5
    com.apple.kext.OSvKernDSPLib 1.1
    com.apple.driver.IOPlatformPluginFamily 3.4.0a17
    com.apple.driver.AppleSMC 2.3.1d1
    com.apple.NVDAResman 5.4.8
    com.apple.iokit.IONDRVSupport 1.7.3
    com.apple.iokit.IOGraphicsFamily 1.7.3
    com.apple.driver.AppleUSBBluetoothHCIController 2.1.9f10
    com.apple.iokit.IOBluetoothFamily 2.1.9f10
    com.apple.iokit.IOUSBHIDDriver 3.4.6
    com.apple.iokit.IOBDStorageFamily 1.5
    com.apple.iokit.IODVDStorageFamily 1.5
    com.apple.iokit.IOCDStorageFamily 1.5
    com.apple.iokit.IOFireWireFamily 3.4.9
    com.apple.iokit.IO80211Family 216.1
    com.apple.iokit.IOAHCIFamily 1.5.0
    com.apple.iokit.IONetworkingFamily 1.6.1
    com.apple.driver.AppleEFIRuntime 1.2.0
    com.apple.iokit.IOSMBusFamily 1.1
    com.apple.iokit.IOUSBMassStorageClass 2.0.8
    com.apple.iokit.IOSCSIBlockCommandsDevice 2.1.1
    com.apple.iokit.IOSCSIArchitectureModelFamily 2.1.1
    com.apple.driver.AppleUSBComposite 3.2.0
    com.apple.iokit.IOUSBFamily 3.5.2
    com.apple.iokit.IOStorageFamily 1.5.6
    com.apple.iokit.IOHIDFamily 1.5.5
    com.apple.driver.AppleACPIPlatform 1.2.5
    com.apple.iokit.IOPCIFamily 2.6
    com.apple.iokit.IOACPIFamily 1.2.0

    is anyone able to tell me why its done it and how to fix it?

    also iv noticed that when im on the web google especially i click on a link and it wont send me to that link itll send me to something else thats usually junk but when i click on back and then re click on the link it sends me to the right page, the one i clicked on in the first place could it be a virus? if it is can any one suggest a good antivirus?

    thank you
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    It is not a virus.

    Safari is the culprit. Is Safari up to date?
    Currently there are zero viruses affecting Mac OS X in public circulation, but there are other kinds of malware existing, that can infect your Mac.
    But as long as you don't install software from unknown and untrusted sources, you are safe, as malware needs administrative permissions to run successfully, which means, you need to install the malware yourself, it can't install itself (one of the reasons, why a Mac OS X virus hasn't appeared yet).
    To learn more about malware in Mac OS X and what steps can be taken to protect yourself, read the following F.A.Q.:

    Maybe this can help you with your redirection problems:
     
  3. MissKreeps, Apr 16, 2012
    Last edited: Apr 16, 2012

    MissKreeps thread starter macrumors newbie

    Joined:
    Feb 6, 2012
    #3

    Thank you ill check safari now and see what it was have to admit both times its happened iv been online and safari has been playing up as i have said about it going wappy with the links and such

    and i only ask about viruses cause recently iv heard that a virus called Flashback has come about thats infecting macs via a weakness in java and to turn java off not java script though (which i have turned my java off but my first GSOD was before that)
    and that this virus is not a very nice one to have

    thanks for the info ill update on safari once iv had a look to see if its up to date or not

    EDIT: well safari is fully updated however my use is pretty bad i leave the mac on for days with web browsers open and just close the lid when done (i realize this is bad usuage) would resetting and clearing out safari properly help?
     
  4. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #4
    The recent malware discovery called Flashback is a trojan, not a virus.
    Please read that FAQ I linked to to learn the difference, and that with common sense and some small steps from your side, you don't need AV software on Mac OS X.
     
  5. MissKreeps thread starter macrumors newbie

    Joined:
    Feb 6, 2012
    #5
    Right thank you i always knew the difference between malware and viruses (had to learn with windows when i used to use it) and i havent run an anti virus on this ever and have had it over 3 years just recently theres been a lot of articals about flashback being a virus and it had me a little worried these articles even useing the term virus but thanks for clearing it up

    safari has no updates at all is there anything else that i could do to safari to sort it?
     
  6. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #6
    First fix the redirection issue, and if the kernel panics remain, try resetting Safari.
    You can reset Safari this way:
    [​IMG]
     
  7. MissKreeps, Apr 16, 2012
    Last edited: Apr 16, 2012

    MissKreeps thread starter macrumors newbie

    Joined:
    Feb 6, 2012
    #7
    Thank you For your help :) Hopefully ill be upgrading my OS form 10.5 to 10.6 soon
     
  8. MissKreeps thread starter macrumors newbie

    Joined:
    Feb 6, 2012
    #8


    Iv reset safari but its still doing the wappy link thing where ill click on something in google itll send me straight to another site that isnt even connected to the original link and ill have to click back on my web browser and click on the link a second time to get to the site i want to, its just happened now with me trying to get to Icelands web site through google sent me to some weird site advertsing some sort of app for ipad/iphone what not

    do you know what could be causing this behaviour?
     
  9. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #9
    Did you fix your redirection issue via the link I provided in post #2? Or did you just reset Safari?
     
  10. MissKreeps thread starter macrumors newbie

    Joined:
    Feb 6, 2012
    #10
    i had just reset safari at the time sorry iv done the DNS thing hope that works thanks for the help also hoping it means safari wont bring on a grey screen of death again
     
  11. MissKreeps thread starter macrumors newbie

    Joined:
    Feb 6, 2012
    #11
  12. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #12
    Did you change the DNS servers on both your Mac and your router? Have your reset your router, as recommended in that link?
     
  13. MissKreeps thread starter macrumors newbie

    Joined:
    Feb 6, 2012
    #13
    the router has been reset a number of times and all this only started happening when sky had a big problem and the internet went down that kept giving me IP errors
    i dunno how to sort out the dns on the router itself and it doesnt appear to be effecting my mac mini or my partners laptop (windows) however i have changed it on the mac to no luck its only my mac book thats effected and now safari is getting worse it crashes once a day
    only had one grey screen since safari again otherwise thats appeared to have stopped

    it keeps telling me the crashes in safari are due to .QuestCentralfor.tmp in plug ins however upon searching my laptop and plugins on safari (of which i have none according to my preferences) i cannot find this .QuestCentralfor.tmp cant even find what it is on google
     
  14. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #14
    You can search for that on your Mac by using the method below:
     
  15. MissKreeps, May 14, 2012
    Last edited: May 17, 2012

    MissKreeps thread starter macrumors newbie

    Joined:
    Feb 6, 2012
    #15
    ah thank you i will have a look at that

    safari has been a right pest for a few month and is really starting to cheese me off it decided to crash again today and close only this time its flash plugin that caused the crash
    really wish i knew why suddenly safari is playing up like mad and i cant even send error reports they just refuse to send now
    im gonna upgrade the software to snow leopard in the next couple of months (the back up is gonna be the biggest issue) im hoping that will help and just get rid of the problems iv been having

    Update:

    well i got the security update for the removal of flashback today and even though i turned java off to try prevent it the update found flashback on my laptop and removed it
    does anyone know if flashback may have been the reason for safari to play up like it did?
     

Share This Page