grey screen of doom?

Discussion in 'MacBook' started by musthaveapples, Jul 17, 2011.

  1. musthaveapples, Jul 17, 2011
    Last edited: Jul 17, 2011

    musthaveapples macrumors newbie

    Joined:
    Jul 29, 2008
    #1
    apologies if this has been covered before - am in panic mode as its not my laptop:

    cousins 13" macbook unibody running snowlepoard, ran software update for them and there was lots of updates (over 2gig of snowlepoard and other various stuff). Trying to be helpful I updated and then it reset to install, grey screen with spinning wheel appeared for over 12 hours. Reset via pressing button down and now it won't go past the grey screen. A task bar starts to appear, gets to about 2 cm along and then the whole thing shuts down.

    - tried resetting PRAM - nothing.
    - ran in safe mode - watched the status and lots of Kext 'failed to load errors popup. Invalid key length appeared after the checking catalog file. and then it shuts itself down.
    - Started from the Mac OS X Install disc and ran disk utility to perform disk repair - said invalid node structure and on the second run i got:
    warning: SUD file "Applications/Utilities... as been midified and will not be reparied. Permissions differ on Libary/internet...uld be -rwxrwxr-x, they are -re-re-r-- Open error 5: blah blah blah... (lots of open error 5's)
    - Tried reinstalling the OS and that wont let me do it either. Don't want to do a clean install as their documents are not backed up (life lesson here somewhere!)
    - It's got no firewire so I can't use a target disk to get out their documents etc.

    So my question is.... do I buy Disk Warrior as a last ditched attempt or just push it out of the window and say the dog did it?

    As always, any help much appreciated!
     
  2. Craftybanana macrumors newbie

    Joined:
    Mar 12, 2011
    #2
    Have you tried painting the LCD? At least that way it will remove the 'grey' screen issue.
     
  3. musthaveapples thread starter macrumors newbie

    Joined:
    Jul 29, 2008
    #3
    Thats genius... would save me over £80 on Disk Warrior!:D
     
  4. stridemat Moderator

    stridemat

    Staff Member

    Joined:
    Apr 2, 2008
    Location:
    UK
    #4
    If you cant use firewire, then you can also use ethernet for Target Disk Mode (If Disk Warrior has not sorted you out).
     

Share This Page