Grey Screen With Apple Logo

Discussion in 'iMac' started by Vaeryx, Aug 30, 2011.

  1. Vaeryx macrumors newbie

    Joined:
    Aug 30, 2011
    #1
    Hello everyone, I just recently started having problems with my iMac.
    Details:
    - 2006 White iMac with CD Writer/DVD Reader
    - 150GB HD
    - 1.83GHz Intel Core2Duo Processor
    - Recently upgraded 2x1GB Lexar RAM
    - OSX Tiger 10.4

    Here's the background on what happened. I had started to archive (I think that's what it was..) something onto a USB stick with Disk Utility. I could see that it was going to take a while so I went out for a bit, expecting it to be done by the time I got back. When I did get back, I found that my iMac was frozen and the mouse wouldn't move at all; I couldn't click on anything, couldn't do anything with the keyboard either. So I though "hm, this is strange". I then held down the power button to force a shut down, expecting that it would start up normally. When I went to go start it up again, it was hung up at the Apple logo, no spinner, no broken folder icon, no question mark , nothing, just the Apple logo.

    Here's what I've tried (after hours upon hours of googling..):
    - Tried unplugging all USB devices (none were attached in the first place except the mouse and keyboard)
    - Tried holding down alt/option key to show list of boot drives; after clicking the main one, still gets hung up on Apple logo
    - Tried booting from CD; again, just gets hung up at Apple logo
    - Tried resetting PRAM
    - Tried booting into Safe Mode; still hung up on Apple logo
    - Tried booting into Single-User mode; I get to the screen with white writing on it, but it won't let me type in or enter any commands; from what I assume, it goes straight into Verbose mode instead
    - Tried Verbose mode, which is how I know that Single-User mode is being skipped..

    I don't know what else to do really. Can someone please offer me advice on how to fix it?
     
  2. treestar macrumors 6502

    Joined:
    Feb 28, 2010
    #2
    It sounds like your HDD has failed and you don't have enough RAM to run an install. It also sounds like your RAM is bad. One or both of those two things.
     
  3. Vaeryx thread starter macrumors newbie

    Joined:
    Aug 30, 2011
    #3
    Thanks for the reply. I only upgraded the RAM a few days ago, and it was working perfectly fine. I'm currently away from home now, and can't try the original RAM (which was only 512MB). If I were to swap it back in, would that be a possible solution to getting it to get past the boot screen? And what other options, other than replacing the HDD, would there be to fix the HDD?
    Also, I don't have anything vitally important on the computer, so would there be an easy way to reformat or erase the drive for a clean install of OSX?
     
  4. treestar macrumors 6502

    Joined:
    Feb 28, 2010
    #4
    I mean that your HDD is dead, and when they die it's for good. Your experience sounds very similar to what I went through a month ago when I was installing Lion on a HDD with a scratch on the platter. I just got the Apple logo for an hour and eventually it switched to an X or something. I could start the Lion installer but it would never finish the install. Eventually I could no longer mount the HDD and the installer couldn't move forward at all. I don't think we had the same problems with the installer but I was running from a USB boot disk, whereas you are probably using an optical disc. Try once more to reformat the HDD as maybe only the filesystem was corrupted. I wouldn't trust that drive though, even if it works for a week. There probably is nothing wrong with the RAM, I was just surprised that even the install disc didn't get you into the installer, but I never installed Tiger and maybe it is very different from Lion in what you should expect to see.
     
  5. Vaeryx thread starter macrumors newbie

    Joined:
    Aug 30, 2011
    #5
    Alright, I was afraid of that. How would I go about reformatting the drive in the first place if I have no way of getting to Disk Utility or anything like that? Also, in your case, did you end up replacing your HDD? If so, what could you recommend? See, my ultimate goal here was to eventually upgrade to Lion, but I needed to go through Leopard and Snow Leopard first, which I was going to do via USB install, cause it seems that my disk drive doesn't read Dual-Layer DVDs..
     
  6. treestar macrumors 6502

    Joined:
    Feb 28, 2010
    #6
    If you can't get into Disk Utility then you'd need to reformat on another system (you might not have the resources to do this). Maybe you can get a Tiger install going to an external HDD just long enough to run Disk Utility (I have no idea if this is even possible). I used the HDD I took out of my 2011 MBP. I believe it is a Hitachi.

    If you have another Mac available than I suggest buying Lion from the App store if you don't have it already, and use the non-Apple sanctioned Lion DiskMaker app to make a USB boot disk. That might get you further. You can do a clean install this way.

    It would be wonderful if you could test the HDD. It wouldn't cost much to replace a 150 GB HDD though.
     
  7. Vaeryx thread starter macrumors newbie

    Joined:
    Aug 30, 2011
    #7
    See, I tried to make a Snow Leopard USB boot disk. It gets recognized when I hold down alt/option, but after selecting it, nothing happens..
    But currently, there's a Macbook running Leopard that I could probably use. How would I reformat my HDD using that?
     
  8. treestar macrumors 6502

    Joined:
    Feb 28, 2010
    #8
    With the MB, mount the dodgy HDD via an external enclosure or connect it in place of the optical drive if the interface is compatible. The external method is simpler, if you have the equipment. The internal method is just messy. I'd get a new HDD at that point. Maybe someone else will come along with another trick you can try, but it just seems like something you have to work and pay your way through to the end.
     
  9. BJMRamage macrumors 68020

    BJMRamage

    Joined:
    Oct 2, 2007
    #9
    Hey I installed new memory in my 2008 iMac and after a week or two it crashed and is in the same status. Boots to Grey screen and that is all.

    I just posted last night about it.

    Best of luck. Last night i was able to get to the Install boot screen off the Installer Disc and into Disk Utility and it ERRORed out on repair option.

    Today I swapped old memory back in and nothing but GREY.

    this doesn't sound good.
     
  10. Vaeryx thread starter macrumors newbie

    Joined:
    Aug 30, 2011
    #10
    A friend of mine mentioned using a eSATA to USB cable, would that be any help?
    If not, thanks for the help, and hopefully someone has an answer for me.
     
  11. teleromeo macrumors 65816

    teleromeo

    Joined:
    Dec 2, 2006
    Location:
    kidnapped by aliens
    #11
    Use target mode to connect to your other mac. Hold the T-key while starting up and connect the both with a firewire cable. Your broken mac should appear as a hard disk on the desktop. This way you can use disk utility to inspect the hard drive.
     
  12. Vaeryx thread starter macrumors newbie

    Joined:
    Aug 30, 2011
    #12
    Ok, that was something else I had read, but hadn't got a chance to try.. I just don't have a firewire cable laying around, and they're fairly pricey for just this single use.. But then again, I am kind of a cheapo. I guess it'll still be cheaper than replacing the Mac. First though, I'm going to try installing OSX on an external hard drive. Can anyone point me to a good resource for such things?
     
  13. dagogo macrumors newbie

    Joined:
    Jul 7, 2007
    #13
    I hate to be the bearer of bad news, but when that same sort of thing happened to my 2005 G5 Imac...it ended up being the bad capacitor issue. I removed the logic board and had the entire thing recapped but afterwards the fans raced, it was painfully slow, and it only now boots 50% of the time.
     
  14. Vaeryx thread starter macrumors newbie

    Joined:
    Aug 30, 2011
    #14
    I was hoping that it wasn't something like that.. I'm gonna try and get it looked at at an Apple store or something, hopefully they can help.
     
  15. Vaeryx thread starter macrumors newbie

    Joined:
    Aug 30, 2011
    #15
    I wiped the hard drive using disk utility on a Macbook. I then installed Snow Leopard via Firewire target disk. It ran on the Macbook, but I'm still incurring the same problem on the iMac.
     

Share This Page