Greyed out buttons in system preferences

Discussion in 'OS X Yosemite (10.10)' started by Manch, Jan 17, 2017.

  1. Manch macrumors newbie

    Jan 17, 2017
    I'm having problems with my Mac. Some features in system preferences are greyed out (as you can see in the picture). I am the administrator on my system and yet I'm unable to access these features. I've been looking on the Internet and I can't find anything related to my problem. Any help would be greatly appreciated.
  2. KALLT, Jan 17, 2017
    Last edited: Jan 17, 2017

    KALLT macrumors 601

    Sep 23, 2008
    There are two possibilities. Either this was set in a local preference or it was forced upon the machine via a configuration profile. The visibility of the ‘Profile’ icon suggests that it may be the latter.

    To confirm the first, type the following two commands separately and see whether a result comes up.
    defaults read DisabledPreferencePanes
    defaults read /Library/Preferences/ DisabledPreferencePanes
    To confirm the second, check if the file ‘’ exists in /Library/Managed Preferences.
  3. Manch, Jan 18, 2017
    Last edited: Jan 18, 2017

    Manch thread starter macrumors newbie

    Jan 17, 2017
    Thanks for the quick response.

    I've typed in both lines of code and both returned with the file did not exist.

    I've found the file but it was in /Library/Preferences rather than Managed Preferences. I could not find a Managed Preferences folder. What should I do from here?
  4. KALLT macrumors 601

    Sep 23, 2008
    What is the result of:
    defaults read /Library/Preferences/
    sudo profiles -P
  5. jbarley macrumors 68040


    Jul 1, 2006
    Vancouver Island
    Sounds like somebody's trying to circumvent their parents "lockdown" scheme. :D
  6. Manch, Jan 19, 2017
    Last edited: Jan 19, 2017

    Manch thread starter macrumors newbie

    Jan 17, 2017
    When I type in the first line of code it tells me the file does not exist.

    For the sudo code it brings up a list of computer levels numbered 1 to 5. At the bottom of the list it says there are 5 configuration profiles installed.
  7. KALLT macrumors 601

    Sep 23, 2008
    That confirms at least that there are configuration profiles. Is your machine managed by your employer or have you installed the profiles yourself? Looking at the kind of preferences that are disabled, I am guessing that this was done for security reasons.

    I am a bit puzzled why there is no directory for the managed preferences though. This command returns no result?
    ls {~/,/,/System/}Library/Managed\ Preferences/
    It is possible to export the profile information and then see whether any of the profiles is responsible for this. You can do this with the following command and then open the file in a text editor. Look for relevant keywords, such as ‘systempreferences’, ‘icloud’ etc.
    sudo profiles -Po ~/Desktop/profiles.plist
    Ultimately, if the profiles are responsible, then your only option is to remove them. Depending on whether the profiles are allowed to be removed of course.
  8. havard.skj macrumors newbie


    Feb 26, 2018
    I am having the same issues. The option to enable internet sharing is greyed out.

    I tried this command you mentioned above on El Capitan and found these five files in "/Library/Managed Preferences":
    • ManagedInstalls.plist

    'ManagedInstalls' had these entries:
        AppleSoftwareUpdatesOnly = 0;
        ClientIdentifier = vg;
        DaysBetweenNotifications = 0;
        InstallAppleSoftwareUpdates = 1;
        LastCheckResult = 0;
        LogFile = "/Library/Managed Installs/Logs/ManagedSoftwareUpdate.log";
        LoggingLevel = 1;
        ManagedInstallDir = "/Library/Managed Installs";
        PackageVerificationMode = hash;
        SoftwareRepoURL = " a link, sensored for safety reasons";
        SoftwareUpdateServerURL = "";
        SuppressAutoInstall = 0;
        SuppressStopButtonOnInstall = 0;
        SuppressUserNotification = 0;
        UseClientCertificate = 0;
        forceInternetSharingOff = 0; 
    This is very interesting and frustrating. I would have thought that it was enabled, but it's not. I'm scratching my head... what is the cause of this issue?!?
  9. brunocostasilva macrumors newbie

    Aug 6, 2018
    I was having the same problem after installing the update to Mojave. Although being the administrator, some items were greyed in Systems preferences.
    In my case the issue was that "enable parental controls" was selected in my User account.
    As I could not deselect parental controls in "user & groups", the solution was to create a new account with admin access. After login in using this new admin account I just went again to "user & groups" and deselected "enable parental controls" in my actual user account.
    After login in again in my actual account the issue was solved.

    Good luck



Share This Page