Greyed Out USB

Discussion in 'Mac Accessories' started by sethmeyers, Jun 24, 2014.

  1. sethmeyers macrumors newbie

    Joined:
    Jan 17, 2013
    #1
    For nearly a year, my flash drive has worked fine with my iMac (10.6.8). But last week, when the power went off two or three times in the same day while I was trying to copy files to the flash drive, it suddenly decided to become "read only."

    I've tried Disk Utility, but all the options are greyed out.

    Can anything be done? Thanks in advance.
     
  2. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    Random thoughts ...

    If the flashdrive is still "readable" on the Mac, and you can see what's on it, copy whatever you wish to save FROM it, to another location.

    If it won't re-initialize on the Mac, do you have access to a Windows PC anywhere on which you could try a re-initialization? Maybe store that sells PC's would do this for you, or a PC repair shop.

    If that works -- if you can re-initialize it on the PC -- take it BACK TO the Mac, and try a second re-initialization with Disk Utility.

    If that doesn't work, might be best to consign the flashdrive to the drawer, and get another...
     
  3. sethmeyers thread starter macrumors newbie

    Joined:
    Jan 17, 2013

Share This Page