Greyed out Wifi / Fix via SSH?

Discussion in 'Jailbreaks and iOS Hacks' started by Shr00m, Jun 23, 2010.

  1. Shr00m macrumors newbie

    Joined:
    Jun 23, 2010
    #1
    I have an IPhone 3G and like other people that I've noticed my Wi-Fi is greyed out. This happened for no apparent reason, my iphone didn't get wet, I didn't drop it, or I didn't run a crazy program to mess it up (that I know of).

    It happened to me when I was on 3.1.2; jailbroken of course. I tried to go back to 3.1 but had problems so I decided to just try to go to the stock 3.1.3 without being jailbroken. That didn't' work either. I then jailbroke 3.1.3 and decided to wait until iOS4 came out and thought that a stock upgrade to 4 from DFU mode would fix my WiFi. That didn't work. So I jailbroke and run the Ultrasn0w thinking that might mess while some settings and fix my Wi-Fi. That didnt' work either.

    Last night I setup my router to accept VPN connections and used my iPhones 3G connection to connect to my home network. I then connected to my iPhone from my notebook using Putty. Being fairly experienced with linux I thought I could run some command line utilities to see what was going on with my Wifi network interface. Unfortunately I couldn't' find anything, not even in dmesg.

    My concern is that it could be a hardware problem since I can't see a MAC address on the adapter (see pic below). I've ready many complaints on this and saw that this could be corrupt NVRAM. My last resort is to somehow try to downgrade (if possible) back to Iphone OS v2.x then upgrade manually all the way to iOS4.

    My question is:
    Does anyone know of troubleshooting commands I can run via SSH to find out what is going on with my Wifi? Better yet, anyone know how to fix this??



    [​IMG][​IMG][​IMG]
     
  2. zoeconner macrumors regular

    Joined:
    Jul 17, 2007
    #2
    I had this before and tried everything. Apple couldnt figure it out either. Had to send it back to apple.:mad:
     
  3. Shr00m thread starter macrumors newbie

    Joined:
    Jun 23, 2010
    #3
    Unfortunately its out of warranty! :mad:
     
  4. Shr00m thread starter macrumors newbie

    Joined:
    Jun 23, 2010
    #4
    Does anyone think that if I downgrade back to an older OS then re-upgrade to Ios4 it will fix my problem?
     
  5. rbrt86 macrumors newbie

    Joined:
    Aug 9, 2009
    #5
    I'm afraid not: I've tried downgrading my iPhone and it didn't work
    Dev-team released a wifi fix in the early days, but I never figured out if it could help the 3g phones (it was designed for the 2g phones with this issue)

    you can find the fix here:
    http://wikee.iphwn.org/sgold_bootrom:fixwifi
    hope it helps!
     
  6. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #6
    If a restore doesn't work, then I'm afraid you've got a hardware problem. Sorry!
     
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #7
    Yep, sounds like a hardware issue.
    Nothing you do true ssh will matter.
     

Share This Page