Gridbased Wordpress Layout not working in FF3

Discussion in 'Web Design and Development' started by Bluefusion, Jul 14, 2008.

  1. Bluefusion macrumors 6502

    Bluefusion

    Joined:
    Apr 25, 2003
    Location:
    New York, NY
    #1
    Hey-- I'm using Aperio (with a lot of modification) on my site, www.ThisMomentIsAllWeHave.com , and I realized that the main page doesn't display properly in Firefox (2 or 3). I'm not sure what's wrong, since I'm not a huge CSS junkie, but it seems like it should work... it works FINE in Safari (and since the theme was made by someone else, who claims it does work in FF, I don't know where the problem could be). Any ideas? I can supply code if you need... but I really want to get this resolved!
     
  2. SrWebDeveloper macrumors 68000

    SrWebDeveloper

    Joined:
    Dec 7, 2007
    Location:
    Alexandria, VA, USA
    #2
    I am using FF3 on Windows presently and the site seems to flow okay, i.e. bunch of images with text underneath, left justified, no overlaps or odd formatting - simple vertical layout. Is it fixed? If not, please describe what's wrong and/or include screenshots showing rendering differences, thanks.

    Your site doesn't validate, numerous errors involving p tags inserted within spans (block level elements can't go inside inline elements) which might affect formatting, as a best guess. Kill those p tags and edit the class referenced in the nearby span tag to include "display: block" for example.

    -jim
     
  3. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #3
    If you look with Safari, the difference is easy to see. To succinctly explain it, it's not completely vertical, more grid like. It has 3-4 images per row with text underneath each image. The page is centered horizontally as well.

    There's a ton of CSS so didn't see anything obvious on a quick look.
     

Share This Page