Groups not working in Apple Mail and Address Book

Discussion in 'Mac Apps and Mac App Store' started by Halcyon, Jan 30, 2012.

  1. Halcyon macrumors 6502

    Sep 21, 2006
    Go to Address Book > Create Group > Drag 5 email addresses > Save

    Go to Apple Mail > Group does not show in the Address Panel, but if I type the Group's name in the To: field the group shows up. Fine till there, but if I try to send the message I get a warning that pop-up saying that it does not seem to be a proper email address in the To: field. If I send the message anyway I'm not allow by the chosen outgoing server (no matter which one I choose from many I have available.

    If I open Address Book the group is there and if I right-click on it I can select send email to group...which takes me to Apple Mail, but from there the same thing happens > my mail goes nowhere.

    I have other groups that I have created a long time ago and they all work fine. Maybe something got screwed during a system upgrade or the likes? I'm running 10.6.8 and Mail 4.5.

    MAybe I can delete Mail's .plist but I'm not sure if I'll lose any of my settings, rules, contacts, etc.

    Thanks in advance for your help.
  2. Halcyon thread starter macrumors 6502

    Sep 21, 2006
    Problem Solved

    Close Mail App > Open Mail App

    It seems that Apple Mail will not recognize the groups you create in Address Book, till you close Mail and open it again.
  3. rjake4 macrumors newbie

    Jul 17, 2012

    Thank you. This has been baffling me for months and I search the web for answers each time. This was the first time I found the answer.
  4. Halcyon thread starter macrumors 6502

    Sep 21, 2006
    I'm glad this short thread was of help to you. Also, don't forget that the group name cannot have any illegal characters in it.

  5. Dizzi45Z macrumors newbie

    Jul 31, 2011
    Wow! I just came across this today. How annoying! Does this bug exist in Mountain Lion?
  6. bjay25 macrumors newbie

    Mar 30, 2010
    Orlando, Florida
    In ML I just created a group in Contacts and edited the Distribution list to select the correct email address for those with multiple email addresses.

    Then went to Mail / New Message and dragged the group name from Contacts to the To: field. The five emails popped into the To: field. Just to check it, I opened another New Message and started to type the Group name. After only two characters the rest of the name appeared. Accepting the name then changed to the five names in the Group.

    I would say there isn't a bug in my Mountain Lion and I didn't have to quit/re-open either application.
  7. TallThomas macrumors newbie

    Mar 5, 2014
    Distribution List is not showing all addresses

    I am having a similar problem. I have created a group but when I go to edit the distribution list, some of the e-mail addresses in the contacts don't show up. In several cases, there is no address listed in the distribution list; only the contact name. Does the address book not recognize certain addresses? Thank you.
  8. jcmac2014 macrumors newbie

    Sep 18, 2014
    Address book, group email doesn't work

    I am using macbook pro, osx 10.6.8 operating system.

    I have a group set up in address book that I use all the time. It has stopped working. Other groups will send but not this one particular one.

    I have deleted it and made a new group, but that did not work. I tried shutting it down like mentioned in this feed. Other suggestions? Also, when I put the group name into the email, it doesn't let me "expand" the list. So, something is obviously wrong but I don't know what!

    I have never had any trouble in the past.
  9. Samboon macrumors newbie

    Oct 31, 2016
    --- Post Merged, Oct 31, 2016 ---
    Under the pull down menu VIEW , select SHOW GROUPS. Damn.
  10. kfd3027 macrumors newbie

    Apr 26, 2018
    On my contacts... all the groups have disappeared and the email addresses are now just listed alphabetically with no reference to which group they belong to. Attached is a screen grab. When I click on the exclamation mark across from Exchange this is the message I get.
    The operation couldn’t be completed. (SOAPWebServicesErrorDomain error -997.)
    This has just happened suddenly, does anyone have any ideas?

    Attached Files:

Share This Page