Groups not working in Lion

Discussion in 'Mac Apps and Mac App Store' started by Dal123, Dec 22, 2011.

  1. Dal123 macrumors 6502a

    Dal123

    Joined:
    Oct 23, 2008
    Location:
    England
    #1
    I have created two groups in address book. One group contains about 5 contacts and works well. The other only contains two contacts and when I go to enter the group name in apple mail i type the group; it recognises the group. But no contacts come up.
    Anyone know why? The contacts have their email stored in address book and are set in the groups. However one of the contacts is a bit strange. Email is added on the contact but only shows when I click on the edit button. This is weird.:(

    I know there are only two contacts in the group and a bit silly but there will be approximately 20 in the group soon.
     
  2. thankins macrumors 6502

    Joined:
    Oct 25, 2007
    #2
    I have the same bug on 10.7.2 - what I ended up doing was just going to the group in Address Book and selecting all the names and dragging them to the Mail.app message.
     
  3. Dal123 thread starter macrumors 6502a

    Dal123

    Joined:
    Oct 23, 2008
    Location:
    England
    #3
    Thanks; I thought I didn't do anything wrong there. :)
     
  4. Dal123 thread starter macrumors 6502a

    Dal123

    Joined:
    Oct 23, 2008
    Location:
    England
    #4
    I tried carrying the group from address book into the email address bar, nothing appears.
    Is there a fix for this? Embarassing for apple :eek:!
     
  5. Ashka macrumors 6502a

    Ashka

    Joined:
    Aug 9, 2008
    Location:
    New Zealand
    #5
    Right click (control click) the group name in the Lion address book and use the "send email to" option.
    S.
     
  6. El Mike macrumors newbie

    Joined:
    Jan 15, 2012
    #6
    I'm having the exact same problem, also with 10.7.2. Doesn't matter if I right click the group in Address book, or drag it over into Mail, or type it in. Either nothing shows up, or sometimes just a comma, or if I drag it in, the group name DOES show up, but goes away as soon as I hit "send"! Very annoying!
     
  7. Dal123 thread starter macrumors 6502a

    Dal123

    Joined:
    Oct 23, 2008
    Location:
    England
    #7
    Yes I control click, send email to group from address book. This loads up a fresh email screen with no email addresses :(.
     
  8. ourstanley macrumors newbie

    Joined:
    Feb 7, 2012
    #8
    Check that each member of the group has a valid e-mail address

    I was having this issue as well and decided to double check each of the members of my group and realized that some of them did not have valid e-mail addresses. Once I corrected that (by either adding an e-mail address, or removing the contact from the group) when I right clicked the group and chose 'send e-mail to "Group Name" ' the e-mail appeared with all the contacts listed. It also worked when typing in the group name in an e-mail.

    It makes sense that they would stop you sending an e-mail to a group if there were e-mail addresses missing, but it would be nice if there was an error message to explain that rather than just failing.
     

Share This Page