Grrr. Comcast blocking port 25, can't send emails now. Hosting advice needed

Discussion in 'Web Design and Development' started by Mike Teezie, Nov 13, 2008.

  1. Mike Teezie macrumors 68020

    Mike Teezie

    Joined:
    Nov 20, 2002
    #1
    Comcast blocked port 25 on my account with zero warning. Now, I can't send emails from Mail from my house on my mac pro or my Macbook Pro. My office is in my home, so this is a problem obviously.

    They refuse to open the port back up. My webhost, IX, doesn't offer the smtp server to use any other port, so I'm pretty much screwed. I'd be willing to change hosts, but I'm limited to Comcast in my area.

    I know nothing about all of this really. I just want to be able to send mail from my business email, using Mail. Like I said, switching hosts is fine, I just have to find one that uses port 587 for smtp or something. Any suggestions?
     
  2. rogersmj macrumors 68020

    rogersmj

    Joined:
    Sep 10, 2006
    Location:
    Indianapolis, IN
    #2
    Setup a free Google Apps for Your Domain account. I use it for most of my personal domains, and you connect to their SMTP on 587.
     
  3. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #3
  4. Dimwhit macrumors 68000

    Dimwhit

    Joined:
    Apr 10, 2007
    #4
    Wait, how can they do that? How do you send email with your Comcast email account? Or do they block it for all other email except theirs?

    Some providers also open up Port 26, I believe. You could try that. Otherwise, I'd have to recommend the Gmail option. Probably not your preferred method, but it works.
     
  5. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #5
    Listen to angelwatt. Just setup your email to use Comcast's SMTP server. Problem solved.

    I have a client who had an (eerily) similar problem this weekend. He has a domain hosted with IX and uses them for email, and he switched to AT&T DSL. He could receive but couldn't send mail. I switched his settings to use AT&T's SMTP server and all is well.
     
  6. SrWebDeveloper macrumors 68000

    SrWebDeveloper

    Joined:
    Dec 7, 2007
    Location:
    Alexandria, VA, USA
    #6
    For those who run their own mail server with a dedicated IP and hostname, it's more common these days that providers block port 25 due to open relay issues. Liquid Web, my web host, allows me to run Exim on port 26 to overcome this. This is a solution that is not as well known and thought I'd suggest it from my experience - something to ask your webhost (do not mention to the ISP, of course). So you can manage your own mail and users, of course. FYI.

    -jim
     
  7. belvdr macrumors 601

    Joined:
    Aug 15, 2005
    #7
    You are not using your ComCast email account. You have your system send the email to their relay/smart host, and it forwards it on for you. This ensures they see all email heading outbound from their network and scan for spam/viruses. The idea is to stop those items as close to the source as possible.
     
  8. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #8
    Hasn't Comcast done this for a few years now?

    Anyways, this is a perfectly good option; the other one is that you can typically use the secure port on your SMTP server (587 or whatever it is) -- those are usually not blocked.
     
  9. belvdr macrumors 601

    Joined:
    Aug 15, 2005
    #9
    True, but those higher ports usually require either authentication or encryption to work. Straight, unencrypted, unauthenticated SMTP is not (and should not) be setup on those ports. The RFC seems to be pushing this port (587) more and more.
     
  10. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #10
    There is a very easy way to use an alternative port.
     
  11. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #11
    Sorry, I thought this was generally understood as being part of the concept of a "secure port." Yes, all the more reason why you should use it (with its encryption and authentication).
     
  12. ChrisA macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #12
    Set up you mail system to use comcast as a relay. This should actually work better then what you have been doing. I'm sure there are instructions on their site about how to use their SMTP server.
     
  13. vixen01 macrumors newbie

    Joined:
    Nov 28, 2008
    #13
    I just experienced this problem on all days, Thanksgiving.
    We couldn't send any mail but could receive mail. Comcast is my internet provider but they are not who we go through for our e-mail. We have 2 domains through IX Webhosting and it's their servers that our e-mails go through. I first contacted them and found out that they don't block Port 25 but that they have this problem coming past there help desk everyday due to Comcast blocking this port. I then contacted Comcast and simply explained that 1) I wasn't about to change anything on my end since it has been working perfectly fine for well over 10+ years and 2) I wanted to know why my modem (which belongs to Comcast due to us upgrading a year ago to the digital voice) was selected and Port 25 was all of a sudden blocked. They couldn't of course tell me why they did this but they did unblock it.

    So, if you go through Comcast's servers to get your e-mail then yes, Port 25 is blocked and you'll have to set your out going to 587 but if you don't go through Comcast's servers for your e-mail and you use their modem, then this is were the block on Port 25 occurs. Call them and ask that the block on your modem be removed and more than likely it will be done in seconds. Problem with them doing all of this is that some of us (including myself) have no clue to what to say to get this problem rectified. The only why I found out was due to the help desk at our hosting company about the block but it was search on Google that talked about Comcast selecting certain modems and blocking Port 25 that way.
     
  14. SrWebDeveloper macrumors 68000

    SrWebDeveloper

    Joined:
    Dec 7, 2007
    Location:
    Alexandria, VA, USA
    #14
    Thanks for reporting that, it's quite typical of the insanity of the large ISPs such as Comcast, Cox, and so on who typically oversell their bandwidth and implement crazy protocols under the guise of "network security". They don't randomly select, it's based on their network nodes that suffer the most network congestion. Good to know if pressed, they can relent. But that's the whole point, that the burden is on the end user to resolve the issue - the ISP hopes we're all a bunch of sheep and wouldn't know any better. Baaaaaaaah!

    If they refuse, use an alternate port like discussed earlier.

    For those unaware, TCP port 25 is the standard SMTP communications port.
    TCP Port 587 is standard submission port for the IMAP/SSL protocols.

    -jim
     
  15. Mac In School macrumors 65816

    Joined:
    Jun 21, 2007
    #15
    I second the nomination for moving it to Gmail for free. Trouble-free IMAP mail. I just moved a small business (25 Email accounts) over.
     
  16. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #16
    Now that this has been in place with nearly every major ISP for several years, I'm really surprised people are still making a fuss about it.

    The ISPs did it because it reduces spam traffic -- if SMTP traffic goes through their servers or authenticated external servers, that eliminates much of the spam mail that is sent out through ISPs. Why is that such a big problem? Anyone with even a basic understanding of computers can set up either solution, which are clearly outlined both on the ISPs pages and on many other websites, in 1-2 minutes flat.

    In 2005, when this first started happening, yes, people were upset, because no one notified us of the change. But that was a long time ago -- ages in internet years.
     
  17. PaperQueen macrumors 6502

    PaperQueen

    Joined:
    Aug 16, 2007
    Location:
    Just this side of insanity (Minneapolis)
    #17
    But how do you change the default port?

    Yes, but.... How do you select 587 when using Mail 3.5? It gives you a radio button that lumps 25, 465, and 587 into one bundle. Even with it selected, outbound mail hangs, unable to send out. If you type 587 into the custom port field, you get an error message.

    I truly hate Comcast, but have no better options in the area. Just spent two hours on the phone with them as they used their “simulator” to guess their way through trouble shooting. Had to explain that no, 10.5 was not a Mail version, but an OS number...that we didn’t need to follow the steps to set up a new email account when the issue was outbound mail on current accounts...that the radio button with the three default ports exists....

    ::: sigh :::
     

Share This Page