GT 330M issue?

Discussion in 'MacBook Pro' started by BarracksBoy, Mar 13, 2011.

  1. BarracksBoy macrumors newbie

    Joined:
    Oct 29, 2010
    #1
    Hi Guys,

    I have one of the last generation 15" i7 mbps and have suddnely realised that the intel integrated graphics card seems to be outperforming my discrete one?

    It's especially noticable when using spaces as when going between itunes and safari it's super speedy, but add an application that starts up the 330M (such as iphoto) and the switch between the two same spaces with just itunes and safari suddenly becomes all laggy.

    Is this a know thing that the 330M is slower off the mark or is this an issue that I should take to apple?

    Many Thanks
     
  2. cluthz macrumors 68040

    cluthz

    Joined:
    Jun 15, 2004
    Location:
    Norway
    #2
    No the 330M is a lot faster then the integrated.

    The 330M also outperforms the new 6490m in the base 15 inch MBP.

    I have no problems with mine. (I got a 15 inch with 330M too)
     
  3. BarracksBoy thread starter macrumors newbie

    Joined:
    Oct 29, 2010
    #3
    ok then

    so what should i do about it? just leave it as i use the integrated so much more or actually bother to go to apple about it?
     
  4. BarracksBoy thread starter macrumors newbie

    Joined:
    Oct 29, 2010
    #4
    just to make things better my integrated graphics seem to have decided to have it's time too:

    yes apparently that's a screenshot of my screen :p
     

    Attached Files:

  5. kobyh15 macrumors 6502a

    Joined:
    Jan 29, 2011
    #5
    Sounds like machine is lagging when switching between the two cards. Nothing wrong with each of the cards individually, just the time it's taking your computer to switch between them. Could be wrong though.
     
  6. BarracksBoy thread starter macrumors newbie

    Joined:
    Oct 29, 2010
    #6
    i'd love to be able to agree but unfortunately it isn't that :(

    it flickers when i start iphoto indicating the switch and profiler shows the 330M becoming the one driving the display, and i've made sure everything's minimally using the card and it still manages to lag doing what the integrated can just zoom through
     
  7. kobyh15 macrumors 6502a

    Joined:
    Jan 29, 2011
    #7
    Yikes, well could be a problem with the 330M then? That would stink.
     

Share This Page