GT650m not running world of warcraft

Discussion in 'MacBook Pro' started by sactown024, Jun 11, 2016.

  1. sactown024 macrumors newbie


    Jun 11, 2016
    When I first got this computer I was able to play world of warcraft with no issues on at least good graphics settings. Recently when I play I have to play on the lowest settings possible and even then im getting really low frame rates. I have my automatic graphic swapping turned off, is there anything else I can try? What could have changed from when it use to work fine, until now?

    Also worth mentioning that I am playing on a 27" thunderbolt display.
  2. Queen6 macrumors 603


    Dec 11, 2008
    Enjoying Better Things
    Cooling system may be getting clogged by dust, which reduces efficiency resulting in the GPU throttling more aggressively. May be worth having it cleaned and see if brings back the performance.

  3. Closingracer macrumors 68020

    Jul 13, 2010
    Blizzard has updated the game so just because computer x ran it fine x years ago doesn't meant will run wow now. The 650 m is a pretty me Meh chip and no way near as good as a 950m
  4. PTLove macrumors 6502

    Sep 12, 2014
    What resolution? You say low settings but don't mention that.
  5. andreyush macrumors 6502


    Oct 24, 2015
    Same situation here... I played a month ago CS:GO just fine on GT650M ...Now either they've updated something related to the graphics ( but i don't think so) or the dGPU is thorttling more because of the dust and the heat.

    Try to get the latest drivers from Nvdia..Maybe it will help with something :D
    Cheers !
  6. sactown024 thread starter macrumors newbie


    Jun 11, 2016
    PTLove -- im running it at full res, 1440
    --- Post Merged, Jun 11, 2016 ---
    I went to download drivers but they only offer them for windows
  7. PTLove macrumors 6502

    Sep 12, 2014
    Judging by this you are running wow on Mac.

    I would suggest you play in Windows. Should give much better performance.
  8. friedkimchi macrumors regular


    Aug 13, 2011
    Apparently the latest drivers from Nvidia bricked some people's GPUs.
  9. Ceare macrumors newbie


    Jun 12, 2016

    by any chance are you running World of Warcraft in Windowed (Fullscreen) mode? Blizzard broke/hobbled something in the Mac client in one of the 6.x patches (at least for the 650m) when using this mode. If so, try switching to either Fullscreen or Windowed.

    Incidentally, the Legion Beta client uses the Metal API so performance is way better and this issue has gone away (for now at least).

    Hope this helps.
  10. andreyush macrumors 6502


    Oct 24, 2015

    Parallels windows is ok ? Or bootcamp is much better?
  11. Samuelsan2001 macrumors 604

    Oct 24, 2013
    Parallels no good for gaming as you have to split your resources between OSes, boot camp the way to go for gaming.

Share This Page