GTalk / Messages Solution Found - High Sierra

rodneypoplin

macrumors newbie
Original poster
Sep 27, 2017
5
0
Boerne, TX
I figured out a solution for GTalk to work on High Sierra



Go to system settings and go to Internet Accounts and delete your google account.

Open Terminal

find ~/Library/Preferences -name "*iChat*" -delete

then

rm -rf ~/Library/Caches/com.apple.Messages

then

rm -rf ~/Library/Messages

and reboot



Now open Messages and add your google account via Jabber. Then go to preferences in Messages and go to Accounts and go to server settings and make sure settings are as follows:

Server: talk.google.com

Port: 5223

Check Use SSL

Then go to Account Information and Enable this account

I rebooted again and then opened Messages and made sure my buddy list was there.

Then I went to System Preferences and go to Internet Accounts and add your google account.

Upon doing this a message popped up for me asking to Add Google Talk to Messages and WHOA it is working.

I can now send and receive messages, have my calendar and everything as before.

Before this I could receive messages and see buddies but couldn't communicate with them.



Hope you have the same success I did doing this. Now if I can get AIM to work I would have it all working lol
 

Joe Rossignol

Editor
Staff member
May 12, 2012
630
1,783
Toronto
I figured out a solution for GTalk to work on High Sierra



Go to system settings and go to Internet Accounts and delete your google account.

Open Terminal

find ~/Library/Preferences -name "*iChat*" -delete

then

rm -rf ~/Library/Caches/com.apple.Messages

then

rm -rf ~/Library/Messages

and reboot



Now open Messages and add your google account via Jabber. Then go to preferences in Messages and go to Accounts and go to server settings and make sure settings are as follows:

Server: talk.google.com

Port: 5223

Check Use SSL

Then go to Account Information and Enable this account

I rebooted again and then opened Messages and made sure my buddy list was there.

Then I went to System Preferences and go to Internet Accounts and add your google account.

Upon doing this a message popped up for me asking to Add Google Talk to Messages and WHOA it is working.

I can now send and receive messages, have my calendar and everything as before.

Before this I could receive messages and see buddies but couldn't communicate with them.



Hope you have the same success I did doing this. Now if I can get AIM to work I would have it all working lol
Wouldn't this delete your iMessage history?
 

chenulu

macrumors newbie
Sep 30, 2017
2
0
Those instructions did not work as talk.google.com now redirects to hangouts.google.com. Any other suggestions would be really helpful
 

rodneypoplin

macrumors newbie
Original poster
Sep 27, 2017
5
0
Boerne, TX

toobastank

macrumors newbie
Oct 3, 2017
2
0
Now open Messages and add your google account via Jabber. Then go to preferences in Messages and go to Accounts and go to server settings and make sure settings are as follows:

Server: talk.google.com

Port: 5223

Check Use SSL

Then go to Account Information and Enable this account
I've tried this several times, and as soon as I go to enable the account it disappears. Help?
 

rodneypoplin

macrumors newbie
Original poster
Sep 27, 2017
5
0
Boerne, TX
If you go to System Preferences and then Internet Accounts you will see one or more accounts Remove all of them and start over.
 

esieens

macrumors newbie
May 7, 2006
6
0
Thanks Everyone for your help with this.

Before I delete all my google accounts, would these steps work even if my email address to my google account is not a 'gmail.com' address?

Do you just need to delete the gmail Messages account in Internet Account or all Google accounts (including emails, notes, calendar...)?

Thanks
 

Cochonou

macrumors newbie
Oct 10, 2017
6
3
Thanks a lot for this very useful topic.
I'd have just another question. On this computer, everything works as described, however the password doesn't stick. It's saved in the keyring, but Messages still asks for it at every connection.
Am I the only one experiencing this ?
 

The Jack Burton

macrumors newbie
Oct 11, 2017
2
0
Thanks a lot for this very useful topic.
I'd have just another question. On this computer, everything works as described, however the password doesn't stick. It's saved in the keyring, but Messages still asks for it at every connection.
Am I the only one experiencing this ?

This also happens with me. Not only does it not stick, I have to enter it in multiple times for it to finally accept the password.
 

willywonkanobi

macrumors newbie
Oct 11, 2017
1
0
Texas
Thanks a lot for this very useful topic.
I'd have just another question. On this computer, everything works as described, however the password doesn't stick. It's saved in the keyring, but Messages still asks for it at every connection.
Am I the only one experiencing this ?
My password is remembered fine. I don't have to enter it manually. And the fix works great (except for losing the chat history :-/ ) THANKS!
 

wowthatisrandom

macrumors newbie
Oct 11, 2012
9
0
Thanks a lot for this very useful topic.
I'd have just another question. On this computer, everything works as described, however the password doesn't stick. It's saved in the keyring, but Messages still asks for it at every connection.
Am I the only one experiencing this ?
Happening to me as well. wondering if its related to 2FA. Im using an app password, which makes it annoying when it asks on each login.
 

arthure18

macrumors newbie
Sep 14, 2011
2
0
It worked for me, but now I have one strange (but perhaps insignificant) behavior. When sending messages to people with iMessage accounts, by bubbles are green, not blue as before.
[doublepost=1510088641][/doublepost]
It worked for me, but now I have one strange (but perhaps insignificant) behavior. When sending messages to people with iMessage accounts, by bubbles are green, not blue as before.
nevermind, I restarted Messages and they are back to blue. And GTalk is still working (after a couple of password entries)
 
Last edited:

rmartyni

macrumors newbie
Nov 17, 2017
1
0
this worked for me other than i have to login again each time i come back from sleep or restart. keychain is not remembering the password.

in my situation, i have 2 factor auth on my google account and had to set up the "app password" google account feature for less secure apps to get it to log in. the password i need to use for it to work is that key google generates during that process.

anyone get this to work with 2 factor authentication and it remember your password?
 

MichaPh

macrumors newbie
Sep 28, 2017
3
2
this worked for me other than i have to login again each time i come back from sleep or restart. keychain is not remembering the password.

in my situation, i have 2 factor auth on my google account and had to set up the "app password" google account feature for less secure apps to get it to log in. the password i need to use for it to work is that key google generates during that process.

anyone get this to work with 2 factor authentication and it remember your password?

I had the same problem. So I went in to the KeyChain and searched for "jabber". There I changed all the related accounts passwords to my "app password" and it worked.
 

ZeroGFrame

macrumors newbie
Sep 8, 2008
10
0
I had the same problem. So I went in to the KeyChain and searched for "jabber". There I changed all the related accounts passwords to my "app password" and it worked.
Is there any further update to this issue? I am now getting the same issue, Messages asking for my password repeatedly, and I did everything that was discussed previously.
 

Similar threads

  • mattspace
0
Replies
0
Views
700
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.