GTX 660 bad performances (compared with a 5770)

Discussion in 'Mac Pro' started by TiberioG, May 21, 2015.

  1. TiberioG macrumors member

    Joined:
    Dec 10, 2013
    #1
    Hello mac pro users,
    i have recently bought a new (2nd hand) video card for my mac pro 2008 3ghz OSX 10.9.5

    I have found a very nice EVGA GTX 660 that in theory should be better than my previous ATI 5770 (PC crd flashed).

    But in fact the nvidia card has worse performance compared to the ATI.
    In fact it seems to me that the Mission control's animation with the GTX 660 is more lagging than it was with the ATI.

    Moreover, I had in minecraft not so much FPS and a lot of lag.

    How is it possible?


    thank you in advance for your advice.

    TG
     
  2. TzunamiOSX macrumors regular

    Joined:
    Oct 4, 2009
    Location:
    Germany
    #2
    Do you have a picture of the card? Some fake 660 cards were on the market, a time ago.
     
  3. mikeboss macrumors 65816

    mikeboss

    Joined:
    Aug 13, 2009
    Location:
    switzerland
    #3
    indeed, there were fake GTX 660 on the market. german IT magazine c't wrote about this. article in german -> http://heise.de/-2302667
     
  4. TiberioG thread starter macrumors member

    Joined:
    Dec 10, 2013
    #4

    I think that mine is not a fake...
    Here are two pictures.

    It's very strange that a more powerful card works with less FPS!
     

    Attached Files:

  5. DrNeroCF macrumors 6502

    Joined:
    Sep 2, 2004
    #5
    Try it in Windows maybe. I actually didn't get that much of a boost going from a 570 to a 760 on the Mac side, Apple's drivers are just plain screwy, I think. I've heard that ATI drivers were way better than Nvidia's in OS X at one point, though I'm not sure if that's still the case.
     

Share This Page