GTX 680 Flash

Discussion in 'Mac Pro' started by Energybutton, May 9, 2013.

  1. Energybutton, May 9, 2013
    Last edited: May 9, 2013

    Energybutton macrumors newbie

    Joined:
    Mar 13, 2013
    #1
    I was wondering if anyone could help me with this, I received my 680 (PYN VCGGTX680XPB-CG) yesterday and attempted to flash it using NVFlash 5.134.0.1 in windows XP.

    First of all the ROM I downloaded was a BIN file which I thought I could just rename to .ROM but NVFlash didn't like it and would still throw an I/O error. I then used Nibitor bio editor to import the BIN file and save it as a ROM file, so now I have a usable file.

    I then proceeded to flash the card with the said ROM and NVFlash reported a successful flash so I restarted my MP and I had boot screens! but when trying to get into OSX (10.8.3) It would just hang on the apple logo with the loading wheel and reboot but there isn't a problem getting back into Windows XP, does any one have any ideas of what's going on?

    I used the card to play a few hours worth of gaming before doing the flash and it was fine and again after I put the stock ROM back on and there aren't any artefacts or anything strange.

    Any help would be much appreciated.

    EDIT: I forgot to mention my Mac Pro is a 2009 8 core 2.26Ghz model.
     
  2. cal6n macrumors 68000

    cal6n

    Joined:
    Jul 25, 2004
    Location:
    Gloucester, UK
    #2
    First, the BIOS I used was originally a .bin.zip file. I unzipped it and renamed it the resulting .bin to .rom but I also renamed it so that the filename had 8 characters. I remember reading somewhere that this is important. I flashed under 64-bit win7 with nvflash 5.118 without any problems.

    Second, last I looked nibitor didn't support the GTX 680, but I could be wrong. I'd be suspicious of any .rom it output unless the GTX 680 is specifically supported.

    Third, have you reset PRAM since the flash. Always a good idea with startup problems.
     
  3. Energybutton thread starter macrumors newbie

    Joined:
    Mar 13, 2013
    #3

    I believe I have the same file as you as mines was originally gtx680mac.bin.zip, I have extracted this under OSX and it provides me with gtx680mac.bin which is 218k in size, I have renamed this to gtx680m.rom and have tried to flash this and NVFlash displays "I/O ERROR: Cannot open file: gtx680m.rom"

    I have noticed that you can extract the bin file again in OSX which provides you with gtx680mac.bin.cpgz which can be changed to a ROM file which is 177kb in size and is recognised as a ROM file (original Pc rom is 183kb OSX 179kb in Windows) but provides a huge warning about mismatches I didn't tell it to go ahead as it seems different from everyone else's flash procedure. (see below)

    [​IMG]


    How big was the ROM that you flashed your card with?

    I did also try a PRAM reset, it didn't make any difference.
     
  4. Energybutton thread starter macrumors newbie

    Joined:
    Mar 13, 2013
    #4
    Hi cal6n,

    I came across one of your other threads where you had posted an actual ROM file for the 680 and gave that a bash, it worked!

    Thanks for your help!

    [​IMG]
     
  5. cal6n macrumors 68000

    cal6n

    Joined:
    Jul 25, 2004
    Location:
    Gloucester, UK

Share This Page