GTX 680 for mac pro

Discussion in 'Mac Pro' started by Decathlon, Jan 24, 2014.

  1. Decathlon, Jan 24, 2014
    Last edited: Jan 24, 2014

    Decathlon macrumors member

    Joined:
    Jun 12, 2011
    #1
    I have ordered a card like this.

    I wasn't sure where to direct my question, but i was hoping anyone would have some experience in this area, since i am having a 30 inch older cinema display. And if anyone have seen this problem and dealt with i would love to hear some fixes :)

    Hes problem was the machine would only boot to the white screen, then stopped ?

    Just for future reference or anyone else who might be having a similar issue.
    This problem turned out to be related to the monitor.

    We used a 30-inch Apple Cinema Display. When that is plugged in, the card doesn't work. When that is diconnected, and replaced with a Dell screen, the card works fine. The monitor works fine with the Radeon card, but not the GeForce.
     
  2. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #2
    The GTX 680 should work fine with the 30" ACD. How were you connecting the two?
     
  3. tomvos, Jan 24, 2014
    Last edited: Jan 25, 2014

    tomvos macrumors 6502

    tomvos

    Joined:
    Jul 7, 2005
    Location:
    In the Nexus.
    #3
    I have a old Mac Pro (5.1) with an EVGA GTX680 2GB (PC) flashed with the official EVGA Mac firmware. So I guess the GTX680 can be considered to be as close as possible to the „true“ GTX680 Mac Edition. And I have a Apple Cinema Display 30“ (30-inch DVI Late 2005) connected to this video card. Needless to say, this combination works fine.

    Perhaps there is a difference between the first and the second revision of the 30“ Cinema display that would result in the problem you’ve encountered?
     
  4. Decathlon thread starter macrumors member

    Joined:
    Jun 12, 2011
    #4
    Nice.

    they had me worried. I'm going ahead with the upgrade.
     

Share This Page