GTX 680 problems with Sierra

Discussion in 'Mac Pro' started by gatd, Sep 21, 2016.

  1. gatd macrumors member

    Joined:
    Jun 2, 2008
    #1
    I have a mac flashed GTX680 4GB , flashed from the upload I found in these forums I need to run 4 monitors, I have never had any problem in doing so in el capitan I just reinstalled the earlier nvidia drivers from yosemite I think (the last working apple drivers for 4 monitors)after any update and all was working good.
    Today I installed Sierra only three monitors working then reinstalled the early nvidia drivers and got all 4 monitors working again.
    There seems to be a problem now with the graphics, slow and flickering jumpy with slight tearing when I go on the dock siri etc. I tried turning reduce transparency on but not much better
    any help please? thanks
     
  2. Draeconis macrumors 6502a

    Joined:
    May 6, 2008
    #2
    You're trying to use a Yosemite driver in Sierra? That's probably not going to work well.
     
  3. ActionableMango, Sep 21, 2016
    Last edited: Sep 21, 2016

    ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #3
    Reflash your card with Florian's 4GB ROM, replacing Dr. Stealth's 4GB ROM which you are using now. Florian's ROM is posted somewhere in the same thread. Then use the latest and correct drivers for your OS. This will fix your dead upper DVI port.
     
  4. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #4
    Is it possible to run a Yosemite driver in Sierra? I think the Nvidia web driver is build specific, otherwise, there is not so much trouble to run those maxwell card.
     
  5. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #5
    There is no reason to run old drivers in this situation. At some point in Yosemite, an update broke the upper DVI port for GTX 680 4GB using the Dr Stealth ROM. OP needs all 4 ports working for his 4 monitors, so he keeps using the older Yosemite drivers in newer version of OS X, which is problematic as he is seeing now.

    Florian's 4GB ROM is not affected by whatever update in Yosemite and later that broke the upper DVI port in the first place, so using that ROM will work with all 4 ports. Then OP can use appropriate drivers for OS X and stop using drivers from 3 OS version back, which is probably causing his new problems.

    Frankly, I'm surprised Yosemite drivers worked at all in Mavericks, El Capitan, and Sierra. There have been a ton of graphics-related changes.
     
  6. gatd thread starter macrumors member

    Joined:
    Jun 2, 2008
  7. CapnDavey macrumors 6502

    CapnDavey

    Joined:
    Apr 11, 2015
    #7
    I'm running a EVGA GTX680 2 gig that I flashed no issues in 10.12 with video so far
     

Share This Page