GTX 680MX Bootcamp Drivers !?

Discussion in 'iMac' started by RNeon, Dec 19, 2012.

  1. RNeon macrumors newbie

    Joined:
    Mar 13, 2011
    #1
    Hey guys,

    i´m looking for better drivers for the GTX 680MX in my iMac Late 2012.

    At Nvidia there are only for the GTX 680M. Any ideas where i can get better one for better Performance under Windows Bootcamp?
     
  2. gecko20 macrumors regular

    Joined:
    Dec 12, 2012
    Location:
    Esch Alzette / Luxembourg
    #2
    they seem to work ^^
    http://www.geforce.com/drivers/results/54629
     
  3. joe-h2o macrumors 6502a

    Joined:
    Jun 24, 2012
    #3
    Right now just use the latest notebook driver - the 310.70 driver. They had a WHQL set signed by Microsoft on the 17th or 18th.

    A few people on the boards have reported that these do give better performance than the stock driver Apple supplies (which is the 306. one I think).

    Nvidia should be releasing a driver set that includes specific support for the 680MX in the future I believe.
     
  4. Razorhog macrumors 65816

    Razorhog

    Joined:
    Sep 16, 2006
    Location:
    Arkansas
    #4
    310.70 driver works well. Far Cry 3 runs great at native resolution.
     
  5. RNeon thread starter macrumors newbie

    Joined:
    Mar 13, 2011
    #5
    Thank you guys. Now i´ve installed the drivers you prefered me. And now the Video Card runs great !!! Thank you !!! :)
     
  6. Buskins macrumors member

    Joined:
    Feb 14, 2012
    #6
    When you install the drivers, do you have to uninstall the ones Bootcamp Assistant installs when you use Windows Support after getting onto windows side.
     
  7. joe-h2o macrumors 6502a

    Joined:
    Jun 24, 2012
    #7
    No you don't. The Nvidia installer simply installs over them with no problems.
     
  8. zarf2007 macrumors regular

    Joined:
    Aug 27, 2010
    #8
    i've installed the nvidia drivers listed above but noticed that when playing far cry 3 the fans are whirring loudly and seem to be running full speed....anyone else had this?

    I am running windows 7 off a lcie 256gb thunderbolt external drive (it was wincloned across). I installed the latest bootcamp drivers/windows updates then the nvidia drivers....
     

Share This Page