GTX570 output isuues

Discussion in 'Mac Pro' started by juliendeka, Jun 19, 2012.

  1. juliendeka macrumors newbie

    juliendeka

    Joined:
    Jun 19, 2012
    Location:
    Detroit
    #1
    Hi everyone,

    like many, I did upgrade recently to a GTX570 from MacVidCards, in order to use the CUDA engine with adobe CS6 softwares.

    I have a MacPro 4,1.

    I use to have an ATI graphic card (don't remember the exact model) + a GT 120. The GT 120 worked fine on both ports (mini-display + DVI)

    Now, that I have the new GTX 570, the GT 120 mini-display port doesn't work anymore, but only the DVI.

    On my GTX 570, I have 2 DVI, 1 HDMI, 1 Display Port... But so far I've been only able to get the Display Port and 1 of the 2 DVI to work.

    I read it is normal for the GTX 570 (don't know why though). But I don't get why my GT 120 stopped to work suddenly.

    Long story short, I have 6 physical ports on 2 cards, but only 3 of them work.

    And I need 4 ports (2 screen for UI, 1 grading monitor, 1 Wacom Cintiq)...

    Can anyone, help me to figure a way of making my GT 120 work again?

    Thanks in advance.

    Julien
     
  2. MacVidCards Suspended

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #2
    yank the 570 and see if GT120 still works via MDP

    GT120 should not be affected by 570

    Did you do anything else to drivers?

    The 570 (and ALL Nvidia cards prior to GTX680) were only able to run 2 separate display channels. Windows can dynamically switch between multiple ports but OSX can not.

    When PC Quadro 4800 came out, it had 3 ports, for Mac version they physically removed one of them.

    When PC Quadro 4000 came out, it had 3 ports, for Mac version they physically removed one.

    I had to choose which of the 4 ports to enable, I choose DVI and DP as these 2 offered greatest range of options.

    Even the lofty 680 which can run 4 display channels is currently limited in OSX to 2. It is just how it is.
     
  3. degl macrumors member

    degl

    Joined:
    Jun 12, 2010
    Location:
    Caracas
    #3
    Hi MVC;

    The Gtx570 are you selling can have both DVI active? i don't use DisplayPort and my 2 monitors have DVI inputs, can be used with your GTX 570?

    Cheers
     
  4. juliendeka thread starter macrumors newbie

    juliendeka

    Joined:
    Jun 19, 2012
    Location:
    Detroit
    #4
    Hi MVC,

    I did like you said, I pulled out the 570 and the 2 ports worked fine on the GT 120...

    Then I kept a step by step protocol, putting back the GTX570 but not plugging any monitor to it = GT120 was still working.

    Then I plugged only one monitor to the GTX570, it was still working. Then I finally plugged 2 monitors to it, and the GT 120 was still working.

    So my bad, something must have moved inside the Mac Pro when I plugged the GTX, because at the end it looks like just a bad PCI connection.

    Now it works. Thanks you

    Julien
     

Share This Page