Guest Account needs to be turn off!

Discussion in 'iMac' started by I WAS the one, Jul 7, 2015.

  1. I WAS the one macrumors 6502a

    I WAS the one

    Joined:
    May 16, 2006
    #1
    I've been paranoid recently about a thing that has been happening for more than two weeks now. Every time I felt my iMac slower than normally is and the beach ball from hell start appearing more than usual I check my user name in my menu bar and for some reason the Guest Account has a check mark as if someone was using it before me. I was in the believe that because I normally use 'Screens' in my iPhone to access my iMac for some reason the guest account activate it self as a bug on the 'Screens' app or something else.

    I'm the only one who use my iMac. No other person have access to it so that's why I was like: "What is going on with this 'Guest Account' being active every now and then?" Ok, Well... last night I was working late on a audio-editing job on other computer in the same office at 2am in the morning when suddenly everything start happening in front of my eyes! my Mac wake up and login by itself as a guest account open up safari and went to a Whoiswhatever.com site and search for my IP address info!

    What? or Who? or Since When? OMG now I'm scare and honestly I don't know what to do now, it's obvious that someone is accesing my iMac but who? how can I stop this? Is there a way to block guest access account? Please Help.

    My immediate solution is turning off my iMac at night but I need it in standby always for my job needs.

    Please any help will be apreciate it.
     
  2. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #2
    If you have Find my Mac active, Guest Account will be activated. This is so that if someone steals your iMac, the thief will log into the guest account and henceforth connect to the internet, which will immediately connect to iCloud to check whether Lost Mode has been activated or not. If it has been activated, the iMac will broadcast its location and instantly lock itself up.

    If your Mac woke up by itself or whatever, it's possible that someone may have connected remotely from another Mac on the same LAN and accessed the guest account. To prevent others from accessing your Mac on the LAN, do this:

    1. Go to System Preferences → Sharing
    2. Make sure that EVERYTHING is unchecked.
     
  3. I WAS the one thread starter macrumors 6502a

    I WAS the one

    Joined:
    May 16, 2006
    #3
    Well, I use Screens to access my home iMac from my Office iMac so I can't block access. any other suggestion?
     
  4. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #4
    @I WAS the one You can disable the Guest account in System Preferences > Users & Groups.
     

Share This Page