Guest User Account Bug

Discussion in 'OS X El Capitan (10.11)' started by ThePhazonMonkey, Oct 7, 2015.

  1. ThePhazonMonkey macrumors newbie

    ThePhazonMonkey

    Joined:
    Oct 7, 2015
    Location:
    Mexico
    #1
    Hi everyone,

    I'm super annoyed and a bit worried: every time I reboot OS X El Capitan, the Guest User account appears in the login screen. No matter how many times I activate and deactivate the account in system preferences it shows up again when I reboot. Is anyone having a similar issue? Does anyone know how to fix it?

    I'm worried because this means that strangers can get access to my Macbook. I know they cannot access my files and etc etc but I don't want unauthorized people using my Macbook!

    MacBookPro11,3
    OS X 10.11

    Cheers!
     
  2. DHagan4755 macrumors 6502a

    DHagan4755

    Joined:
    Jul 18, 2002
    Location:
    Massachusetts
    #2
    I think this gets activated when you turn on Find My Mac.
     
  3. oGu macrumors member

    Joined:
    Sep 19, 2007
    #3
    I also got this bug. I first got it installing on my MBPr the GM clean. After installing over the GM the Appstore version the bug disappeared. Now I did a clean install with the final version on my MBr and I get the same issue.

    Any tips on fixing this?
     
  4. ThePhazonMonkey thread starter macrumors newbie

    ThePhazonMonkey

    Joined:
    Oct 7, 2015
    Location:
    Mexico
    #4
    Well that is really idiotic, isn't it? Having Find My Mac activated should make the OS more secure, not the other way around.
     
  5. xgman macrumors 601

    xgman

    Joined:
    Aug 6, 2007
    #5
    Same issue here. Seems you are stuck with Guest no matter what.
     
  6. oGu macrumors member

    Joined:
    Sep 19, 2007
    #6
    That is just bogus.

    Find my Mac does not activate this. I never had this issue with any other OSX version except for El Capitan.
     
  7. xgman macrumors 601

    xgman

    Joined:
    Aug 6, 2007
    #7
    I think the bug is maybe where if you don't first deactivate Guest upon installation, it doesn't remove the guest acct later when you disable it in prefs. Maybe the guest acct won't actually log-in if you have it disabled. Anyone try it yet just to see?
     
  8. DHagan4755 macrumors 6502a

    DHagan4755

    Joined:
    Jul 18, 2002
    Location:
    Massachusetts
    #8
    Well if someone steals your Mac, and the Guest account isn't enabled, how's the thief supposed to join a wireless network so you can track where your Mac is?
     
  9. oGu macrumors member

    Joined:
    Sep 19, 2007
    #9
    Well I did try to see if it works and guess what even if it's disabled in control panel I can easily login as a guest. This is a hit ridiculous as I was able to disable this account prior to El Capitan.
     
  10. xgman macrumors 601

    xgman

    Joined:
    Aug 6, 2007
    #10
    Not good. Wonder if this is fixed in today's beta?
     
  11. c8rlo, Oct 7, 2015
    Last edited: Oct 7, 2015

    c8rlo macrumors 6502

    c8rlo

    Joined:
    Sep 1, 2015
    Location:
    FL
  12. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #12
    What does complete the process mean?

    -Kevin
     
  13. c8rlo macrumors 6502

    c8rlo

    Joined:
    Sep 1, 2015
    Location:
    FL
    #13
    sorry to be confusing, it had to with FileVault in System Preferences>Security&Privacy...
     
  14. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #14
    Yeah that's what I'm not understanding. For me, I select Find My Mac.....it spins for a second and then shows checked. Is there something else you are doing?

    BTW....what's odd is I have a Macbook Air that has Filevault on, yet the Guest User does NOT show on the login screen. I just had my Mom enabled Filevault, and we can't get the Guest user to go away....no matter what we do.

    -Kevin
     
  15. c8rlo macrumors 6502

    c8rlo

    Joined:
    Sep 1, 2015
    Location:
    FL
    #15
    kbmb,

    i had the exact issue with my MBA as well...i'm currently looking for the article i read that fixes this problem.
     
  16. DiCaprioAngel macrumors 6502

    Joined:
    Jul 12, 2013
    Location:
    New York
    #16
    I noticed this on my MacBook Pro too, it's kind of annoying because I do not want a guest account activated and this issue didn't occur when I first upgraded to El Capitan. I started noticing it about two days ago.
     
  17. oGu macrumors member

    Joined:
    Sep 19, 2007
  18. DiCaprioAngel macrumors 6502

    Joined:
    Jul 12, 2013
    Location:
    New York
    #18
    Hopefully they'll come up with a solution soon because it is rather annoying
     
  19. oGu macrumors member

    Joined:
    Sep 19, 2007
    #19
    Still no solution. This is becoming ridiculous. It's 10.11.2 now. If I do any fresh install I get this bug.
     
  20. b0fh666 macrumors 6502a

    b0fh666

    Joined:
    Oct 12, 2012
    Location:
    south
    #20
    as said before, the guest acct is activated by the find my mac feature... at least since maveriks IIRC.

    give it a rest :)
     
  21. rkonopka macrumors newbie

    Joined:
    Dec 29, 2015
    #21
    Well that may be so, but the behavior is inconsistent at best. I've got 3 MBP all running El Capitan and all 3 have FileVault turned ON, and Find My Mac turned ON. Yet only one of the computers is showing the Guest Account on the login screen.

    From my experience, there is something else that is going on that is causing this behavior.

    -Ray

     
  22. Renecek macrumors member

    Joined:
    Jun 1, 2011
    #22
    Any new solution please? Have this "bug" on my MacBook Pro Retina 2015 too..
     
  23. nnyymm, Jun 17, 2016
    Last edited: Jun 21, 2016

    nnyymm macrumors regular

    Joined:
    Nov 30, 2010
    Location:
    Singapore
    #23
    Found a solution,

    1. Make sure “Find My Mac” and Guest User are disabled, reboot;

    2. Check whether System Integrity Protection is enabled or disabled by running: csrutil status at the Terminal.

    3. If it says "System Integrity Protection status: enabled." proceed to 4.1,

    4. if not, only do 4.4 and 4.7;

    4.1. Reboot into "Recovery Mode": Shutdown and hold Command + R after pressing the power button;​

    4.2. Go into "Utilities > Terminal" and run the command: csrutil disable;​

    4.3. Reboot;​

    4.4. Open the Terminal and run: sudo touch /System/Library/PrivateFrameworks/EFILogin.framework/Resources/EFIResourceBuilder.bundle/Contents/Resources, this will force the EFI login update;

    4.5. Reboot(again) into "Recovery Mode": Shutdown and hold Command + R after pressing the power button;

    4.6. Go into "Utilities > Terminal" and run the command: csrutil enable;

    4.7. Reboot and it’s fixed!

    4.8. Re enable “Find My Mac” as you wish.​
     
  24. Coltaine macrumors regular

    Coltaine

    Joined:
    Jan 7, 2012
    #24
    This solution actually worked for me.

    How did you find this?

    I would not consider this "obvious" by any means!

    Thank you very much!!
     

Share This Page