iPhone [Guide] Evasi0n Weather App fix

Discussion in 'Jailbreaks and iOS Hacks' started by bmash, Feb 7, 2013.

  1. bmash macrumors newbie

    Joined:
    Feb 7, 2013
    #1
    Try this if you updated the pkg (UIKit tools) in cydia and rebooted and the weather app still crashes.

    @planetbeing : https://twitter.com/planetbeing/status/299205571507257344
    Guide:
    1) Install iFile in cydia or use any filesystem manager for your idevice.
    2) Navigate to \private\var\mobile\Library\Caches
    3) Delete com.apple.mobile.installation.plist
    4) iFile may unexpectedly quit but reopen iFile
    4) Delete com.apple.LaunchServices-045.csstore
    5) Reboot
    6) You may notice some app icons on your springboard is gone
    7) Wait patiently:) and the app icons will gradually reappear.
    8) Try opening the weather app.

    This fix helped me and I hope it will for you too.:)
     
  2. kalirob99 macrumors 68000

    kalirob99

    Joined:
    Dec 24, 2008
    Location:
    California
    #2
    :/ It didn't work for me, still not opening after delete and reboot.
     
  3. Danoots macrumors newbie

    Joined:
    Nov 12, 2010
    #3
    Did you delete AppSync before you did the steps?

    Delete AppSync from Cydia should be step 1
     
  4. kalirob99 macrumors 68000

    kalirob99

    Joined:
    Dec 24, 2008
    Location:
    California
    #4
    I did it again a second time just now and it worked. Odd, (as I don't have AppSync) but I won't question it as long as it's working again lol. I gather the other issue was a way to keep some people from pirating apps?
     
  5. Danoots macrumors newbie

    Joined:
    Nov 12, 2010
    #5
    I'm confused, you tried it with AppSync deleted or without?
     
  6. kalirob99 macrumors 68000

    kalirob99

    Joined:
    Dec 24, 2008
    Location:
    California
    #6
    Without, I don't have AppSync, sorry I'm tired at the moment lol.
     
  7. Mvkoe macrumors member

    Mvkoe

    Joined:
    Aug 4, 2008
    Location:
    Belgium
    #7
    THIS WORKED FOR ME (With Appsync installed at the end!)

    1. Delete Appsync
    2. Make a backup of your phone
    3. Restore and rejailbreak
    4. Weather should work now
    5. Open cydia let it do al the updatedes
    6. now install Appsync as last.

    This worked for me ;)
     
  8. dontpannic macrumors 6502

    dontpannic

    Joined:
    May 16, 2011
    Location:
    Orpington, Kent, UK
    #8
    It worked for you because evasi0n 1.1 fixes the weather problem... ;)
     
  9. MrGimper macrumors 601

    MrGimper

    Joined:
    Sep 22, 2012
    Location:
    Andover, UK
    #9
    You're assuming he downloaded the new evasion 1.1 and didn't use the 1.0 he already had.
     
  10. dontpannic macrumors 6502

    dontpannic

    Joined:
    May 16, 2011
    Location:
    Orpington, Kent, UK
    #10
    Did that need pointing out?

    Of course that assumption is there, but given how well publicised it has been that evasi0n 1.1 fixes long boots and the weather app bug you'd download the latest version of the evasi0n tool?
     
  11. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #11
    Don't worry your iCloud apps are still probably messed up :p
     
  12. Mvkoe macrumors member

    Mvkoe

    Joined:
    Aug 4, 2008
    Location:
    Belgium
    #12
    What would be messed up ? iCloud works fine here for my notes, contacts, mails etc ?
     
  13. iRooney macrumors 6502

    iRooney

    Joined:
    Jul 14, 2011
    Location:
    Charleston, SC
    #13
    I'm curious as I've never tried...do iCloud restores work with a jailbreak just like they do stock?
     
  14. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #14
    Don't know which apps in specific, but planetbeing talked about it messing up some apps that are integrated with iCloud.
     
  15. Snesley Wipes, Feb 8, 2013
    Last edited: Feb 8, 2013

    Snesley Wipes macrumors regular

    Joined:
    Jun 29, 2009
    #15
    Now do you restore to "pre-jailbreak" backup, or just restore to your jailbroken restore backup that you just did?
     
  16. Snozzberries, Feb 8, 2013
    Last edited: Feb 8, 2013

    Snozzberries macrumors newbie

    Joined:
    Feb 6, 2013
    #16
    Not all my icons are reappearing. Help?!

    Edit: After a couple of reboots they finally appeared.
     
  17. axledentaldj macrumors member

    Joined:
    Oct 18, 2009
    #17
    Followed first post instructions and it worked for me once I did the first step and remove Appsync. Weather App is now working.
     
  18. 7heM4cM4n macrumors newbie

    Joined:
    Oct 16, 2011
    #18
    apps not showing back up.... help!

    even the weather app isnt working. so that was just a waste of a try. someone please help!
     
  19. sassenach74 macrumors 65816

    sassenach74

    Joined:
    May 3, 2008
    Location:
    Hampshire, England
    #19
    I found you don't need to uninstall appsync, before you do the above, go to springtomize>more>mobilesubstrateaddons and turn off appsync. Then do the above, reboot once your icons are back, then turn appsync back on. Worked for me iPhone 4S ios 6.1.

    Neil.
     
  20. Demonface macrumors 6502a

    Joined:
    Mar 13, 2012
    Location:
    Jersey/Miami
    #20
    Might end up trying this . Hopefully it works.
     
  21. dontpannic macrumors 6502

    dontpannic

    Joined:
    May 16, 2011
    Location:
    Orpington, Kent, UK
    #21
    READ!

    We have helped!

    Run the Cydia updates

    Remove appsync

    Run the manual process

    All of these work!
     
  22. Demonface macrumors 6502a

    Joined:
    Mar 13, 2012
    Location:
    Jersey/Miami
    #22
    Well I did all of the steps and it worked prefectly . I personally think this thread should be stickied .
     
  23. AlexBlaha macrumors newbie

    Joined:
    Feb 13, 2013
    #23
    I did this and my weather app works, thanks. But my icons still haven't reappeared. I rebooted for what must have been 6 times now and it's been hours. Just starting to get a little worried.. Though I'll leave it overnight then reboot.
     
  24. TM WAZZA macrumors 68000

    Joined:
    Sep 18, 2010
    Location:
    Hamilton, New Zealand
    #24
    Try a respring
     
  25. Anajaf27 macrumors regular

    Joined:
    Sep 23, 2012
    #25
    I dont have com.apple.mobile.installation.plist

    Or even launch services?
     

Share This Page