Guide: Getting NES roms to iPhone

Discussion in 'Jailbreaks and iOS Hacks' started by alecapple, Mar 12, 2008.

  1. alecapple macrumors regular

    Joined:
    Feb 23, 2008
    #1
    Alright so i know a lot of people are having trouble with getting NES roms to their iphone, or at least i was, and i think i have discovered the easiest way to get about 30 or so roms onto your phone, and I'll explain.

    What you need-
    Jailbroken iPhone
    Newest version of installer (3.01)
    NES (the emulator itself), already installed
    BSD Subsystem

    Step one:
    Open installer and add "http://markmon.mine.nu:90/iphone/repo/repo.plist" as a source.

    Step two:
    Exit installer, And restart your phone.

    Step three:
    Open Installer, go to the games sub-menu, and you will see a package entitled "NES roms" (Version 1.20), install it.

    Step four:
    Restart your phone once more.

    When you open the nes application you will now see a list of 30 or so games. If you do not see the "NES Roms" package right away be patient, it took a while for it to show up for me.
    Enjoy!
    And let me know of any troubles.


    Troubleshooting:

    You may want to verify that you have everything that i have listed under the "What you need section"

    Make sure that you entered the source correctly

    Make sure you are on a wi-fi network, not edge

    When you enter iphone in the source it will suggest that you change it to i"P"hone but you dont. Capitolization matters

    First solution:
    I jailbroke using ziphone, i beleive version 2.5b. I have an 8gb iphone. if you did it someother way and you really want this to work you may want to restore, and jailbreak again.

    Second solution:
    When your in installer you may want to go to the source section and verify that you have the source at the bottom. (It should be under Uncategorized, and that it is also an Untitled source)

    Third solution:
    When your in the sources tab, tap refresh on the top left of the screen.

    Fourth solution:
    Keep restarting your phone. (actually turning it off and then on again)

    Fifth solution:
    Reset your phone by holding down the sleep/wake button along with the home button, until it shuts down and restarts. (should take about 10 seconds)

    I just removed the source and the package, and added the source over again, and the NES Roms package was there again so i can verify that it does indeed work.
     
  2. ViPa macrumors 6502a

    Joined:
    Dec 4, 2007
  3. Yagyu Jubei macrumors newbie

    Joined:
    Mar 8, 2008
  4. Yagyu Jubei macrumors newbie

    Joined:
    Mar 8, 2008
    #4
    i add the source but the NES roms folder is not there
    frustrations are a plenty!
     
  5. Yagyu Jubei macrumors newbie

    Joined:
    Mar 8, 2008
  6. ViPa macrumors 6502a

    Joined:
    Dec 4, 2007
  7. CoryBoyUSA macrumors member

    Joined:
    Aug 7, 2007
    #7
    It's never showed up in my Installer either, and I've waited an hour or more. Perhaps the source URL is wrong or something, because I've never had to wait for apps to show up after adding any other source. Kinda disappointed especially because it feels like I've wasted my time trying to get this to work.
     
  8. iJimmy macrumors regular

    iJimmy

    Joined:
    Feb 4, 2008
  9. NeoZ24 macrumors newbie

    Joined:
    Jan 22, 2008
    #9
    Its easy to use ibrickr, just download the fix if you used ziphone. Then you can add files to your iphone. The roms are easy to find on google.
     
  10. alecapple thread starter macrumors regular

    Joined:
    Feb 23, 2008
    #10
    Alright so people are still having problems...i'm going to add a troubleshooting section to the original post, with all the possible causes and solutions. Please, if you have tried this method and it has worked just let me know that it did for you so i know the guide is not completly useless.

    -alec
     
  11. VoodooDaddy macrumors 65816

    Joined:
    May 14, 2003
    #11
    I added the source the OP posted and nothing either. Did a search and found 123locker.com, added that as source and the NES roms came up right away.
     
  12. Stryker908 macrumors newbie

    Joined:
    Mar 4, 2008
    #12
    Worked for me too ! Yummy
     
  13. swapna81 macrumors member

    Joined:
    Mar 11, 2008
    #13
    how can we delete the added sources from the installer??
     
  14. idonotliketostu macrumors 6502

    Joined:
    Feb 28, 2008
    #14
    I prefer the FUGU way :D

    mainly because I hate typing on my iphone.
     
  15. idonotliketostu macrumors 6502

    Joined:
    Feb 28, 2008
    #15
    Yes you can, just go to sources, hit edit and press the red minus sign.
     
  16. rumbletum macrumors regular

    Joined:
    Apr 2, 2005
    Location:
    Wolverhampton, UK
    #16
    Didn't work for me either but the 123locker method did, thanks VooDooDaddy :)
     
  17. paramsaluja macrumors newbie

    Joined:
    Feb 12, 2008
    #17
    how to use ibrickr with 1.1.3 ziphone jailbreaked??pls reply
     
  18. alecapple thread starter macrumors regular

    Joined:
    Feb 23, 2008
    #18
    You need to make sure that the capitolization is correct. I installed the roms on one of my friends ipod touches today, and they were there.
     
  19. atifhasan86 macrumors newbie

    Joined:
    Aug 20, 2008
    #19
    better off just add
    apt.123locker.com as a source in Cydia
    let it do its thing and VOILA!!!!!!!
    u'll see the Nes roms package in games

    enjoy
     
  20. Tokiopop macrumors 68000

    Tokiopop

    Joined:
    Dec 6, 2008
    Location:
    West Yorkshire, UK
    #20
    Or you could just put http://apt.123locker.com/ into cydia. That gives you all the NES, GBA, and Genesis ROM Packs.

    Edit: DAMN! Beaten to it. :(:(
     
  21. jlpippin macrumors newbie

    Joined:
    Jan 27, 2009
  22. atlantatan1 macrumors member

    Joined:
    Feb 8, 2009
    #22
    Thank you.
     
  23. TJisYeah macrumors member

    Joined:
    Jan 12, 2009
    #23
    its funny that you reply to this thread. considering this site does not tolerate this kind of talk .. and you yelled at someone for doing the same exact thing your doing now in another thread. your not as perfect as you think you are


    niiiiiiiiice
     
  24. Siamex Twin macrumors newbie

    Joined:
    Feb 12, 2009
    #24
    Hmm...how come when I add it as a source it won't come up? It gives me the whole spiel about legacy and such. Is there something I'm missing?
     
  25. UFMatt macrumors member

    UFMatt

    Joined:
    Jan 28, 2009

Share This Page