[Guide] How To Install Windows 8 RTM

Discussion in 'Windows, Linux & Others on the Mac' started by mac-hacks, Aug 17, 2012.

  1. mac-hacks, Aug 17, 2012
    Last edited: Apr 12, 2013

    mac-hacks macrumors regular

    Jan 14, 2011
    Swimming In Tsunami
    ### Alternative Install method for Windows 8 RTM x64 Booting UEFI

    *"I kept getting install errors with Windows 8 Consumer Preview. I notice it made "WINRE" and 2nd "EFI" partitions, which I do not care for. I started looking for alternative way to install Windows 8 on 2011 Macbook Pro and 2010 MacPro."*

    * *No Slip-streaming or autounattend.xml*
    * *Use at your own Risk. Back all your "DATA"*

    * *Guide has been tested & works on Mac Pro 2010 & MacBook Pro 17" 2011*
    * *No Issue with Drivers on my Mac Pro with Nvidia Quadro 4000 for Mac*
    * *Work around for Macbook Pro 2011 Black Screen Issue*
    #### Prerequisites:

    * Lion USB Installer: "There are plenty of guides online if you need help"
    * Create folder, I named mine "win82Mac" on "/root" of WinPE4.0 USB. [Download WINPE4.0][1]
    * Extract install.wim from Windows 8 Pro x64 RTM 9200 , found in "/Windows/Source/" to "/USB/win82Mac/"

    #### Optional - Add newer updated Drivers:

    * *Select Apple "BOOTCAMP.app" found in OSX/Application/Utility. Choose option to "Save to Disk"*
    * *After download is finish, move Windows Support Folder "aka: Windows BOOTCAMP Installer" to /win82Mac folder on [WINPE 4 Flash Drive.](http://www.adminosx.com/screenshots/win82Mac/win2mac-usb.jpg)*

    * *Update all possible drivers before installing Bootcamp, delete drivers in Windows Support folder that match new ones.*
    * *Delete ATI & Nvidia folders, none of them work.*
    * *Delete all BOOTCAMP 32-bit .exe*
    * *Post-Install, Bootcamp Partition will be slimmed down and only install left over x64-bit drivers that are needed.*

    #### Very Important to remember following:

    * *Remember to Change installer Settings before installing BOOTCAMP*
    * *Locate & Right click setup.exe in Windows Support folder*
    * *Change compatibility to Windows 7 and Run as Administrator*
    #### Step 1 - Boot WINPE 4.0:

    01) Hold Option on REBOOT, select "Yellow USB" disk from BOOT menu name "EFI"
    02) Open Command Prompt:

    # Type:
    		list disk 
    		select disk 0 
    		convert gpt 
    		create partition efi size=200 
    		format fs=fat32 quick label=EFI 
    		create partition primary size=75000 # Size for OS X Partition 
    03) Hold Option on Reboot.
    04) Select External "HD" with OS X or USB OS X installer from "EFI" boot menu.

    *** *Watch Install [Video](http://vimeo.com/48053238) for this Section.*

    #### Step 2 - Install OS X:

    01) Select Show Package Contents on either Install Mountain Lion.app or Lion.app.
    02) Navigate to /Contents/SharedSupport/
    03) Mount InstallESD.dmg
    04) Select installer from mounted .dmg"
    05) Do not install OS X by .app located in /Applications, you will reformat EFI.
    06) I think one of issue has to do with certain SSD and how there formatted.
    07) If your using SSD or having trouble just installing Windows 8 UEFI, read this post for more info.
    08) Boot "USB" LION Installer or External OS X Drive.
    09) Open "Disk Utility.app"
    10) Format UN-formated partition "Format as Mac OS Extended (Journaled)"
    11) Install "OS X" - *Note: OS X Recovery HD will be created*

    *** *Watch Install [Video](http://vimeo.com/48054086) for this Section.*

    #### Step 3 - Install Windows 8 x64 RTM:

    01) Boot WINPE4.0 (Hold Option on reboot)
    02) Select Yellow "USB" disk from BOOT menu name "EFI".
    03) Open "CMD" prompt & Type:

    		list disk 
    		select disk 0 
    		list partition 
    		create partition msr size=128 
    		create partition primary size=?MB? 
    		format fs=ntfs quick label=Windows 
    		assign letter=Y 
    		select partition 1 
    		assign letter=S 
    		list volume
    		# remember WinPe 4.0 USB drive 
    *** *Watch [Video](http://vimeo.com/48058578) for this Section.*

    #### Step 4 - Apply the image to the Windows partition:

    01) "CMD" prompt ">", has to be elevated to:

    02) WINPE4 should be ":C:" change "C" to match WINPE4 USB.
    03) Verify: Type following in Command Prompt.
    list disk
    04) Apply Image.

    dism /apply-image /imagefile:C\:win82Mac\install.wim /index:1 /applydir:Y:
    05) Prepare the system partition by typing following in Command Prompt.
    *Note: "/l en-us" country code it will load from menu on 1st boot. Change it if you need to.*

    		Y:> bcdboot M:\Windows /l en-us /s M: 

    *** *Remove WINPE4.0 "USB" on reboot!!!*
    *** *Hold "Option" to boot Windows 8. Select "EFI" disk"*

    #### Step 5 - Macbook Pro 2011 Work Around:

    01) Start off by resetting VRAM/PRAM x 3 (MBP reboots x3 while holding Command-Option-P-R)
    02) Hold "Option" on last VRAM/PRAM BOOT to load "Boot" menu.
    03) Select Grey "HD" label "EFI" from "Boot" menu.
    04) Windows 8 starts loading. You will see Splash Screen for about 15 Second. During "loading settings"It will get around 30% then monitor goes black & few minutes later it reboots.
    05) Next Windows 8 Boot, same 15 second Splash screen starts loading and monitor goes BLACK.
    06) Be patient do not touch mouse or keys and wait around 10+ minutes.
    07) Hit "Enter" few times, it should power off.
    08) Give it at least 15 minutes and force shutdown if it does not power-off.
    09) Depending on your Mac processor speed, it could take longer.
    10) Boot OS X (Hold "Option", select OS X partition from "Boot" menu)
    11) Install Paragon Tools NTSC free trial
    12) Enable right access to Windows Partitionby enable driver found in System Preference/Paragon NTSC.
    13) Remove /Windows/System32/ Driver/igdkm64.sys
    14) Disable Intel HD 3000 Driver on 1st boot, Windows 8.
    15) You should see [Windows 8 Activation Screen](http://www.adminosx.com/screenshots/win82Mac/product-key.jpg) on next boot to Windows.

    #### How to disable IntelHD Driver From Windows 8 Metro Menu:

    01) Select Desktop
    02) Right click on Start Menu
    03) Select Device Manger
    04) Select Display
    05) Right click on Intel Driver
    06) Select Disable
    #### Important Notes:

    * *igdkm64.sys will restore to your /Driver folder on next boot if you do not disable it*
    * *Intel HD driver is system default driver*
    * *Only issue running Windows 8 RTM Pro on MacBook Pro 2011 is GPU Drivers*
    * *Microsoft Basic Display Driver will work except sound*
    * *Last Time I check Apple, AMD or Intel drivers were compatible*

    #### Reference Screen Shots for my settings from my BOOTCAMP setup on MacBook Pro:

    * [Boot Camp Pre-Install Settings](http://www.adminosx.com/screenshots/win82Mac/compatability-mode-win8.PNG)

    * [Boot Camp Installer Version](http://www.adminosx.com/screenshots/win82Mac/bootcamp-version.PNG)

    * [Boot Camp Post Install Windows 8](http://www.adminosx.com/screenshots/win82Mac/bootcamp-finish.PNG)

    * [System Overview for MacBook Pro via Windows](http://www.adminosx.com/screenshots/win82Mac/mbp-win8-system-overview.PNG)

    * [MacBook Pro Driver Issue](http://www.adminosx.com/screenshots/win82Mac/MicrosoftBasicDisplayDriver.JPG)

    * [System Overview for MacBook Pro via OS X](http://www.adminosx.com/screenshots/win82Mac/mbp-osx-overview.jpg)

    [1]: https://www.dropbox.com/screenshots/win82Mac/WINPE4.0.iso
    [2]: http://www.adminosx.com/screenshots/win82Mac/compatability-mode-win8.PNG
    [3]: http://www.adminosx.com/screenshots/win82Mac/bootcamp-version.PNG
    [4]: http://www.adminosx.com/screenshots/win82Mac/bootcamp-finish.PNG
    [5]: http://www.adminosx.com/screenshots/win82Mac/mbp-win8-system-overview.PNG
    [6]: http://www.adminosx.com/screenshots/win82Mac/MicrosoftBasicDisplayDriver.JPG
    [7]: http://www.adminosx.com/screenshots/win82Mac/mbp-osx-overview.jpg
    [8]: http://vimeo.com/48053238
    [9]: http://vimeo.com/48054086
    [10]: http://vimeo.com/48058578
  2. mac-hacks, Aug 22, 2012
    Last edited: Jan 20, 2013

    mac-hacks thread starter macrumors regular

    Jan 14, 2011
    Swimming In Tsunami
    Working Drivers - Windows 8 RTM

    Install Ubuntu 12.04 on OS X

    Create Ubuntu-12.04-desktop-amd64.iso boot installer on USB
    *** Do not use Mac Version
    1) Use REFind
    5) Install*Ubuntu-12.04.-Desktop-amd64.iso*from USB to left over Empty Space.
    6) Leave*128MB*free space preceding*root*ext4 partition.
    7) "Fix "Hybrid"*GPT" after formating ext4 & swap partitions, before installing Ubuntu.
    8) Create Partitions->Reboot to OSX->Fix "Hybrid" GPT- >Reboot back to Ubuntu.
    9) Do Not select format partition from BootMenu when you install Ubuntu.
    10) Only select "ext4" as "/"
    11) Install

    1st Boot:
    sudo -s
    apt-get install bison libopts25 libselinux1-dev autogen m4 autoconf help2man libopts25-dev flex libfont-freetype-perl automake autotools-dev libfreetype6-dev texinfo bzr
    sudo add-apt-repository ppa:mactel-support
    apt-get update*
    apt-get upgrade*
    apt-get dist-upgrade
    sudo REBOOT
    bzr branch --revision -1 bzr://bzr.savannah.gnu.org/grub/trunk/grub grub\
    cd grub
    grub:~#sudo -s
    export EFI_ARCH=x86_64
    ./configure --with-platform=efi --target=${EFI_ARCH} --program-prefix=""
    sudo mkdir -p /mnt/EFISYS # if the mount-point does not exist*
    sudo modprobe dm-mod # required to make grub-probe stop complaining
    sudo mount -t vfat -o rw,users /dev/sda1 /mnt/EFISYS*
    sudo mkdir -p /mnt/EFISYS/efi/grub
    sudo rm -rf /mnt/EFISYS/efi/ubuntu
    sudo make install
    sudo grub-install
    sudo update-grub
    sudo reboot
    • Install*rEFInd*manually*from*Ubuntu*to*EFISYS*/dev/sda. Follow*guide in*doc*folder.
    • Do Not*mount*EFISYS*or install**rEFInd*from your /dev/disk0*main OS X*partition if you plan on using*Ubuntu!!! After I install*grub, loading*ubuntu*from*grub menu error*if i did anything to /dev/disk0s1*"EFI" from*OSX.

    * If you have*issuedown road whenBOOTING. Check yourGPTwithgptfdisk, fix "Hybrid"GPT.*
  3. mac-hacks, Aug 29, 2012
    Last edited: Sep 6, 2012

    mac-hacks thread starter macrumors regular

    Jan 14, 2011
    Swimming In Tsunami
    MacBook Pro Early 2011 17" - Windows 8 RTM - Intell 3000 HD - Hardware Bug

    I accidentally found little hardware bug w/ my MacBook Pro Early 2011 17"

    It's actually good thing if your having issue with GPU in Windows 8.

    For Windows 8 RTM, if display goes black after loading splash screen. A "Quick Press" or "Tap" to power button on MBP will switch to Microsoft Basic Display Driver. I press power button x2 when I 1st notice it, at time i was trying to force shutdown.

    If you notice, Intel HD 3000 driver is enable and doesn't work properly with out 2 display. I do not have 2nd display connected. ATI doesn't work properly. Which leads me to believe by tapping Power Button cause MBP to switch to Microsoft Basic Display Driver

    Update: Been using this bug for over week now. Only 1 quick press/tap works.

    you will notice I Press/Tapped it x3 in Video on Vimeo, it needed more time to load.

  4. lethrich macrumors newbie

    Oct 2, 2012
    Can't get it to work

    Tried though I may I could not get beyond the black screen after the 30% Initializing devices. I ca wait till I'm blue in the face but it will not reboot. If I force a reboot then I get an error indicating that the installation cannot continue.
    If I open a repair prompt and delete rename the igdkm64.sys then there is a boot error

  5. arashb macrumors 6502

    May 3, 2009
    Hey mac-hacks. I have a bigger SSD coming in a few days and I'm planning on doing this but with Windows 7. Anything I'll need to do any differently?

    I'd be doing this to my 2011 MBP with ATI + discrete.
  6. RamGuy macrumors 6502a


    Jun 7, 2011
    Your links seems to be dead? :(

    I tried to do this, but as the links are dead and I don't understand the whole WINPE thingie I tried it my own way:

    First I made sure to have a TimeMachine Backup of my Mac OS X Mountain Lion Installation before I stared and created a OS X Mountain Lion Bootable USB.

    Then used Windows 7 USB / DVD Tool from Microsoft on my Windows 8 desktop and created a bootable installation USB, booted it up on my Mac and went into CMD and converted my HDD to GPT, created the small EFI partition and created a 100GB partition for OS X.

    Then I went ahead and formatted the 100GB partition and installed OS X, copied back from my TimeMachine Backup and OS X is all good and dandy.

    But then the tricky part starts, I booted up Windows 8 Installation again but it wouldn't install on any GPT partition and state that would require me to boot it in EFI mode. I have no idea on how to get it to boot directly in EFI mode instead of BIOS mode so I read on the Internet that I could just format the USB using diskpart, convert it to GPT and use either FAT32 or exFAT on it and simply extract my Windows 8 ISO over to the USB and then simply boot it up..

    After doing all that, it's shown as EFI on my MacBook Pro Retina's boot list and all seemed to be good but upon loading it will just bluescreen on me, this happens with both FAT32 and exFAT so I guess it not that easy to get the installation booting in EFI mode?
  7. mac-hacks, Nov 8, 2012
    Last edited: Nov 8, 2012

    mac-hacks thread starter macrumors regular

    Jan 14, 2011
    Swimming In Tsunami
    look for "DaGr8Gatzby" post in this thread starting with post 459

    "Win7 x64 booting natively via EFI (no bios emulation) "

    Good Luck

    I accidentally deleted .jpeg & WINPE on my DropBox server. All other links should work. I plan on doing re-install and will fix links and upload new WINPE 4.0 in next few days. If you need WinPE, there plenty of guides on how to make one online. It's not difficult. VIMEO video's along with guide is all you should need for Windows 8 install.

    I started new job and haven't had time to tinker around in last 2 months. Plan on testing new drivers & updates in next few days. I will post my results after I'm done.

  8. RamGuy macrumors 6502a


    Jun 7, 2011
  9. RamGuy macrumors 6502a


    Jun 7, 2011
    That's with AMD64, if I try X86 it won't show in my boot list at all.
  10. RamGuy macrumors 6502a


    Jun 7, 2011
    I managed to get Windows 8 successfully installed using EFI instead of emulated BIOS on my MacBook Pro 15" Retina.

    All I did was grabbing a SanDisk 8GB memory stick (it wouldn't work with my Corsair Survivor 32GB GTR for some reason), formatted it to FAT32 and just extracted my Windows 8 RTM installation right onto it.

    Booted it up on my Mac, it's shown as "EFI" in the boot list and went into repair, launched CMD and did the whole convert to GPT and creating my OS X partition for OS X installation.

    Then I simply went on with the Windows 8 installation, installing it on it's own NTFS formatted GPT partition and upon the first boot it will bluescreen when trying to mess with the Macs EFI bootloader.

    All I did was just boot from the installation again, fired up CMD once more and typed bcdboot C:\Windows /l en-us and wollah I'm now successfully booting and running Windows 8 under EFI on my Mac.
  11. RamGuy macrumors 6502a


    Jun 7, 2011
    I've struck my first issue with Windows 8 in EFI mode.. Installing BootCamp is no problem, but since the BootCamp Control Panel can't sense any MBR partitions it will just give me an error when I try to open it resulting it shutting down instantly.

    This means I have no way to enable secondary click, to finger secondary click or anything which is a big deal as having no secondary click in Windows is rather tiresome to deal with. Have you been able to come around this issue in some way?

    And when it comes to the Intel HD 4000 + GT 650M I have yet to see any problems. I don't have any black screen or anything and I have just updated both drivers to the latest version with ease. How do I know which of the graphics card my Mac is actually using, and will the Mac support switchless graphics to begin with or should I just disable the Intel HD 4000 even though it doesn't seem to cause me any issues yet?

    Last but not least, the Cirrus Audio driver don't seem to get installed so I have no audio which is a downer.
  12. arashb macrumors 6502

    May 3, 2009
    Try control + click for right click. It may work for that.
  13. RamGuy macrumors 6502a


    Jun 7, 2011
    I managed to bypass the whole BootCamp Control Panel situation by creating a new user, with the new user it loads successfully so I've got my left clicking sorted.

    The only problem I have left is the no audio issue, I tried with both installating the Cirrus Audio Driver manually and by testing the Realtek HD Audio but none of them seems to be working. And for some reason my nVIDIA GeForce GT 650M drivers reverts it self back to 1024x768 resolution on every reboot.. Which isn't really a big deal either as I just switch back to 2880x1800 but it's weird.
  14. RamGuy macrumors 6502a


    Jun 7, 2011
    It seems like the control panel is working if I'm using a standard account, if I use a admin account it wont work. But now I've got the right config running so it's not a problem.

    The only problem I have left is the no audio issue, which seems to be related with Apples EFI so that might be hard to fix, Intel has supposedly come with a EFI update to fix it but I have a really hard time believing Apple is going to prioritize EFI updates which helps out Windows EFI installations any time soon.

    That's a major drawback, forcing me to go back to BIOS emulation mode without AHCI and Intel Rapid Storage drivers, slower boot times and no Intel integrated graphics (which I'm not sure actually works with switchless graphics anyway).
  15. Azrael808 macrumors newbie

    Nov 22, 2012

    This is a great how-to, but I would love it if you could clarify the steps you took to create the WINPE image. Specifically, which drivers and/or additional features did you slip-stream into the boot.wim?

    I have tried building my own WINPE 4.0 image for two reasons: first, I don't tend to download and execute binaries from unknown sources (no offence intended!) and secondly, I am new to the WINPE environment and would like to learn more about how to customise it and make it useful for my own work environment.

    I have slipstreamed in all the drives provided by BootCamp and I was able to boot the WINPE image once, but as soon as I partitioned the drive, it wouldn't boot again. Instead, it blue screens and reboots instantly, without me having a chance to see the error message.

    I'm sure that I'm just missing some important component, it would be good if you could point me in the right direction here. :)

    Thanking you in advance!
  16. mac-hacks, Nov 26, 2012
    Last edited: Nov 29, 2012

    mac-hacks thread starter macrumors regular

    Jan 14, 2011
    Swimming In Tsunami
    If you put "Windows Support" folder on OSX desktop and run each line in terminal you should delete and download needed files for Windows 8 x64.

    Pay attention before you download drivers and double check your getting right drivers for your specific Mac.

    Here URL I use for Driver links:


    # 1. Delete Non-Driver files
    sudo rm -rf $HOME/Desktop/WindowsSupport/Boot\ Camp\ Installation\ \&\ Setup\ Guide.pdf $HOME/Desktop/WindowsSupport/BootCamp.xml $HOME/Desktop/WindowsSupport/BootCamp64.xml $HOME/Desktop/WindowsSupport/Documentation $HOME/Desktop/WindowsSupport/setup.exe
    # 2. Delete 32 Bite & Outdated 64 bite Drivers
    sudo rm -rf $HOME/Desktop/WindowsSupport/Drivers/Apple/AppleBluetoothBroadcomInstaller.exe $HOME/Desktop/WindowsSupport/Drivers/Apple/AppleBluetoothEnablerInstaller.exe $HOME/Desktop/WindowsSupport/Drivers/Apple/AppleBluetoothInstaller.exe $HOME/Desktop/WindowsSupport/Drivers/Apple/AppleDisplayInstaller.exe $HOME/Desktop/WindowsSupport/Drivers/Apple/AppleiSightInstaller.exe $HOME/Desktop/WindowsSupport/Drivers/Apple/AppleKeyboardInstaller.exe $HOME/Desktop/WindowsSupport/Drivers/Apple/AppleMultiTouchTrackPadInstaller.exe $HOME/Desktop/WindowsSupport/Drivers/Apple/AppleNullDriver.exe $HOME/Desktop/WindowsSupport/Drivers/Apple/AppleODDInstaller.exe $HOME/Desktop/WindowsSupport/Drivers/Apple/AppleRemoteInstaller.exe $HOME/Desktop/WindowsSupport/Drivers/Apple/AppleSoftwareUpdate.msi $HOME/Desktop/WindowsSupport/Drivers/Apple/AppleTrackpadInstaller.exe $HOME/Desktop/WindowsSupport/Drivers/Apple/AppleWirelessMouse.exe $HOME/Desktop/WindowsSupport/Drivers/Apple/AppleWirelessTrackpad.exe $HOME/Desktop/WindowsSupport/Drivers/Apple/BootCamp.msi $HOME/Desktop/WindowsSupport/Drivers/Apple/BootCamp64.msi
    sudo rm -rf $HOME/Desktop/WindowsSupport/Drivers/Asix/AsixSetup.exe
    sudo rm -rf $HOME/Desktop/WindowsSupport/Drivers/Atheros/AtherosInstallerWin7.exe
    sudo rm -rf $HOME/Desktop/WindowsSupport/Drivers/ATI/ATIGraphicsSetup.exe
    sudo rm -rf $HOME/Desktop/WindowsSupport/Drivers/Broadcom/BroadcomCardReader32.exe $HOME/Desktop/WindowsSupport/Drivers/Broadcom/BroadcomEthernet32.exe $HOME/Desktop/WindowsSupport/Drivers/Broadcom/BroadcomNetworkAdapterWin7_32.exe
    sudo rm -rf $HOME/Desktop/WindowsSupport/Drivers/Cirrus/CirrusAudio32.exe
    sudo rm -rf $HOME/Desktop/WindowsSupport/Drivers/IDT\ SigmaTel/SigmaTelSetup.exe
    sudo rm -rf $HOME/Desktop/WindowsSupport/Drivers/Intel/Chipset/*
    sudo rm -rf $HOME/Desktop/WindowsSupport/Drivers/Intel/CrystalBeachInstaller.exe $HOME/Desktop/WindowsSupport/Drivers/Intel/Intel945Setup.exe $HOME/Desktop/WindowsSupport/Drivers/Intel/Intel965Setup.exe $HOME/Desktop/WindowsSupport/Drivers/Intel/IntelEthernetInstaller-Win7_32.exe $HOME/Desktop/WindowsSupport/Drivers/Intel/IntelHDGraphicsSetup.exe $HOME/Desktop/WindowsSupport/Drivers/Intel/IntelHDGraphicsSetup64.exe $HOME/Desktop/WindowsSupport/Drivers/Intel/IntelMgmtEngine.exe
    sudo rm -rf $HOME/Desktop/WindowsSupport/Drivers/Marvell/MarvellInstaller.exe $HOME/Desktop/WindowsSupport/Drivers/MotorolaSetup.exe $HOME/Desktop/WindowsSupport/Drivers/RealTek/RealtekSetup.exe
    sudo rm -rf $HOME/Desktop/WindowsSupport/Drivers/NVidia/*
    cd $HOME/Desktop/WindowsSupport/
    mkdir downloads
    # Remove "#" in front of "c" in "curl" to download driver, depending on your Mac will depend on which link's to un-comment.  Use commen sense and google your model if your not sure.
    # Need only  1 link for the next 2 options:  (Do you Have ATI or Nvidia GPU?"
    # NVIDIA GeForce 310.61 Beta
    #curl -C – -OLR http://us.download.nvidia.com/Windows/310.61/310.61-desktop-win8-win7-winvista-64bit-international-beta.exe
    # AMD-( 12.11Beta8
    #curl -C – -OLR http://www2.ati.com/drivers/beta/AMD_Catalyst_12.11_Beta8.exe
    # HD Graphics 4000/2500 & HD Graphics 3000/2000
    #curl -C – -OLR http://downloadmirror.intel.com/22082/a08/win64_15288.zip
    # Intel® Management Engine Interface (MEI/HECI)
    #curl -C – -OLR http://www.station-drivers.com/telechargement/intel/chipset/intel_me_8.1.2.1318_5M(www.station-drivers.com).exe
    # Need only 1 link for the next 2  Intel Chipset Device
    # Intel Chipset Device Software Version
    #curl -C – -OLR http://downloadmirror.intel.com/22152/eng/INF_allOS_9.3.0.1026_PV.exe
    # !!!! -6 Series Chipset !!!!! Intel Chipset Device Software version
    #curl -C – -OLR http://downloadmirror.intel.com/22153/eng/INF_allOS_9.3.0.1026_PV.exe
    - Use 7zip if you have bootable windows drive or VPC to extract .exe
    - Create Folder on root and name it "Inject"
    - Rename "WindowsSupport" folder to "x64_drivers" and movie it to "Inject"
    - Make another folder in "Inject" name it "mount"
    - Make 2 folders in "mount" name them "winpe" & "setup"
    - Delete .exe in "x64_drivers" folder so all you have are extracted folders in "x64_drivers" folder
    - put innstall.wim & boot.wim in "Inject" folder
    - Install Windows A.D.K.
    - Slipstream Drivers by running following in Deployment and Imaging Tools Environment:

    cd C:\Inject
    dism /mount-wim /wimfile:boot.wim /index:1 /mountdir:mount\winpe
    dism /mount-wim /wimfile:boot.wim /index:2 /mountdir:mount\setup
    dism /image:mount\winpe /get-drivers
    dism /image:mount\setup /get-drivers
    dism /image:mount\winpe /add-driver /recurse /forceunsigned /driver:x64_drivers
    dism /image:mount\setup /add-driver /recurse /forceunsigned /driver:x64_drivers
    dism /image:mount\winpe /get-drivers
    dism /image:mount\setup /get-drivers
    dism /unmount-wim /mountdir:mount\winpe /commit
    dism /unmount-wim /mountdir:mount\setup /commit
    dism /get-wiminfo /wimfile:install.wim
    mkdir mount\Windows8_Preview
    dism /mount-wim /wimfile:install.wim /index:1 /mountdir:mount\Windows8
    dism /get-mountedwiminfo
    dism /image:mount\Windows8 /get-drivers
    dism /image:mount\Windows8 /add-driver /recurse /forceunsigned /driver:x64_drivers
    dism /image:mount\Windows8 /get-drivers
    dism /unmount-wim /mountdir:mount\Windows8 /commit            
    - Install "BootCamp64.msi" found in "/WindowsSupport/Drivers/Apple" after you get Windows 8 install. Right click on ".msi" and change settings in Properties -> Compatibility -> run as "Admin" & Run Program Compatibility and select "Windows 7"

    Good luck...
  17. Azrael808 macrumors newbie

    Nov 22, 2012
    Thank you for such a detailed response! I'll be sure to give this a go asap and I'll get back to you with my results. :)
  18. Azrael808 macrumors newbie

    Nov 22, 2012
    @Mac-Hacks: I finally got around to trying out your steps and I've managed to create my own WinPE 4.0 image!

    On my first attempt, I was presented with a 0x5c error when booting (HAL initialisation error). I returned to my PE build environment to try again from scratch and noticed that the ATI Beta driver failed to install. Investigating further, it looked as though it was trying (and failing) to copy a "difxapi.dll" from the ATI\Packages\Drivers\Display\W86A_INF\B149702 directory into the image. The file was actually present in the ATI\Bin64 directory, so I simply copied it!

    That allowed to me reliably boot the WinPE HDD and continue with your install guide. Thanks again! I'll be documenting this process on my own blog and I'll be sure to name-check you and this forum. :)

    Only problem I'm having now is with the Windows 8 install routine; I have a late 2011 MacBook Pro and it doesn't seem to be behaving as outlined in the "Step 3, part B" section of your guide. The machine keeps rebooting, and if I delete the \Windows\System32\igdkm64d.sys file, the subsequent boot gives a message stating that the system has recovered from an unexpected error or reboot and the installation can't continue. :(

    I'll try wiping the Windows partition and re-installing from WinPE and see how I get on, maybe I missed something on my first run through. I'll keep you posted.
  19. Azrael808 macrumors newbie

    Nov 22, 2012
    Yup... Same problem...

    It runs through the first boot attempt as you say: gets to around 30-40% before the screen goes blank and eventually it reboots. Second time it starts to boot, a similar thing happens: screen goes blank it it eventually reboots. The next time I get a message staging that my machine has failed to boot too many times (0x1 error) and should be repaired.

    If I force it to try and boot again, it started to "repair" drive C: and seemed to reboot around 40%. A final attempt results in the following:


    I must be missing something that's not critical for WinPE, but _is_ for Windows 8 itself maybe? When I get a moment, I'll see if there are any logs on the system that document the failure and point to a particular piece of hardware.
  20. mac-hacks thread starter macrumors regular

    Jan 14, 2011
    Swimming In Tsunami
    Best bet is to whip your drive clean or at least windows partition using secure erase either diskutil or diskpart.

    Run this in OS X terminal:
    $ sudo mkdir /efi
    # change "disk0s1" for some reason it's not disk with "EFI".  I have issue some times with external showing up as "disk0s1"
    $ sudo mount -t msdos /dev/disk0s1 /efi
    $ open /efi
    # Delete /Boot & /Microsoft folders then reboot
    $ sudo shutdown -r now
    try it agian, looks like your almost there. I bet it's old efi from previous install causing error.
  21. Azrael808 macrumors newbie

    Nov 22, 2012
    OK, tried that and no luck; still getting the 0x5C error. :( As that's a HAL initialisation, I'm going to try updating some of the drivers I inject into the WIM file.
  22. mac-hacks, Dec 3, 2012
    Last edited: Dec 3, 2012

    mac-hacks thread starter macrumors regular

    Jan 14, 2011
    Swimming In Tsunami
    What Mac are you trying to install on? Be sure to reset nvram. I had issue and would boot to recovery "WINRE" unless I i did reset and booted from cold boot before I started install process. I've been able to install Windows 8 x64 Pro and Pr-Releases without slip-streaming drivers.
  23. Azrael808 macrumors newbie

    Nov 22, 2012
    It's a MacBook Pro 8,2, so the AMD Radeon and Intel 6-series drivers you linked to should be perfect. I just managed to download a stable Radeon mobility Catalyst driver that I was going to give a try.

    WRT resetting NVRAM: I have done this, but I'm unsure if I have done so from a cold boot and not simply restarted the machine. I definitely held down the CMD, option, P and R buttons until the machine rebooted 3 times though.

    I'll give it another shot: write out the wim file again but shut down completely before attempting to boot the Windows installation routine.

    Thanks for your continued help with this! :)

    Out of interest, will resetting the NVRAM be necessary every time I try to boot into Windows 8, or just for the installation?
  24. mac-hacks, Dec 4, 2012
    Last edited: Dec 4, 2012

    mac-hacks thread starter macrumors regular

    Jan 14, 2011
    Swimming In Tsunami
    We have same Macbook Pro, except mines 8.3 "17" ". Im guessing yours is 15".

    "NVRAM" No, only a good idea to do that if you boot to WINRE recovery or having other issue like fans going 1000mph , or dock showing duplicates, & etc....

    I had same issue, you are having. Until I reset NVRAM/PRAM, 1st boot of Windows Install, I use cold boot. I had to format my SSD with starting block at 2048.

    After you get install, your default Boot will be windows , you can reset it to OS X in System Preferences. Any time you reset NVRAM, it wiill default back to Windows.

    After getting Recovery few times, I final figure out that you could not re-use Microsft EFI files on new install. Might help you to wipe EFI after OS X install, I did that few times when I was trying to get AMD drivers working.

    It's early I do not use windows terminal all that much, I think this command should wipe it and re-create it with out deleting OS X partition. You will be able to boot OS X by holding option key. OSX looks for 2 EFI loaders, you have 1 in EFI partition & another in /usr/standalone/i386: might want to try this on USB/Flash drive 1s to make sure it works or you might have EFI partition in wrong place.

    diskpart select disk 1 ?
    diskpart select partition 1
    diskpart delete partition EFI ("you may or may not need to add "EFI" in command)
    diskpart create partition EFI size=200  (Use same size as the one u deleted)
    diskpart format fs=fat32 quick label=EFI
    diskpart assign letter=S
    - On 2nd black screen boot, be sure and wait. maybe give it 30 mins. I have 16GB ram, it might take you longer.

    - If you boot WINRE recovery any time during or after 2nd black screen boot. Choose option that allows you to disable or allow UN-assign drivers. Before you reboot Windows, boot OS X and delete intellHD 3000 driver.
  25. Shelltoe, Dec 11, 2012
    Last edited: Dec 11, 2012

    Shelltoe macrumors member

    Dec 11, 2012
    Hi there! In the past weeks I build an eGPU setup via Thunderbolt for my 15" MBP retina.

    It works great on external screen (3D Mark 2011 with dGPU: 2500p / with eGPU: 7500p (!)).
    I'd love to make it happen on my interal screen too so I can use it while I'm not at home.
    For this to work I'll have to enable Intel HD as primary GPU and enable Optimus on my Nvidia card.
    Guess it would be huge having Intel HD + Optimus for anyone booting Windows.
    Installation of Optimus drivers can be forced by fixed Nvidia .inf files easily.

    I'm in touch with developers of Linux's "apple-gmux" driver and I'm actually able to switch graphics before Windows boots. Because of bugged Intel HD drivers I'm stuck for now (black screen). I'm able to use Basic Display Drivers which already saves some energy though. Linux systems have similar problems with latest 2012 models as far as I know.

    I'm actually not asking for help regarding my problem as it seems to be unfixable for now. (any hints would be great anyways)

    I just wanted to ask if this problem is present for all previous models (2010/2011) or if someone was actually able to install Intel HD drivers without blackscreen / igdkmd64.sys errors? Especially using latest Beta Drivers (04.12.2012).

    If anyone's intrested in graphics switching for Windows I'll post some more info.

Share This Page