Hacked 1.0.2 to 1.1.1 Advice

Discussion in 'Jailbreaks and iOS Hacks' started by martinmartin, Oct 17, 2007.

  1. martinmartin macrumors 6502

    Joined:
    Jun 5, 2007
    #1
    Hi,
    I upgraded my fresh 1.0.2 iphone to 1.1.1 when the firmware first came out. Then I missed my ringtones so much that I went back to 1.0.2 and decided to install apptapp and a few applications.

    Now that iToner 1.1.1 compatibility will be released shortly, I want to go back to 1.1.1. (I didn't really find the applications that useful. Blackjack is cool, and the custom look is cool, but the novelty wears off rather quickly.)

    My question is, what is your advice for going from a ?hacked? 1.0.2 phone to 1.1.1. I guess I am planning on uninstalling everything that i can on the phone itself using installer.app. Then restoring using itunes (which I assume will take it back to 1.0.2). Then updating to 1.1.1.

    Do I need to do anything special to A. make sure my phone doesn't get bricked and B. delete any *evidence* of hacking the phone (for future service)?

    Thanks in advance.
     
  2. mcdj macrumors 604

    mcdj

    Joined:
    Jul 10, 2007
    Location:
    NYC
    #2
    First off, no need to remove apps via Installer. When you upgrade to 1.1.1, the phone will be wiped clean of them.

    However, from what I've read, a restore from an iTunes backup made while apps were installed will also restore bits and pieces of the previously installed apps...prefs, etc. You could delete them manually, but you'd have to SSH into the phone, and to do that, you need BSD subsystem and SSH installed on the phone, AKA hack the phone again. And it will be kinda tricky to then delete the program you're using to delete programs.

    AFAIK, the only way to truly wipe the phone clean is to upgrade to 1.1.1, but do NOT restore from an iTunes backup. This means you'll have to reset all your prefs, you'll lose your current notes, etc.

    If anyone knows differently, speak up!
     
  3. martinmartin thread starter macrumors 6502

    Joined:
    Jun 5, 2007
    #3
    Thanks mcdj.

    Anyone else have any tips for this upgrade?

    Cheers.
     
  4. martinmartin thread starter macrumors 6502

    Joined:
    Jun 5, 2007
    #4
    I know some of you iphone geniuses have some good advice...

    I dont want to end up with a bricked phone and i dont want to end up with a phone that has hacked files in it...

    Thanks again
     
  5. carlos1078 macrumors newbie

    Joined:
    Sep 1, 2007
    #5
    I just updated my hacked iPhone to 1.1.1 using ifuntastic 4.6.1 discussed at http://www.iphonealley.com/ifuntastic/ifuntastic-auto-jailbreaks-iphone-v1-1-1-rocks-my-socks. Everything worked well, except my applications were not visible, even though I updated Installer and they showed up in my "uninstall" list. I fixed this by uninstalling and re-installing all of my apps- my preferences seemed to persist. So, everything works great except for one thing- I was unable to reinstall the bsd subsystem. Every time I would try, Installer would give me the error "Packager download failed: can't find host!". Anyone have any ideas? Any help would be much appreciated!
     
  6. borelli macrumors newbie

    Joined:
    Oct 24, 2007
    #6
    any luck with the BSD problem yet? I have exactly the same issue
     
  7. pjs20 macrumors newbie

    Joined:
    Oct 24, 2007
    #7
    yeah I'm having the same BSD problem as well..
     
  8. hansning macrumors newbie

    Joined:
    Feb 11, 2007
  9. bushman1 macrumors regular

    Joined:
    Jul 28, 2007
    #9
    Real simple just use cyberduck, open ssh, and the bsd system installer.
     
  10. borelli macrumors newbie

    Joined:
    Oct 24, 2007
    #10
    Could you elaborate on this please? I understand FTP, open SSH etc... but where is the BSD installer? Where should I install it to and how? Many thanks

    Could this be an issue with Nullriver's servers? I can install anything else on install.app. Really weird
     
  11. netsrack macrumors newbie

    Joined:
    Oct 24, 2007
    #11
    seems to be a server problem with BSD files.
    I unlocked a 1.1.1 yesterday without any problems with touchfree and Anysim.

    Today i wanted to unlock another virgin 1.1.1. an the BSD package does not work.
    When i press the button "Reinstall" on the working iphone the same error occurs.
    Hopefully they fix the server issue soon
     
  12. dalvin200 macrumors 68040

    Joined:
    Mar 24, 2006
    Location:
    Nottingham, UK
    #13
    i upgraded my unlocked 1.02 iphone last night to 1.1.1 using the instructions over at modmyiphone.com

    some quirks, but worked fine..

    very pleased with the step by step guides
     
  13. pjs20 macrumors newbie

    Joined:
    Oct 24, 2007
  14. bushman1 macrumors regular

    Joined:
    Jul 28, 2007
    #15
    It is in the installer app "BSD subsystem"
     
  15. carlos1078 macrumors newbie

    Joined:
    Sep 1, 2007
    #16
    Fixed! I was able to re-install the BSD subsystem successfully.
     
  16. 30naa macrumors newbie

    Joined:
    Oct 28, 2007
    #17
    i updated my 1.0.2 unlocked iphone to 1.1.1 with iNdependence but when i run anysim to unlock it can not unlock my phone.
     

Share This Page