Hacked 2G iphone won't start up properly, and Windows can't see it properly

Discussion in 'Jailbreaks and iOS Hacks' started by podleian, Aug 19, 2008.

  1. podleian macrumors newbie

    Joined:
    Aug 19, 2008
    #1
    I am not an iphone user, and have very little experience or knowledge concerning the jailbreaks and hacks. A colleague of mine at work owns the iphone in question, and someone hacked it for him. It has now stopped working, and he has asked me to look into it as he has no internet connection. He doesn't know what procedure was used to hack it, and the person who did it will only say that he followed a guide on the net.

    It worked for a couple of weeks after being hacked, but a few days ago, when he pressed the sleep button, all he got was the battery icon, with the minimum amount of red, and it switched off. He tried to charge it with a wall charger, and it would not switch on, or take a charge; he just got the same battery icon.

    I have tried plugging it into USB, with no recognition from iTunes. When I pressed Home and Sleep for a few seconds, a pineapple icon appeared, and then a cartoon of Steve Jobs with a voice bubble with what I assume is cyrillic writing in it appears. Windows brings up a box telling me that the USB device is unknown.

    I have tried this on 2 PCs, one running Vista Home and one running XP sp3, and on all USB ports for both PCs, to the same result. Both are running the newest version of iTunes, with the latest Apple packs (I have a Touch with the new v2 firmware that I installed last week).

    I had hoped that I would be able to get iTunes to see the iphone, and then just restore from there, but since I can't get Windows to see the phone, the same applies for iTunes.

    I have searched everywhere I can find, but can't find a person with the exact same problem. I suppose that it is in restore mode, from what I have read, but I can't figure out why the USB detection is not working.

    As I say, I'm not even a noob, since I have never played with a working iphone, so if anyone can help, I would be very grateful, as would my colleague, but I need basic level explanation please!
     
  2. spinstorm macrumors 65816

    Joined:
    Sep 14, 2007
    #2
    There is good news and bad news.

    First of all the good news is the phone was unlocked with pwnage which means that it is very easy to make a new custom firmware and upgrade it to 2.0.

    On PC use winpwn and on mac use pwnagetool - read my FAQ for download details and instructions.

    The bad news is that if leaving it plugged and charging is not working then the USB or some other hardware is the cause of the problem.

    Maybe he got it wet or damaged it some other way.

    That means that you would have to return it to apple (assuming it is under warranty and an official phone from that country) however because it has been pwned with custom logos Apple would not touch it as it has been hacked.

    So this is what I suggest:

    Leave it plugged into the wall for a day - see if it gets enough power to switch on.

    If it does then restore with new custom 2.0.1 in itunes and it will unlock it.

    If it doesn't have enough charge then all you can do is connect it to itunes and hold the home and power buttons and keep trying for restore mode and see if it will work with a custom firmware.

    I am afraid if it does not then there is nothing you can do - it is a hardware fault.

    Make sure when you make your custom firmware you use the original apple logos so if it doesn't boot at least apple would not know it was hacked and change it.

    Like I said read the FAQ for pwnagetool for instructions.
     
  3. podleian thread starter macrumors newbie

    Joined:
    Aug 19, 2008
    #3
    Thanks, the help is much appreciated.

    I will try and charge all day tomorrow, and then go through the FAQ.

    There is power coming into the unit - it gets warm as though charging, and when plugged into mains or USB, the Jobs image always stays onscreen (for hours).

    The problem that I think that I will face is that Windows detects the presence of a USB device, but has no idea what it is. Presumably, iTunes will not know either, when I reach that stage.

    What does the Jobs image mean? What mode is the iphone in when it is displayed?

    Oh, another issue - I have legit installs of iTunes on both of my PCs, and need both. Will the winpwn procedure cause problems with those installs? I certainly don't want to cause issues with my Touch or Classic doing someone else a favour!
     
  4. podleian thread starter macrumors newbie

    Joined:
    Aug 19, 2008
    #4
    Sorry for the double post.

    I charged the iphone; now I can get the pineapple and Jobs, or a black screen, but don't get the battery icon anymore.

    I ran pwnage, created the .ipsw, pwned iTunes, but the PC still can't see the phone, so neither can iTunes. I can't use the restore due to that.

    Has anyone ever come across this "USB device not recognised" issue before?
     

Share This Page