hackintosh installation issue

Discussion in 'macOS' started by adi.shoukat, Jan 5, 2010.

  1. adi.shoukat macrumors newbie

    Joined:
    Jan 5, 2010
    #1
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    Try booting in verbose mode (type -v I guess). Anyway, InsanelyMac is much better place for hackintosh help
     
  3. adi.shoukat thread starter macrumors newbie

    Joined:
    Jan 5, 2010
    #3
    I've tried verbose mode .. But it isn't working ..
    :(
    please tell me if you have any other solution ... and thanks for sending the link
     
  4. illy123 macrumors member

    Joined:
    Jan 1, 2010
    #4
    Try booting in safe mode (-x flag)

    What kind of hardware have you got and what was your install method? Also is this Snow Leo? Try booting in 32 bit mode (arch=i386)
     
  5. adi.shoukat thread starter macrumors newbie

    Joined:
    Jan 5, 2010
    #5
    Here are my System Hardware Details:
    System Summary:
    [​IMG]
    CPU:
    [​IMG]
    Graphics:
    [​IMG]
    Audio:
    [​IMG]
     
  6. adi.shoukat thread starter macrumors newbie

    Joined:
    Jan 5, 2010
    #6

    Please tell me how to boot in 32bit mode?
    I am new with Hackintosh or with it's installation .. I don't even know what do you mean by (arch=i386) ?? :(
     
  7. adi.shoukat thread starter macrumors newbie

    Joined:
    Jan 5, 2010
    #7
    No this is Leopard
    Being Specific it's:
    iPC OSx86 10.5.6 Intel AMD SSE2 SSE3
     
  8. Winni macrumors 68030

    Winni

    Joined:
    Oct 15, 2008
    Location:
    Germany.
    #8
    In the foler /Extra on both your Hackintosh installation medium -and- on the installed Hackintosh system should be a file named com.boot.plist (or something similar, I don't know it by heart) in which you can define all the kernel flags. You will want to add "-v -arch=386" in ONE line in the appropriate field. Just search on insanelymac.com for more detailed info.

    However, if this is really a Pentium 4 CPU on your system, then it is unsupported and you will probably require a patched kernel - the out-of-the-box (or "vanilla") kernel on the original Snow Leopard/Leopard/Tiger DVD will -not- work with certain Intel CPUs like Celeron and older Pentium CPUs. It only supports Core Solors, Core Duos, Core 2 Duos and Xeons.

    There's a tool called "myHack" available somewhere on the Internet that can prepare your installation USB stick (preferred method) properly. However, this tool requires an already running version of Mac OS X - it won't work on Windows or Linux.

    When I turned my Dell XPS M1530 into a Hackintosh, I needed to delete certain original Apple kernel extensions because they crashed the machine during installation. The worst culprit was Apple's own IOATAFamily.kext. When I put a modified ATA driver in /Extra, everything worked.

    Setting up a Hackintosh can easily consume three days of fulltime work - and that's when you are an experienced administrator who's setup a lot of systems, including Unix/Linux machines, before. So you'll need a lot patience but you'll get there eventually. It will be a lot easier when you use a machine that is very similar to Apple's own hardware configurations. After all, Apple only uses commodity hardware in their Macs; in the inside, they're just regular PCs.


    Good luck! :)
     
  9. adi.shoukat thread starter macrumors newbie

    Joined:
    Jan 5, 2010
    #9
    When I start my CPU it asks
    Press <F4> If the change is Expected
    Press <F9> If the change is not Expected

    I press <F4> and then the system is just hang!!
    OS doesn't starts ... please guide me how can i access the folder /Extra ??

    My Friend had installed MAC from the same DVD on his Pentium 4 machine. I don't think it's an issue of compatibility with P4.
    I can't even think about it ... My MAC isn't starting up :(
    I hadn't installed any of Apple's drivers .... I made it sure while installing The OS
    I am ready to spend 3 days ... but i really need it .. I am not an experienced administrator and this is why I am here to seek help from people like you ... :)

    Regards.
     
  10. adi.shoukat thread starter macrumors newbie

    Joined:
    Jan 5, 2010
    #10
    Now I am one step ahead ... :)
    Because Now I am facing a new problem ... :(

    Now after the OS tries to load some time it shows a text on the screen which says something like:
    "Please contact the Voodoo Kernel dev-team with a photo of the information
    printed below, along with a description of your system configuration and
    what you were doing at the time that the kernel panic occurred. We
    apologize for the inconvenience.

    panic(cpu 0 caller 0x00136372): "thread_invoke: preemption level 2\n"@/VoodooKernal/xnu-1228.7.58/osfmk/kern/sched_prim.c:1435
    Debugger called: <panic>
    ......
    .........
    ............
    "

    I know it's a case of Kernal Panic ... but i don't know what does it mean and how to fix it ?? :(
    please help me :(
     

Share This Page