hal.dll error. XP works under Parallels, but not Boot Camp

Discussion in 'Windows, Linux & Others on the Mac' started by mysterui, Jan 17, 2008.

  1. mysterui macrumors newbie

    Joined:
    Jun 18, 2007
    #1
    When I try to load up Boot Camp, I get the missing hal.dll error. However, I can boot into Windows just fine from my Boot Camp partition that I use for Parallels. If it works for one, it should work for the other...right?

    Can anyone help e out?
     
  2. kwfl macrumors 6502

    Joined:
    Aug 20, 2007
    #2
    i got this error once when i tried to install xp as a third operating system into my imac

    when i restarted after installation i got this error and never booted again.

    and it think the file is not missing, it is just something wrong with your Parallel installation to speculate and dont know for sure.
     
  3. jlewis2k1 macrumors 6502a

    jlewis2k1

    Joined:
    Jan 14, 2005
    Location:
    in your closet
    #3
    the quick simple way to fix that is to do an install over the installation.

    But, the technical way of doing it. you can run the recovery console from the windows installation cd. with the recovery console you can extract the hal.dll file into the appropriate location.

    when you are in the recovery console type in

    Code:
    expand D:/i386/hal.dl_ C:/Windows/System32/ /d /y
    this should extract that hal.dl_ file to your system32 directory. if it doesn't then you can do:

    Code:
    ren C:/Windows/System32/hal.dll hal.dll_old
    copy d:/i386/hal.dl_ C:/Windows/System32/hal.dll
    As I said it would be just easier to do an install over the current installation that way it would save you lots of headaches and drinks.
     
  4. riscy macrumors 6502a

    riscy

    Joined:
    Jan 4, 2008
    Location:
    China
    #4
    I have had similar problems and now have a messed up boot.ini :

    [boot loader]
    timeout=1
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Parallels configuration" /fastdetect /NoExecute=OptOut
    multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /kernel=ntkopvs_.exe /hal=halopvs_.dll
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Parallels configuration" /fastdetect /NoExecute=OptOut /kernel=ntkopvs_.exe /hal=halopvs_.dll

    I do not want to try another installas it seems that Parallels is craeting multiple versions. Windows works fine through BootCamp, so there is no issue with the installation of XP (spit).

    Any advice on boot.ini?
     
  5. brkirch macrumors regular

    Joined:
    Oct 18, 2001
    #5
    Here's the article on the Parallels knowledge base site about this. If you've already tried unsuccessfully to repair your Windows install, there is one more thing to try. Open the Boot Camp VM without starting it. Then go to the "Edit" menu and select "Virtual Machine...". Select the hard disk in the left column, then select the "Advanced" tab and click the "Clear" button.
     

Share This Page