Half Life 2 lag? Really?

Discussion in 'Mac and PC Games' started by TRUCRACKER, Jun 10, 2010.

  1. TRUCRACKER macrumors 6502

    TRUCRACKER

    Joined:
    May 31, 2010
    Location:
    VA
    #1
    I just downloaded HL 2 on Steam and it was a bit laggy. When I first started the game there was no sound in the train for a few seconds. It also jumps a bit here and there and a random loading screen pops up in the middle and stays for about 20 seconds. I also lost sound again during the part when the main character is being teleported. Isn't this game a few years old now? I expected it to run flawlessly. Is there something wrong here?
     
  2. Sir Lethal macrumors newbie

    Joined:
    Feb 23, 2010
  3. benpatient macrumors 68000

    Joined:
    Nov 4, 2003
    #3
    talk to apple about those OpenGL drivers.

    Other than that, it seems like your machines should be able to handle it without what you're describing, unless you are doing something else at the same time, or you have too many fancy effects turned on.
     
  4. Zortrium macrumors 6502

    Joined:
    Jun 23, 2003
    #4
    Try turning off AA. That really screws HL2 performance on my iMac, but turning it off and leaving everything else maxed is very smooth.
     
  5. R.R.Mac macrumors regular

    R.R.Mac

    Joined:
    Sep 16, 2006
    Location:
    Guildford, England
    #5
    how good is your computer. It runs really well on my Macbook Pro.. Try turning down the graphics and turn off Anti-analysing.

    I have a 15" MacBook Pro Core i5 2.4 GHz 4 GB RAM if thats of any use >.>
     

Share This Page