Halo UB 2.0.4 crawling on 24" iMac C2D?

Discussion in 'iMac' started by cosmichobo, Jun 8, 2014.

  1. cosmichobo macrumors 6502

    cosmichobo

    Joined:
    May 4, 2006
    #1
    G'day,

    Having recently changed over from a G5 PowerMac 1.8GHz dual processor with 1.5GB of RAM, to a 24" iMac C2D 2.93GHz with 4GB of RAM, I was expecting Halo to be able to run with all the options ticked, high res, etc etc...

    However, instead, it's completely unplayable, even on 800x600 res with no particles, no shadows, no nothing. It is VERY unresponsive to key or mouse commands, feels like I'm running it through Screen Sharing.

    What the???

    Googling, I see most people say it runs like silk... What is wrong here?

    I'm running the 2.0.4 universal version (as PPC wont run under Mavericks anyway)...

    Thanks,

    cosmic
     
  2. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #2
    The GPU on the 24" iMac is pretty weak.

    You should be playing it on a system with at least 1GB GT 650M.
     
  3. cosmichobo thread starter macrumors 6502

    cosmichobo

    Joined:
    May 4, 2006
    #3
    Ahh...

    It has the stock NVIDIA GeForce GT 120 256 MB.

    Though - my G5 tower only had the stock standard video card, and it ran fine (at 800x600, with generally "lower" video settings)...
     
  4. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #4
    The GT 120 is still a very weak card.

    I'd recommend at least a 2011 21.5" iMac with Radeon 6750M.
     
  5. cosmichobo thread starter macrumors 6502

    cosmichobo

    Joined:
    May 4, 2006
    #5
    Just needed the Halo UB patch - working like a charm now.
     
  6. joe-h2o macrumors 6502a

    Joined:
    Jun 24, 2012
    #6
    What nonsense is this?!

    Halo was released for the Mac in 2003, in the PPC era.

    Any of the Intel Macs, with the correct universal binary (that the OP has) are more than adequate to run it well. A 650M "at least" is like saying that you need "at least" a 747 to transport 15 people. The *recommended* system requirements call for a GeForce 4Ti card with 64MB RAM (minimum was a GeForce 2 with 32MB).

    I was running Halo:CE on an X1600 with 128 MB RAM on a 2006 iMac with no issues whatsoever.

    1GB VRAM on a 650M minimum. Man, that's the funniest thing I've read all day.
     
  7. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #7
    Oops sorry I thought he was referring to the more recent Halos.

    If it's an old Halo back from '03, then maybe even an old 9400M could do the job.
     
  8. cosmichobo thread starter macrumors 6502

    cosmichobo

    Joined:
    May 4, 2006
    #8
    There's a more recent Mac version of Halo than the '03 release?
     
  9. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #9
    I (mistakenly) assumed that you were running through Boot Camp in Windows.

    My bad, sorry :p
     

Share This Page