HALP! Ipod Touch won't charge.

Discussion in 'iPod touch' started by awraawr, Apr 20, 2011.

  1. awraawr macrumors newbie

    Joined:
    Apr 20, 2011
    #1
    I'm sorry for asking for help without a big post count but any help will be highly appreciated. I have a 1st Gen Ipod Touch and I've had it for around 6 months, it was a steal at £60 at second hand store and it worked perfectly fine. Until a month ago I plugged it into directly into the wall, my battery was 100% drained so everytime I pressed the sleep button it came up with the empty battery with a lightning bolt below it. It charged up until the point that screen went and it was usable (the unlock screen) but it doesn't charge any further, the battery icon on the top just has a red bar not the charging icon it's supposed to have. I had forgotten about it and just picked it up from the drawer just today and decided to see if it had magically fixed itself. I've tried directly to the wall and the same thing happens, it charges to the point it's usable but the battery doesn't charge fully. I've tried all USB ports on my PC (Itunes doesn't sync or pick it up) and Mac (Itunes doesn't sync or pick it up), I've tried a dock and still does the same. I have no warranty and it is jailbroken. I'm guessing it's a battery replacemet but why can it not fully charge?
     
  2. Crigger540 macrumors member

    Crigger540

    Joined:
    Jun 16, 2010
    Location:
    The Old Dominion
    #2
    Sounds like your battery crapped out, considering its a 1st gen, its about
    time. Google one of the places that replaces batteries - they are pretty cheap and you will get a battery that is more powerful than the original.
     
  3. mayflower macrumors member

    Joined:
    Apr 19, 2011
    #3
    Souds like you really need to get a replacemnet battery,I have encountered the same problem with you, I got a replacemnet ipod battery from GDP and have no such issues now.
     

Share This Page