Handbrake/ATV2 and 5.1 settings...ARG!

Discussion in 'Apple TV and Home Theater' started by emaja, Sep 7, 2012.

  1. emaja macrumors 68000

    Joined:
    May 3, 2005
    Location:
    Chicago, IL
    #1
    I am ripping my BD collection with MakeMKV and am getting the correct audio tracks. When I use HB, I am not sure what to do when it comes to audio. Sometimes I get stereo, sometimes 5.1 and AFAIK I am doing the same thing for the audio settings.

    BH sees 2 audio tracks - 0: English (DTS-HD MA)(5.1), and 1: English (DTS)(5.1). I select AAC (core audio) for the first and "Auto Passthru" for the second and that results in a stereo file.

    What should I be using?
     
  2. ProudLoz macrumors regular

    Joined:
    Aug 26, 2012
    #2
    You should be encoding the DTS track to AC3 because the Apple TV cannot decode DTS audio tracks at the moment. It's the only option you have if you want 5.1 Surround Sound on the Apple TV.
     
  3. tbayrgs macrumors 603

    tbayrgs

    Joined:
    Jul 5, 2009
    Location:
    Florida, USA
    #3
    This. If you use the Apple TV 2 preset, it should automatically set up a stereo AAC track and a 5.1 AC3 track (Dolby Digital).
     
  4. ViperDesign macrumors 6502a

    ViperDesign

    Joined:
    Aug 7, 2007
    Location:
    Utah
    #4
    I believe apple tv will do AC3 passthrough, someone correct me if I am wrong. That would give you the best quality besides DTS.
     
  5. Rushli0n macrumors regular

    Joined:
    Aug 27, 2012
    #5
    However, if you don't use the ATV preset, if you select 0 for the first one and choose AAC CoreAudio, and select the 0 again for the second audio track but choose AC3 PassThru, it should give you Stereo and Dolby. That's what I do anyways and it seems to always work.

    I don't ever select the other tracks besides the "0" one as there are most likely Director's Commentaries or something else.
     

Share This Page