Handbrake Detelecine/Decomb; Batman TAS

Discussion in 'Apple TV and Home Theater' started by iOrbit, May 16, 2015.

  1. iOrbit macrumors 6502a

    Joined:
    Mar 8, 2012
    #1
    can anyone help me improve encoding Batman TAS? i've set Decomb and Detelecine to default, and it improves the video almost perfectly. the source is hard telecine. the encoded result almost completely removes it resembling the progressive look (that I'm especially familiar with on the PAL UK release of these volume sets) but I'm using the american ones (because they were released complete) and I'm still getting instances of this:

    [​IMG]

    it happens every now n then during more high speed motion, its sort of distracting and unsatisfying given that I'm familiar with the content without this.

    i've tried changing the frame rate from "same as source" to "23.93 fps NTSC Film" but no difference. should i try 30FPS NTSC Video? i thought of trying custom settings on detelecine or decomb but i have no idea what the range is on the setting (it just offers a box to enter numbers in with no guideline)

    any help would be appreciated!
     
  2. HobeSoundDarryl macrumors 603

    HobeSoundDarryl

    Joined:
    Feb 8, 2004
    Location:
    Hobe Sound, FL (20 miles north of Palm Beach)
    #2
    Don't mess with frame rate (leave it same as source).

    Have you tried Decomb by itself? If not, identify the approx. minute range or chapter within one you've already encoded and experiment with Decomb rendering just that part. There are 4 settings for Decomb. Experiment by trying each of them. This should not take long if you are rendering just the problematic part of one of the videos.

    And are you trying to convert the NTSC versions for playback in PAL?

    Is the source material SD and you're playing it back on an HDTV?

    Do you have a disc player hooked to your TV? If so, when you play the actual disc, does it show the lines in this kind of scene or does it look more like what you seek?
     
  3. iOrbit thread starter macrumors 6502a

    Joined:
    Mar 8, 2012
    #3
    I haven't tried custom Decomb settings, only leave it on Default along with Detelecine.

    Nope, I'm trying to keep it exactly the same as source, i don't like PAL

    the source is SD from DVD

    i'll get back to you on that one, i believe it probably does. it happens in all parts of the video every few moments, it is like this on the disc (the file is like this from the MKV) when i encode with Handbrake with default decomb/detelecine on, it improves greatly and most of it is gone. i wish i just could get the remaining splices here and there.
     
  4. HobeSoundDarryl macrumors 603

    HobeSoundDarryl

    Joined:
    Feb 8, 2004
    Location:
    Hobe Sound, FL (20 miles north of Palm Beach)
    #4
    If I understand you right, you are first taking the Batman discs and using something like MakeMKV to get them into the MKV format. When you play back the MKV, does it have the lines showing too?

    Which Handbrake preset are you using?

    Are you changing the resolution in Handbrake?
     
  5. iOrbit thread starter macrumors 6502a

    Joined:
    Mar 8, 2012
    #5
    it shows on the DVD in playback. and yep its in the original make MKV file, but its constant in the MKV file, after default deteleine/decomb it removes it almost completely, its only in more high motion scenes (like moving smoke, or this fight sequence) that it shows itself.


    im cropping the video in handbrake if that counts? (under auto, its 4:3 image)

    the preset I'm using.. i believe I'm starting from High or Apple TV and customising it some after.
     
  6. HobeSoundDarryl, May 16, 2015
    Last edited: May 16, 2015

    HobeSoundDarryl macrumors 603

    HobeSoundDarryl

    Joined:
    Feb 8, 2004
    Location:
    Hobe Sound, FL (20 miles north of Palm Beach)
    #6
    Best move is to test without your own customizations. Just pick a preset (I suggest AppleTV3 or High Profile) and render a few minutes of the video that typically shows the lines.

    Then try the same few minutes with only Decomb (meaning just turn on Decomb only, nothing else).

    Then try the same few minutes with Decomb's other 3 or 4 settings (again, only this tweak to what will otherwise be the default preset).

    If none of that works, then experiment with only the Deinterlace options. The price of deinterlacing tends to be quality of the result. So hopefully, one of the Decomb options will do the job.

    By adopting only a single (changing) variable, you can rule out a bunch of other possibilities. Once you figure out how to get the render you want, then you can add back in the various customizations (like cropping, etc) that you are trying.

    There appears to be a lot of fan momentum to get this series released on Blu Ray. That may end up being your best option for getting a pristine version for HDTV playback.
     
  7. iOrbit thread starter macrumors 6502a

    Joined:
    Mar 8, 2012
    #7
    thanks so much for your input and help! i'll try this today. would you mind elaborating on the various settings for decomb? i don't have Handbrake in front of me just now, and i can't remember other variations of the setting apart from "Custom" which brings up a white box to enter numbers but i have no idea what the highest and lowest value to enter are.

    i am also one of the fans wishing for a blu ray release, i have to have something in the mean time unfortunately :(

    i had a thought - i could upload the first 2 minute intro segment (from the MKV) and see if others including yourself can experiment with me.

    i believe I'm using an older version of handbrake as well, once i had one that worked fine for me i never upgraded it, i didn't want changes to cause a ripple effect across my conversions.
     
  8. HobeSoundDarryl macrumors 603

    HobeSoundDarryl

    Joined:
    Feb 8, 2004
    Location:
    Hobe Sound, FL (20 miles north of Palm Beach)
    #8
    I can't offer good input based upon an older version of HB. I'm using the latest. In the latest, the decomb choices are custom, default, fast and bob. For my purposes, I usually use Decomb Default for everything but experimenting with your file is the best way to figure this out.

    Unfortunately, I'm not sure the problem is going to fully resolve no matter what you do as HB's primary job is to duplicate the master... and if the master is showing the lines, it's duplicating it well. Yes, Decomb and similar tools may be able to minimize them but you are also trying to go from a SD source to an HD TV screen. Some of my content is SD converted and there are some interlacing artifacts that show here and there.

    I wouldn't be afraid of upgrading to the latest HB. All playback equipment can't tell which version of HB you used for an encode. And HB only gets better and better with newer versions. Now, one of the first things I would do is download the latest version and try a straight encode with a preset like AppleTV3. That might do the job itself.

    The HB website has pretty solid documentation about the picture setting options.
     
  9. iOrbit, May 17, 2015
    Last edited: May 17, 2015

    iOrbit thread starter macrumors 6502a

    Joined:
    Mar 8, 2012
    #9
    i just installed the newest handbrake (but kept the old one as well) and tried the same settings but added a lot of 9's in the custom value for detelecine, and the result is much better! there is still evidence of that frame but the lines have gone! much less distracting. i'm going to test the same setting on the older handbrake to judge if its the setting or the newer handbrake.

    edit**

    it looks like its the new handbrake that deals with it better. thanks for the help HobeSoundDarryl, without your input i probably wouldn't have got to where i have!
     

Share This Page