Handbrake & H.264 - Audio not in sync

Discussion in 'iPod touch' started by aidanpendragon, Sep 17, 2007.

  1. aidanpendragon macrumors 6502a

    Joined:
    Jul 26, 2005
    #1
    Help needed!

    Using Handbrake, I tried converting an hour-long (45 min.) TV show for my Touch. But when I started it up, the video and audio are out of sync! (the audio lags the video by 2-3 seconds).

    Is this a one-time glitch, or something wrong with my settings - before I go to the 4-hr. trouble of running this again?

    Source was a Video_TS on the hard drive (7200 RPM). Encoded using iPhone settings, H.264 (iPod), single-pass, avg. bitrate of 1500kbps. Mac is an eMac 1.42.

    I've run 2-hr. movies with no problems using the Mpeg-4 encoder. Also run shorter programs using H.264, but a lower bitrate (based on MR's 5G iPod guide), with no problems.

    One more question: I assume the advantage of H.264 is that it has smaller file sizes than Mpeg-4 at the same quality & bitrate? Otherwise, don't see why you'd use it.

    Thanks
     
  2. aidanpendragon thread starter macrumors 6502a

    Joined:
    Jul 26, 2005
    #2
    Even though it's NOT a "my screen is crap" thread, perhaps someone can offer advice...
     
  3. wildcardd macrumors 6502a

    Joined:
    Mar 26, 2007
    Location:
    Denver, CO
    #3
    I haven't run into the problem with the newer versions of handbrake. A long time ago (like a couple of years) when the first video pods came out there were some issues.

    I encoded h.264 at a bitrate of 1000kbps just fine. Just curious why do you have your bitrate so high? I drop mine down to 500 for most movies...saves a ton of space and with a small screen it is hardly noticeable.
     
  4. Santoanderson macrumors member

    Joined:
    Sep 15, 2007
    #4
    Hmmm, I haven't been having any audio synching problems with Handbrake, but AVS gave me a scare yesterday. I converted all the Star Wars films to mpeg4, all but Episode III worked perfectly. Why? Because 4 seconds after starting the screen pixelized itself, like a bad DVD read, and started recompressing the video, therefore there was a 4 second synch issue. I'm trying it with Handbrake now. I tried it earlier, under a higher resolution setting, and it crashed, but I'm trying it again under a different size. Hopefully it'll work, if not I may just end up blaming the DVD or optical drive.
     
  5. madmaxmedia macrumors 68030

    Joined:
    Dec 17, 2003
    Location:
    Los Angeles, CA
    #5
    It should've worked fine. You might want to try lowering the video bitrate just to see what happens.

    1500 kbps is sorta overkill for 480 x 320 resolution anyway. I use 500 kbps and am very satisfied with image quality. Try 1000 kbps perhaps...
     
  6. aidanpendragon thread starter macrumors 6502a

    Joined:
    Jul 26, 2005
    #6
    Thanks. I am totally new to this and am trying to go by the outdated MR guide for 5G iPods, and the Handbrake guide/forums. In the latter, they make a big deal about "H.264 bitrates up to 2000kbps are now supported under Quicktime 7.x," and suggested using 1000-1500kbps. I'll try 1000.

    Also, I figured lower (500-600) bitrates might not look as good on Touch/iPhone screens as on the 5G iPods. But it sounds like it looks OK for you?

    Finally, what's the advantage of H.264 again? Is it smaller file sizes at equivalent bitrates? It takes me 4x as long as Mpeg-4 to encode, so there better be some advantage.
     
  7. Sean Dempsey macrumors 68000

    Sean Dempsey

    Joined:
    Aug 7, 2006
    #7
    I used the latest handbrake to rip Star Wars and Indiana Jones last night, took about an hour each?

    I set the width to 480 and the bitrate to 1000, looks perfect, no visual artifacts.

    No idea how to fix the audio sync issues though.... try the settings. Also, what is your computer specs?
     
  8. madmaxmedia macrumors 68030

    Joined:
    Dec 17, 2003
    Location:
    Los Angeles, CA
    #8
    I think the best bitrate is going to vary from person to person. I suggest 500 kbps as a starting point, but I know others have gone lower. 400 kbps was acceptable to me, it just depends on how small you want your files to be.

    I think you did fine by starting with the iPhone preset, it actually puzzled me why they would set the preset with such a high bitrate, when the iPhone (and iPod Touch) don't have a ton of capacity.

    H264 is a new codec which should deliver somewhat better picture quality. One advantage of H264 is that it's as necessary to do 2-pass encoding. With MPEG4/Xvid 2-pass will significantly help image quality, so you should take that into account when comparing image quality and encoding times.

    I do know that H264 encoding in HandBrake is faster on Intel CPU's than G4/G5's. So on an eMac you might end up with better overall results with MPEG4. Just set it to 2-pass, and also check 'Turbo' for the first pass (will help some with time.) Rip 1 or 2 chapters with each method, and compare the results. The good thing is that after you get all this testing out of the way, you can save your settings as your default preset, from then on ripping DVD's is efffortless.
     
  9. aidanpendragon thread starter macrumors 6502a

    Joined:
    Jul 26, 2005
    #9
    Thanks. They actually don't have the iPhone preset that high - I manually cranked it up to 1500 (from the 960 default) - based on what their forums & guide said.

    I have yet to compare file size of an H.264 and 2-pass Mpeg-4 at the same bitrate. I'm basically trying to balance size with quality.

    1-pass Mpeg-4 at 2000 kbps looks great on my Touch (and encoded in real time). But I bet I can get the file size down even if I stick with that. (Why so big? The 5G instructions here at MR said "do 600 for iPod, 2000 for TV" - so I erred on the side of quality for my Touch).
     

Share This Page