Handbrake & judder

Discussion in 'Apple TV and Home Theater' started by shevans, Nov 16, 2009.

  1. shevans macrumors member

    Joined:
    Feb 25, 2007
    Location:
    Herts, UK
    #1
    I Currently using SVN 2907, with UK region 2 PAL DVD's and playing back in the UK.

    I have several DVD's that when ripped have what can only be described as motion/panning judder. This show typically when panning in most directions.
    I have tried using a few settings in the picture settings option on just a couple of chapters but cannot eliminate the judder. Its not stuttering, pausing or freezing.

    I have the same issue with nearly every Region 1 (NTSC) DVD. Playing DVD's directly in a DVD player for both R1&R2 do not exhibit the stutter. Not very well clued up on Handbrake options and the Handbrake forum looked a little scary for me to try so any help here would be appreciated please.
     
  2. dynaflash macrumors 68020

    Joined:
    Mar 27, 2003
  3. shevans thread starter macrumors member

    Joined:
    Feb 25, 2007
    Location:
    Herts, UK
    #3
    I'm using the AppleTV preset (I have run update presets after SVN2907). Tried both the decombe and deinterlace default settings but without any improvement on just one chapter each time to save on time.
     
  4. roidy macrumors 6502a

    Joined:
    Dec 30, 2008
    Location:
    Nottingham, UK
    #4
    For region 1 dvd's try using the detelecine option in handbrake to see if that helps, each dvd is different. As for the region 2 dvd's what resolution and refresh rate is your ATV set to?

    I get the same problem if I set my ATV to any of the 50Hz modes.
     
  5. shevans thread starter macrumors member

    Joined:
    Feb 25, 2007
    Location:
    Herts, UK
    #5
    Many Thanks, switching to 720pHD gets rid of the Region 2 DVD stutter, this is still very slight stutter on Region 1 DVD's so I shall re-encode a few more clips and try again. It makes sense getting this fault if the TV is running in the incorrect mode.
     
  6. roidy macrumors 6502a

    Joined:
    Dec 30, 2008
    Location:
    Nottingham, UK
    #6
    No problem, Region 1 dvd's can be a bit funny some need the detelecine option while others don't, it's a case of just encoding a small sample chapter and seeing.
     
  7. dynaflash macrumors 68020

    Joined:
    Mar 27, 2003
    #7
    also, check and see that weightb=0 is in you're advanced options. The atv had some panning issues with weightb.
     
  8. roidy macrumors 6502a

    Joined:
    Dec 30, 2008
    Location:
    Nottingham, UK
    #8
    Yep, worth a try. I never use weighted-b frames because for some reason it always causes corruption in fast moving scenes.
     
  9. shevans thread starter macrumors member

    Joined:
    Feb 25, 2007
    Location:
    Herts, UK
    #9
    Many thanks for all the tips, So far I found that if I use the 720p 50hz setting AND encode using detelecine for all region DVD's I get very smooth panning. Not sure if I should use detelecine all the time but it certainly makes a difference.

    The most import thing I realised is to NEVER EVER preview a test rip on the Mac, go downstairs and view it on the TV :eek:
     
  10. dynaflash macrumors 68020

    Joined:
    Mar 27, 2003
    #10
    Detelecine + Same as source for framerate will give you a true variable framerate from the source. no dropped frames or dupes. Make it you're default.

    Very true, the atv and you're Mac are two totally different animals.
     
  11. shevans thread starter macrumors member

    Joined:
    Feb 25, 2007
    Location:
    Herts, UK
    #11
    Thank you very much, I shall work out how to add this to the AppleTV preset.
     
  12. dynaflash macrumors 68020

    Joined:
    Mar 27, 2003
    #12
    Should just be able to pick the appletv preset, then choose detelecine in filters and then add it as a new preset. On the mac click the plus button at the bottom of the preset drawer and then use Source max for picture sizing and use video filters (detelecine being considered a filter).
     
  13. shevans thread starter macrumors member

    Joined:
    Feb 25, 2007
    Location:
    Herts, UK
    #13
    Thank you, sorted.... for the moment ;)
     
  14. Feek macrumors member

    Feek

    Joined:
    Nov 9, 2009
    #14
    This is a thread I was going to post myself.

    I'm ripping all my Star Trek DVDs for my AppleTV, I've got a custom preset based on the AppleTV one but I get the same issue, although it's only really on external scenes such as the starting credits. For example, on the TNG opening credits as the Enterprise approaches, it judders quite badly and then smooths out as it gets really close, then judders its way away.

    These are R2 DVDs I own (I'm in the UK).

    I've got the fps set to same as source, I'm using a target size but the problem is the deinterlacing. If I run with no deinterlace then I don't get the jerkyness but if I have it on then I get the jerking and it's really annoying me. I've tried all three deinterlace settings and also no specific deinterlace but decomb on the default and it still happens.

    I'm getting quite annoyed by it, I want to get all my DVDs into iTunes/AppleTV and this isn't helping my mission. I've already done TOS and that was fine.
     
  15. doctor-frog macrumors newbie

    Joined:
    Jun 18, 2009
    #15
    Feek ... or anyone else ... have you got anywhere with this yet?

    You have just described exactly what my problem is with R2 ST:TNG DVDs.

    Using "Haven" (Disc 3, series 1) as my test subject with Handbrake 0.9.4, I have noticed juddering no matter what mode of de-interlacing, de-combing, or de-telecine-ing I use. I've tried ripping to same framerate, static framerates, etc. No joy.

    I'm using "Universal" settings and currently ripping much of my DVD collection in anticipation of the AppleTV that should be arriving with Father Christmas. My movies haven't presented much of a problem (out of dozens, I got only one that wanted de-telecine-ing).

    I've noticed in my test episode that not all scenes seem interlaced to begin with. But some do ... and that's not just the graphics, but sometimes the live-action scenes as well. (I hear that ST:V filmed different framerates for the CGI bits and for the live action and did all sorts of weird things with interlacing and telecine-ing; but I don't know how that applies to the other series.)

    Anyway, if anyone has managed to solve the settings, I'd love to know about it.
     
  16. shevans thread starter macrumors member

    Joined:
    Feb 25, 2007
    Location:
    Herts, UK
    #16
    A few of my DVD's still had judder, so I bought a Blu-ray player!

    Now I can sleep a night knowing they playback perfectly :D
     
  17. doctor-frog macrumors newbie

    Joined:
    Jun 18, 2009
    #17
    not quiiite the answer I was looking for, but well done you, all the same.
    ;)
     
  18. shevans thread starter macrumors member

    Joined:
    Feb 25, 2007
    Location:
    Herts, UK
    #18
    I just re-read your post, you won't be able to tell until you playback on the Apple TV, something I keep forgetting. Also set the Apple TV's resolution to 720p (not the frequency versions), which I found made a big difference. They still looked pap on the Mac, but considerably better on the Apple TV.

    You should also try and use the Apple TV preset.
     
  19. doctor-frog macrumors newbie

    Joined:
    Jun 18, 2009
    #19
    Ok, noted. 720p. I'll hang fire on the Star Treks till I get the Apple TV up and running. I can wait.

    None of my DVDs have caused the same problem, yet, except for one non-essential film. At least, not so far as I can tell.

    Regarding the ATV pre-sets: if I rip movies to ATV pre-set, will that cause any problems if I want to load some of them onto my iPod Touch or iPhone? I just assumed that Apple Universal would be the most useful and ... errm ... universal ... option but, given some of the issues I've come across today trying to research the ST:TNG issue, I'm not so sure now.
     
  20. shevans thread starter macrumors member

    Joined:
    Feb 25, 2007
    Location:
    Herts, UK
    #20
    We have both ipods and a Touch in our household, we found that creating additional copies using the correct preset for each device is not that much work.

    The Ipod/touch/phone presets convert at a much faster frame rate, on my old iMac (1.83Ghz) we never had a movie take longer than 40 minutes. Takes another 30 secs to add to the queue.

    The file size is a lot smaller so saves space on the device and also syncs faster. We have user profiles on the iMac so the correct files are loaded in iTunes for the corresponding user/device. There is probably a "correct/better" way to do this but it works!
     
  21. dynaflash macrumors 68020

    Joined:
    Mar 27, 2003
    #21
    Er, more universal than the "Universal" preset ? I think not.

    However, if you have the very latest iPhone/iPod touch (3GS and 3G respectively) the AppleTV preset will play on all of them ( note: iPod Touch 2G need not apply). The AppleTV preset will be the same quality at a lower file size and bitrate than the Universal preset as the atv can handle bframes primarily which are much smaller than I or P frames.
     
  22. doctor-frog macrumors newbie

    Joined:
    Jun 18, 2009
    #22
    following on from that, I've tried a little experiment and discovered that, actually, neither the Universal and Apple TV presets for 0.9.4 will transfer to the iPod Touch. Only the iPod Touch & iPhone preset will. This was not true of the 0.9.3 universal, which happily went there.

    Guess that solves that little query. ATV preset it is ... for the ATV, at least!
    --
    edit. Was writing this whilst the last post was posted. I have an iPod Touch 2G (but an iPhone 3GS). That explains that, then. I was testing with the 2G.

    But, then, that does leave the question wide open: what's with calling it "universal" if it just ain't so?
     
  23. dynaflash macrumors 68020

    Joined:
    Mar 27, 2003
    #23
    Um, I must have 20 movies on my 2g iPod touch made with the 0.9.4 HB Universal preset < confused > .
     
  24. doctor-frog macrumors newbie

    Joined:
    Jun 18, 2009
    #24
    in which case, I am equally confused.
    --
    edit: iPod seems to have changed its mind now and is accepting Universals.
    Go figure.
     
  25. Feek macrumors member

    Feek

    Joined:
    Nov 9, 2009
    #25
    Right, sorry this has taken a while to answer but I've had other things on my mind.

    I've got a reasonable configuration within Handbrake 0.9.4 x86_64 that seems to have minimal juddering and no interlacing on the R2 ST:TNG DVDs.

    I selected the default AppleTV preset, changed the quality to a Constant quality of 65.69% RF: 17.5

    In audio settings, removed Track 2 (set it to 'none')

    In picture settings, set deinterlace to 'slow' and Anamorphic to 'Strict'

    Give that a try and see how it works for you.
     

Share This Page