Handbrake problem with my new MacBookPro

Discussion in 'Mac Apps and Mac App Store' started by pspmanny, Feb 17, 2009.

  1. pspmanny macrumors newbie

    Joined:
    Feb 17, 2009
    #1
    I just got a mac book pro and i transferred all my aplications from my old g4 but handbrake doesn't work the same or doesn't at all. It takes very long to scan and it doesn't let me rip. I tried the same dvd on my old g4 and it worked just fine so it's not the dvd. can some one please help.
     
  2. Mr. Owl macrumors newbie

    Mr. Owl

    Joined:
    Feb 17, 2009
    #2

    The one you transferred from the G4 is most likely the PPC version; it won't run well at all on the MBP. Download the Intel version here:

    http://handbrake.fr/?article=download
     
  3. pspmanny thread starter macrumors newbie

    Joined:
    Feb 17, 2009
    #3
    I'm sorry I forgot to mention that i also removed and reinstalled handbrake with the newer version but it still doesn't help
     
  4. tropic10 macrumors member

    Joined:
    Sep 8, 2008
    #4
    Install the latest version of VLC. It's required if you want to decrypt DVD's with Handbrake 0.9.3. Handbrake no longer has built in decryption.
     
  5. pspmanny thread starter macrumors newbie

    Joined:
    Feb 17, 2009
    #5
    I installed the latest version of vlc 0.9.8 but i'm still having the same problem it takes forever to scan.
     
  6. Mr. Owl macrumors newbie

    Mr. Owl

    Joined:
    Feb 17, 2009
    #6
    What else have you already done to try to fix things so far? Restart? Repair permissions? Run the daily/weekly/monthly CRON scripts?

    If you say what you've already done, it will help out; no one will have to suggest you do them again.

    More info than is strictly relevant is better than not enough info when troubleshooting. :)
     
  7. pspmanny thread starter macrumors newbie

    Joined:
    Feb 17, 2009
    #7
    The vlc download fixed the decoding part (so thank you for that) but it still taking about 15-20 minutes to scan when on my g4 it only took 2-3 minutes. I'm still wondering what the problem could be?
     
  8. tropic10 macrumors member

    Joined:
    Sep 8, 2008
    #8
    I would go to the Handbrake forums and post an activity log so they can look at it.
     
  9. pspmanny thread starter macrumors newbie

    Joined:
    Feb 17, 2009
    #9
    I logged in as a different user under a different account on the same computer and handbrake worked just fine, so i'm wondering what kind of settings or better yet what's going on with my account that handbrake doesn't work? please help
     
  10. FSMBP macrumors 68020

    FSMBP

    Joined:
    Jan 22, 2009
    #10
    If it works better on a different account on the same computer, you need to delete the Preference file on the account that it doesn't work fast on.

    To do that:

    1. Go to your HOME folder (the Folder is named after your user account)
    2. Go to LIBRARY
    3. Go to PREFERENCES
    4. Find the file named COM.HANDBRAKE (or some close variation)
    5. Delete that file

    Now, try to use Handbrake again and see if it works. If not, repeat the instructions I posted but do it for VLC preference file.
     
  11. pspmanny thread starter macrumors newbie

    Joined:
    Feb 17, 2009
    #11
    So I called applecare because its a new computer, they told me the same thing to delete the preference file, but it didn't work, so we decided it would be best to create a new user account which wiped out all my files, but i still have my old g4 and i have transfered my files/folders individually without using migration assistant.

    So i have handbrake working well and I'm happy so thanks everybody.:)
     
  12. ScoutsOut327 macrumors newbie

    Joined:
    Jun 28, 2009
    Location:
    Arroyo Grande CA
    #12
    Same problem as pspmanny handbrake wont work

    i have tried all but what pspmanny did which is change accts, i know that it works because i got my wife a new MBA and i just downloaded a fresh copy instead of any migration and it works on her computer.

    has anyone else had this problem that was successful besides pspmanny's approach
     
  13. digitalnomad macrumors newbie

    Joined:
    Oct 28, 2008
    #13
    Check Region on new computer's DVD drive

    I was having a similar problem where Handbrake would hang on "Scanning title 1 of x" and would never show any progress on the progress bar. I just bought this new MacBook Pro 17" Unibody last week so I decided to try playing the DVD to see if the drive would work for that. I launched the "DVD Player" app built into Mac OS X Leopard and this window popped up telling me my DVD drive was set for Region 6 (Asia) so I changed it to Region 1 for the USA and now Handbrake is scanning like the good old days!
     

    Attached Files:

  14. jabbott macrumors 6502

    Joined:
    Nov 23, 2009
    #14
    I finally figured this problem out. It has to do with permissions of all things! Right click on the folder that HandBrake is set to write to and choose "Get Info". Then at the bottom you should see "Sharing & Permissions". Click on the triangle next to that text if there is nothing displayed beneath that text. Then click the lock, enter in your password, then see if Administrators or your username are listed. If not, click the "+" and select Administrators or your username from the window that pops up. Then in the "Get Info" window, click on all of the names at the bottom until it shows the one you just selected from the other window. Change the "Privilege" to "Read & Write", then click on the gear and select "Apply to enclosed items". Click that you are sure, and then close the "Get Info" window. Then try HandBrake again on that folder and see if it works.
     
  15. Soulflower macrumors regular

    Soulflower

    Joined:
    Jul 17, 2011
    #15
    I have a new Macbook Pro Retina and have been trying to get Handbrake to work but have not been successful.

    When I open Handbrake and select the source, I immediately get this message:

    HandBrake could not find a compatible version of libdvdcss (32-bit libdvdcss is not compatible with 64-bit HandBrake and vice-versa).

    I've tried old and new versions of Handbrake and VLC. I've tried deleting the files in the library, rebooting and starting over

    Doe anyone have suggestions?
     
  16. mic j macrumors 68030

    Joined:
    Mar 15, 2012
    #16
    VLC no longer supplies the library files for decryption. The have to be downloaded directly.

    Link: https://forum.handbrake.fr/viewtopic.php?f=5&t=23301
     

Share This Page