(Handbrake) Subtitles on ATV3 - what am I doing wrong?

Discussion in 'Apple TV and Home Theater' started by pullman, Nov 7, 2014.

  1. pullman macrumors 6502

    pullman

    Joined:
    Feb 11, 2008
    Location:
    '(,,,,)°l°
    #1
    I have ripped a DVD (the Danish-Swedish "Bridge" series) using HB's ATV3 preset and would like to have subtitles. It doesn't matter if I can turn them off or if they're always present. But I can't get it to work.

    The only thing I changed in the preset was under the Subtitles tab. I changed the Track from <none> to "0-Swedish (Bitmap) (VOBSUB)" and ticked "Forced Only". "Burned In" was ticked by default and I didn't untick it.

    But there are no subtitles on ATV3 and also, if I hold down the centre button, the Subtitles, Audio and Speakers tabs are greyed out; I can only change the chapters. I've tried changing the Subtitle language in Settings - Audio & Video to various settings, including Off, Auto and several different languages, all without improvement.

    When I try in VLC, the menu item Subtitles - Subtitle Track is greyed out. In Quicktime subtitles also don't work.

    Any ideas?
    Many TIA
    Philip
     
  2. Penquin79 macrumors member

    Joined:
    Jan 22, 2011
    #2
    Sub-titles

    Do not check forced only. Forced only is for situations where most of the movie is in English and subtitles are limited to those instances where it is a foreign language and pop in when watching in a DVD player. Also I think you really want to use the English track, otherwise the subtitles will be in a foreign language.
     
  3. pullman thread starter macrumors 6502

    pullman

    Joined:
    Feb 11, 2008
    Location:
    '(,,,,)°l°
    #3
    Thanks for the quick reply and the explanation. Very helpful. I will try when I am back at my desktop.
     
  4. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #4
    Also, if you burn the subs in (that's btw the only option with the DVD subs, because they are bitmaps, not text), you won't see them in aTV UI. In that menu you will see soft subtitle tracks that are muxed into MP4 files.
    You can do that e.g. with MKV sources, that have text-based sub tracks. These HandBrake can mux into MP4 stream as text sub tracks and you can turn them off or on as you will in aTV UI.
    If you burn subs in, they will become part of the picture and be on screen forever.
    You can find good explanations about these 2 approaches here:
    http://www.bitfield.se/isubtitle/about_subtitles.html
    http://www.bitfield.se/submerge/index.html
     
  5. pullman thread starter macrumors 6502

    pullman

    Joined:
    Feb 11, 2008
    Location:
    '(,,,,)°l°
    #5
    Thanks very much also for that explanation.

    I unticked Forced only and now all is well.
     
  6. ra108 macrumors newbie

    Joined:
    Mar 31, 2009
    #6
    I used Handbrake on an Arabic movie and I want subtitles for the entire movie. I have tried different combinations with Forced Only and Burned Checked that didn't work. I tried with just default that didn't work. Not sure what to select to get the English subtitles throughout the movie. Any help would be appreciated. Thanks.
     
  7. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #7
    First of all - does your source even contain full subtitles?
    If not, then you shall find and download them on the net. Then add the subtitle file to HandBrake.
    Personally, I still prefer the muxed "soft" subs, as they can be made to appear and disappear on screen at will. If you turn them on on aTV menu, they will stay on for the entire movie.
    I also use http://subtitleseeker.com the most to find subs, as it consolidates availability across most sites and groups subs by languages. So you have instant overview about the availability of subs in your preferred language(s).
     
  8. ra108 macrumors newbie

    Joined:
    Mar 31, 2009
    #8
    Yes when I click on subtitles I have the following in the drop down box
    None
    Foreign Audio Search - (Bitmap)(VOBSUB)
    0 - English - (Bitmap)(VOBSUB)
    1 - English (Closed Caption) - (Bitmap)(VOBSUB)
    2 - Francais - (Bitmap)(VOBSUB)

    I can't figure out what the difference is between option 0 and 1. I can try both to see what works . But what should be checked? Forced Only Burned In Default ?

    Thanks.
     
  9. Darby67 macrumors 6502

    Joined:
    Jul 5, 2011
    Location:
    the corner of Fire and Brimstone
    #9
    If you want english subs to always show, click English (option 0 in this case) and burned in.
     
  10. ra108 macrumors newbie

    Joined:
    Mar 31, 2009
  11. Darby67 macrumors 6502

    Joined:
    Jul 5, 2011
    Location:
    the corner of Fire and Brimstone
  12. cynics macrumors G3

    Joined:
    Jan 8, 2012
    #12
    Since this seems resolved by a group of people well versed in this subject maybe I can pick your brains.

    I'm trying to get subtitles on a certain DVD I own just for foreign language parts. From the bit of research I did I found in HB you want to do "Foreign Audio Search" under Subtitles and it will pretty much do the rest "Forced only, burned in etc etc".

    However that didnt work.

    So then I tried to redo it with English selected and forced only and burned in turned on. Then with burned in turned off.

    Regardless of what I try I never get subtitles in the foreign language part of the movie. It doesn't display on the Mac via quicktime or ATV3.

    I checked and the DVD does put subtitles on the screen during those parts so they are there. And I have used HB to burn in subtitles for a couple foreign movies I own before and after trying this particular title.

    What am I doing wrong? Thanks in advance guys.
     
  13. Darby67, Nov 15, 2014
    Last edited: Nov 15, 2014

    Darby67 macrumors 6502

    Joined:
    Jul 5, 2011
    Location:
    the corner of Fire and Brimstone
    #13
    I have never figured out Foreign Audio Search option and usually just ignore it.

    You should see two tracks of English, one that is full time subs and one that has a flag that your DVD player sees as forced subs. My workflow consists of ripping with MakeMKV, it does a great job and is very easy most of the time, and then potentially process further with HB.

    MakeMKV will save the file in MKV format which is basically just a wrapper of the original file which many media players can play but not Quicktime or iTunes. You would need to process further with HB to put it in a file format that QT or iTunes can play. Plex, VLC and many others support MKV.

    With MakeMKV the second English track is the forced track and will only be in seen in HB if it exists: MakeMKV may say there are two English subs but HB might show two or one if there isn't actually any forced sub. As I don't rip with HB I am not certain how it would appear. There is occasionally some guesswork here, but if there are two sub files, the second is the one I burn in; if there is one that is almost always it. I use Plex as my media player of choice and I continue to use the Burned In option as I don't believe they have adopted the Forced Only flag that would be set nor the Default.

    My apologies if I have repeated info that you may already be versed in, I hope this helps a bit.
     

Share This Page