Handbrake won't convert MOV to MP4 - one particular file

Discussion in 'Digital Video' started by Stuckster, Feb 23, 2012.

  1. Stuckster, Feb 23, 2012
    Last edited: Feb 23, 2012

    Stuckster macrumors newbie

    Joined:
    Apr 28, 2011
    #1
    Hi all,

    Literally been pulling my hair out over this issue. Spent HOURS researching and testing a fix for this but to no avail. So it's finally time to actually ask for some help.

    --BACKGROUND--
    I'm editing HDV 1080i50 video in FCP 7. Output to a HDV 1080i50 1440 x 1080 master as a self contained mov. This will then be converted to mp4, deinterlaced and downsized for use on the web. (note: not using ProRes because Handbrake doesn't seem to like it).

    After testing various converters using a sample .mov from my master (Handbrake, MPEG Streamclip, Compressor, Quicktime Pro, Visual Hub) I have settled on Handbrake because it is delivering the best quality and speed for my purposes. MPEG Streamclip came second with Compressor 3 easily the worst of the bunch on both speed and quality.

    --ISSUE--
    Handbrake is now having an issue with my master mov file. No matter what I try it simply won't start the conversion. After setting everything up I click on start and nothing happens. I can't even add it to the queue. The activity window simply says "macgui: Rip: Pending queue count is 0". If I hit start again it simply repeats "macgui: Rip: Pending queue count is 0". (Full activity log posted in next post.)

    After so many hours testing and crafting a nice workflow it is EXTREMELY frustrating to be faulting at the very last step. Aarrgh!

    --OTHER INFO--
    My master mov file is 1.5 hours duration and 18GB file size.

    --TESTS ALREADY RUN--
    - Completely deleting Handbrake and reinstalling latest version. No change.
    - Changing the .mov extension to .mp4 and .m4v.
    - Changing the source and destination locations.
    - Shortening the video file name.
    - Using a Quicktime reference file as the master instead of self contained.
    - Converting another .mov file of the same format (HDV 1080i50) and larger size (100GB). This file worked just fine.
    - All other Handbrake presets. None want to work with this file.
    - Changing security preferences on my master file.
    - Re-rendering and outputting a completely new master .mov file.


    I would consider using MPEG Streamclip as option B, but strangely it is also having issues with the same master file (green vertical lines overlaid on the video, completely new and separate issue which I will troubleshoot next if all else fails with Handbrake).

    As you can see I'm getting pretty desperate. Would really appreciate any help.

    thanks
    Andrew

    2010 iMac i7, OSX 10.6.8, Handbrake 0.9.5, FCP 7, QT Pro 7.6.9

    ----------

    Handbrake log

    [12:59:01] macgui: trying to open video_ts folder (parent directory chosen)
    [12:59:01] macgui: Preview: Disabling HUD Controls
    [12:59:01] macgui: Minimum length of title for scan: 900000
    [12:59:01] hb_scan: path=/Volumes/MYBOOK 2/Video Masters/Workshops/2011 Adv Workshop/AWP4_HDV_1080i.mov, title_index=0
    libbluray/bdnav/index_parse.c:157: indx_parse(): error opening /Volumes/MYBOOK 2/Video Masters/Workshops/2011 Adv Workshop/AWP4_HDV_1080i.mov/BDMV/index.bdmv
    libbluray/bluray.c:960: nav_get_title_list(/Volumes/MYBOOK 2/Video Masters/Workshops/2011 Adv Workshop/AWP4_HDV_1080i.mov) failed (0x103008800)
    [12:59:01] bd: not a bd - trying as a stream/file instead
    libdvdnav: Using dvdnav version 4.1.3
    libdvdread: Encrypted DVD support unavailable.
    libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.IFO failed
    libdvdnav:DVDOpenFileUDF:UDFFindFile /VIDEO_TS/VIDEO_TS.BUP failed
    libdvdread: Can't open file VIDEO_TS.IFO.
    libdvdnav: vm: failed to read VIDEO_TS.IFO
    [12:59:02] dvd: not a dvd - trying as a stream/file instead
    Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/Volumes/MYBOOK 2/Video Masters/Workshops/2011 Adv Workshop/AWP4_HDV_1080i.mov':
    Metadata:
    major_brand : qt
    minor_version : 537199360
    compatible_brands: qt
    Duration: 01:32:36.88, start: 0.000000, bitrate: 26546 kb/s
    Chapter #0.0: start 33.320000, end 36.640000
    Metadata:
    Chapter #0.1: start 36.640000, end 37.400000
    Metadata:
    Chapter #0.2: start 37.400000, end 515.160000
    Metadata:
    Chapter #0.3: start 515.160000, end 953.400000
    Metadata:
    Chapter #0.4: start 953.400000, end 1026.080000
    Metadata:
    Chapter #0.5: start 1026.080000, end 1132.120000
    Metadata:
    Chapter #0.6: start 1132.120000, end 1634.080000
    Metadata:
    Chapter #0.7: start 1634.080000, end 2053.040000
    Metadata:
    Chapter #0.8: start 2053.040000, end 3124.560000
    Metadata:
    Chapter #0.9: start 3124.560000, end 3695.720000
    Metadata:
    Chapter #0.10: start 3695.720000, end 4022.400000
    Metadata:
    Chapter #0.11: start 4022.400000, end 5163.200000
    Metadata:
    Chapter #0.12: start 5163.200000, end 5163.240000
    Metadata:
    Chapter #0.13: start 5163.240000, end 5384.600000
    Metadata:
    Chapter #0.14: start 5384.600000, end 5523.480000
    Metadata:
    Stream #0.0(eng): Video: mpeg2video, yuv420p, 1440x1080 [PAR 4:3 DAR 16:9], 25000 kb/s, 25 fps, 25 tbr, 25 tbn, 50 tbc
    Stream #0.1(eng): Audio: pcm_s16le, 48000 Hz, 2 channels, s16, 1536 kb/s
    Stream #0.2(eng): Data: tmcd / 0x64636D74
    Stream #0.3(eng): Subtitle: text / 0x74786574
    [12:59:02] scan: decoding previews for title 1
    [12:59:03] scan: 10 previews, 1440x1080, 25.000 fps, autocrop = 0/0/0/0, aspect 16:9, PAR 4:3
    [12:59:03] scan: title (0) job->width:768, job->height:432
    [12:59:03] libhb: scan thread found 1 valid title(s)
    [12:59:04] macgui: showNewScan: This is a new source item scan
    [12:59:04] macgui: Preview: Enabling HUD Controls
    [12:59:51] macgui: Rip: Pending queue count is 0
    [13:00:12] macgui: Rip: Pending queue count is 0
    [13:00:12] macgui: Rip: Pending queue count is 0
    [13:00:12] macgui: Rip: Pending queue count is 0
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    In order to find out, what may be wrong with your video, you can use the following three applications to analyse a sample of video files.
    When done, you can use the "Report" (VideoSpec) and "Export" (Media Inspector) button to export a report,
    attachable to your next post via the [​IMG] button.
    In MediaInfo you have to go to the Menu Bar, select View > Text and copy the text via CMD+A > CMD+C and paste it via CMD+V into your next post.
     
  3. Stuckster thread starter macrumors newbie

    Joined:
    Apr 28, 2011
    #3
    Hey simsaladimbamba,

    Thanks for those apps. Very handy little tools to add to the collection! :cool:

    Reports for my master .mov file attached. :)
     

    Attached Files:

  4. Ritsuka macrumors 6502a

    Joined:
    Sep 3, 2006
    #4
    You should try to export the mov from Final Cut without the chapters markers. Handbrake sometimes has issues with them.
     
  5. cgbier macrumors 6502a

    Joined:
    Jun 6, 2011
    #5
    Stuckster, you know that you can integrate x264 into Compressor? The quality is better than with the standard Apple h.264 encoder. If you set up Qmaster correctly, Compressor will be about as fast as Handbrake.
     
  6. Stuckster thread starter macrumors newbie

    Joined:
    Apr 28, 2011
    #6
    I've tired Compressor running in a virtual cluster (4 cores) on my 2010 i7 iMac, and even then I've found it no where near as fast as Handbrake, MPEG Streamclip, ffmpeg, etc. Not even close. What these programs can churn through in 2 hours, compressor will only be 10% done and estimating another 130 hours!!

    It's not hard to choose between these workflows when you're pushed for time. ;)

    ----------

    So I tried the x264 codec in QT and I wasn't overly impressed. :eek:
    Not sure if QT does something to it or maybe I didn't have it fully optimised. Either way I was very surprised because its known to be such a great codec.

    However I then tried x264 with MPEG Streamclip and got some excellent results, on par with Handbrake!! :D
    (Very strange that QT could not deliver similar results with the same codec).

    So it now seems that I have a viable workaround. What's even better is that unlike Handbrake, MPEG SC will handle AIC formats like ProRez, which is excellent.

    Thanks all for your help.
    I'll churn my master through and see how it goes.

    cheers
    Andrew
     
  7. Sedulous macrumors 68000

    Sedulous

    Joined:
    Dec 10, 2002
    #8
    Consider trying a nightly build of handbrake. I've had problems sort of like this and for whatever reason, the newer nightly build worked where the current handbrake version (0.9.5 or whatever) failed after initiating the conversion.

    http://build.handbrake.fr/
     
  8. Stuckster thread starter macrumors newbie

    Joined:
    Apr 28, 2011
    #9
  9. Stuckster thread starter macrumors newbie

    Joined:
    Apr 28, 2011
    #10
    SOLVED! :D
    --------------
    Sedulous, you're an absolute LEGEND. Thank you so much.

    The latest nightly build of Handbrake not only manages to encode my master file, it also supports ProRes formatted files :).

    Now all that is left is to compare the ProRes x264 encodes from Handbrake with the ones from MPEG Streamclip. Should be pretty close I imagine.

    I can't believe how valuable these forums are. Thanks heaps guys.
     
  10. Sedulous macrumors 68000

    Sedulous

    Joined:
    Dec 10, 2002
    #11
    Cool beans. Thanks to the wonderful Handbrake devs.
     

Share This Page