Handbranke not encoding full length of movie

Discussion in 'Apple TV and Home Theater' started by Ctrice, Aug 26, 2011.

  1. Ctrice macrumors newbie

    Nov 4, 2007
    This happens to me from time, it is very rare though. I'll rip a movie with MTR and then when I encode it, the last few minutes of the film will be missing. Lets say the movie is 1h57m, the final outputted file will only be 1h53m.

    Has this ever happened to anyone? Is there any way to fix this?
  2. CylonGlitch macrumors 68030


    Jul 7, 2009
    This has happened to me when the studio has put multiple "copies" on the disc in an attempt to get people frustrated and not rip them. True Grit did this; there was 50+ different "versions" of the movie and only ONE that played all the way to the end. When you get the info on the disc it says that every title is the same length, thus Handbrake just pulls the first one, which is wrong.

    Load the disc in DVDPlayer and look at the title # that is shown when the movie is playing, that will be the title# you need to rip.
  3. xraydoc macrumors 604


    Oct 9, 2005
    Could also be a MTR issue. Try RipIt and see if you get the same result.
  4. obsidian1200 macrumors 6502


    Jun 19, 2010
    Albuquerque, NM
    I've had similar issues with MTR in the past. I loaded the disc in DVDplayer, and it turns out the disc was corrupted in that section that handbrake either dropped or otherwise messed up on. So, it could be possible that you have the bad luck of trying to rip a damaged enough disc. You could even open the resulting VIDEO_TS folder with DVDplayer or VLC and check the end of the movie to see if it's the complete film. The error may not be on handbrake in this case.

    Have you tried encoding the movie directly from the disc? Make sure that, if it's one of those discs with 99 titles on it, that you have the right title selected, as has already been mentioned.
  5. Ctrice thread starter macrumors newbie

    Nov 4, 2007
    Thanks for the reply guys. I even tried ripping directly from the DVD, and even just ripping the main title from the disc. I even tried using DVDFab and still no luck. Could it just be because the DVD is corrupt, perhaps?



  6. slothrob macrumors 6502

    Jun 12, 2007
    In DVDFab, it looks like you have selected Merge, instead of Full Disk or Main Movie.
  7. rumin macrumors newbie

    Feb 19, 2013
    Multiple Movies Not Copying Full

    I'm downloading from DVD to HD. Then using Handbrake to convert to MP4. I'm copying a course I'm taking so I can watch them fast on VLC and to make a backup. With the whole VIDEO_TS file downloaded I use Handbrake to change over. For some reason it stopped copying the whole movie. Out of ave size of 500 MB for 1.3 hours I'm only getting 120 MB and its cut off randomly. First 4 movies no problem. Last 3 same problem. ALL chapters are checked so that's NOT the problem. Nothing changed. Computer restarted. Same problem. I even downloaded Mac the Ripper. Ripped from DVD and SAME problem. PLEASE help!!!!!!!!!

Share This Page